[PATCH]: gnu: Add lowdown.

  • Done
  • quality assurance status badge
Details
3 participants
  • Zhu Zihao
  • Liliana Marie Prikler
  • phodina
Owner
unassigned
Submitted by
Zhu Zihao
Severity
normal
Z
Z
Zhu Zihao wrote on 7 Jun 2021 14:22
(address . guix-patches@gnu.org)
86czsxamoz.fsf@163.com
--
Retrieve my PGP public key:

gpg --recv-keys D47A9C8B2AE3905B563D9135BE42B352A9F6821F

Zihao
-----BEGIN PGP SIGNATURE-----

iIsEARYIADMWIQTUepyLKuOQW1Y9kTW+QrNSqfaCHwUCYL4PnBUcYWxsX2J1dF9s
YXN0QDE2My5jb20ACgkQvkKzUqn2gh/N4wD/TXYqvYCUAfD1mfI03cvSS2acdJCz
jd0EcKwpVFnZNKoA+QGSH7syrf9VUb9UjxMnPKV+1B1OWtkjEztrpEsIILUC
=6Tbn
-----END PGP SIGNATURE-----

From 15feae91f6192f22d519968c9849de512eaaf525 Mon Sep 17 00:00:00 2001
From: Zhu Zihao <all_but_last@163.com>
Date: Mon, 7 Jun 2021 20:17:22 +0800
Subject: [PATCH] gnu: Add lowdown.

* gnu/packages/markup.scm(lowdown): New variable.
---
gnu/packages/markup.scm | 30 ++++++++++++++++++++++++++++++
1 file changed, 30 insertions(+)

Toggle diff (43 lines)
diff --git a/gnu/packages/markup.scm b/gnu/packages/markup.scm
index 368976bfde..0a643809aa 100644
--- a/gnu/packages/markup.scm
+++ b/gnu/packages/markup.scm
@@ -114,6 +114,36 @@ convert it to structurally valid XHTML (or HTML).")
(license (non-copyleft "file://License.text"
"See License.text in the distribution."))))
+(define-public lowdown
+ (package
+ (name "lowdown")
+ (version "0.8.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://kristaps.bsd.lv/lowdown/snapshots/lowdown-"
+ version ".tar.gz"))
+ (sha256
+ (base32 "1f6lpyz5bbvwqadal8xcfjcm46zcycrgk5079isjyipg85zdyvb2"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ;No test
+ #:phases
+ (modify-phases %standard-phases
+ (replace 'configure
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ (invoke "./configure"
+ (string-append "PREFIX=" out)
+ (string-append "MANDIR=" out "/share/man"))))))))
+ (native-inputs
+ `(("which" ,which)))
+ (home-page "https://kristaps.bsd.lv/lowdown")
+ (synopsis "Simple Markdown translator")
+ (description "Lowdown is a Markdown translator producing HTML5,
+roff documents in the ms and man formats, LaTeX, gemini, and terminal output.")
+ (license license:isc)))
+
(define-public discount
(package
(name "discount")
--
2.31.1
Z
Z
Zhu Zihao wrote on 6 Jul 2021 05:05
Re: bug#48899: Acknowledgement ([PATCH]: gnu: Add lowdown.)
(address . 48899@debbugs.gnu.org)
86wnq4b0rf.fsf@163.com
ping.
--
Retrieve my PGP public key:

gpg --recv-keys D47A9C8B2AE3905B563D9135BE42B352A9F6821F

Zihao
-----BEGIN PGP SIGNATURE-----

iIsEARYIADMWIQTUepyLKuOQW1Y9kTW+QrNSqfaCHwUCYOPIZBUcYWxsX2J1dF9s
YXN0QDE2My5jb20ACgkQvkKzUqn2gh+27QEA47AyAzCM6TWcXug7kBdRLiAbqeVj
JnWfAH0ZnouEVaABAJCC47DMd5B/cn2UKxzARVbiq0vv1T9FzUa3X6TaxkoH
=5zHC
-----END PGP SIGNATURE-----

P
P
phodina wrote on 5 Nov 2021 06:48
[PATCH v2 1/2] gnu: Add lowdown.
(name . 48899@debbugs.gnu.org)(address . 48899@debbugs.gnu.org)
xU42LNhtt1IRudiGRCXfqGMP3k3sCmMeUZfyap0QxUl4Ke7UEbEoJ6qDJPjKA1UuUj8bA6csxgJa_1g9pmqTcucvSvcjZa0eWMgnjEQJGpc=@protonmail.com
Hi Zhu,

thanks for the patch. However, your patch was missing some imports as well as in the meantime a new version was released.

I also created one more patch to add prefix to all licenses in this module.

Petr

----8<--------cut here ------------------>8------------

* gnu/packages/markup.scm (lowdown): New variable.

Toggle diff (66 lines)
diff --git a/gnu/packages/markup.scm b/gnu/packages/markup.scm
index 368976bfde..720bdb178b 100644
--- a/gnu/packages/markup.scm
+++ b/gnu/packages/markup.scm
@@ -7,6 +7,8 @@
;;; Copyright © 2020 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2020 EuAndreh <eu@euandre.org>
;;; Copyright © 2021 Noisytoot <noisytoot@disroot.org>
+;;; Copyright © 2021 Zhu Zihao <all_but_last@163.com>
+;;; Copyright © 2021 Petr Hodina <phodina@protonmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -34,12 +36,14 @@ (define-module (gnu packages markup)
#:use-module (guix build-system perl)
#:use-module (guix build-system python)
#:use-module (guix utils)
+ #:use-module (gnu packages base)
#:use-module (gnu packages compression)
#:use-module (gnu packages)
#:use-module (gnu packages perl)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages python)
- #:use-module (gnu packages web))
+ #:use-module (gnu packages web)
+ #:use-module ((guix licenses) #:prefix license:))

(define-public hoedown
(package
@@ -114,6 +118,36 @@ (define-public markdown
(license (non-copyleft "file://License.text"
"See License.text in the distribution."))))

+(define-public lowdown
+ (package
+ (name "lowdown")
+ (version "0.10.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://kristaps.bsd.lv/lowdown/snapshots/lowdown-"
+ version ".tar.gz"))
+ (sha256
+ (base32 "2f6lpyz5bbvwqadal8xcfjcm46zcycrgk5079isjyipg85zdyvb2"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ;No test
+ #:phases
+ (modify-phases %standard-phases
+ (replace 'configure
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ (invoke "./configure"
+ (string-append "PREFIX=" out)
+ (string-append "MANDIR=" out "/share/man"))))))))
+ (native-inputs
+ `(("which" ,which)))
+ (home-page "https://kristaps.bsd.lv/lowdown/")
+ (synopsis "Simple Markdown translator")
+ (description "Lowdown is a Markdown translator producing HTML5,
+roff documents in the ms and man formats, LaTeX, gemini, and terminal output.")
+ (license license:isc)))
+
(define-public discount
(package
(name "discount")
--
2.33.1
P
P
phodina wrote on 5 Nov 2021 06:49
[PATCH v2 2/2] gnu: Update license.
(name . 48899@debbugs.gnu.org)(address . 48899@debbugs.gnu.org)
Fmd2Z4bFyhyHonsNdgyJZJftF4nimGVgRKxJLm7DQ-Hd4wfif9pv-yS8Cf5qWzrMLSCPyRhyFdoHkKJ0Ix20JarqeesVMr7tLygQYdml6VU=@protonmail.com
* gnu/packages/markup.scm (hoedown, markdown, discount,
perl-text-markdown-discount, cmark, smu, md4c, python-mistletoe)
[license]: Add prefix license:.

Toggle diff (73 lines)
diff --git a/gnu/packages/markup.scm b/gnu/packages/markup.scm
index 720bdb178b..91aa7b8fa0 100644
--- a/gnu/packages/markup.scm
+++ b/gnu/packages/markup.scm
@@ -71,7 +71,7 @@ (define-public hoedown
(description "Hoedown is a standards compliant, fast, secure markdown
processing library written in C.")
(home-page "https://github.com/hoedown/hoedown")
- (license expat)))
+ (license license:expat)))

(define-public markdown
(package
@@ -115,7 +115,7 @@ (define-public markdown
"Markdown is a text-to-HTML conversion tool for web writers. It allows
you to write using an easy-to-read, easy-to-write plain text format, then
convert it to structurally valid XHTML (or HTML).")
- (license (non-copyleft "file://License.text"
+ (license (license:non-copyleft "file://License.text"
"See License.text in the distribution."))))

(define-public lowdown
@@ -192,7 +192,7 @@ (define-public discount
"Discount is a markdown implementation, written in C. It provides a
@command{markdown} command, and a library.")
(home-page "https://www.pell.portland.or.us/~orc/Code/discount/")
- (license bsd-3)))
+ (license license:bsd-3)))

(define-public perl-text-markdown-discount
(package
@@ -237,7 +237,7 @@ (define-public perl-text-markdown-discount
use Text::Markdown::Discount;
my $html = markdown($text)
@end example")
- (license perl-license)))
+ (license license:perl-license)))

(define-public cmark
(package
@@ -277,7 +277,7 @@ (define-public cmark
;; cmark is distributed with a BSD-2 license, but some components are Expat
;; licensed. The CommonMark specification is Creative Commons CC-BY-SA 4.0
;; licensed. See 'COPYING' in the source distribution for more information.
- (license (list bsd-2 expat cc-by-sa4.0))))
+ (license (list license:bsd-2 license:expat license:cc-by-sa4.0))))

(define-public smu
(package
@@ -313,7 +313,7 @@ (define-public smu
Smu was started as a rewrite of Markdown but became something more
lightweight and consistent. The biggest difference between Markdown
and smu is that smu doesn't support reference style links.")
- (license x11)))
+ (license license:x11)))

(define-public md4c
(package
@@ -335,7 +335,7 @@ (define-public md4c
(description "MD4C is a C Markdown parser with a
SAX-like interface. It is compliant to the CommonMark specification,
with a few extensions.")
- (license expat)))
+ (license license:expat)))

(define-public python-mistletoe
(package
@@ -357,4 +357,4 @@ (define-public python-mistletoe
Parsing Markdown into an abstract syntax tree also allows @code{mistletoe} to
swap out renderers for different output formats, without touching any of the
core components.")
- (license expat)))
+ (license license:expat)))
--
2.33.1
L
L
Liliana Marie Prikler wrote on 5 Nov 2021 21:39
Re: [PATCH v2 1/2] gnu: Add lowdown.
4a5013e15be751271907a893c1af8d1de65898f3.camel@gmail.com
Hi Petr,

Am Freitag, den 05.11.2021, 05:48 +0000 schrieb phodina:
Toggle quote (11 lines)
> Hi Zhu,
>
> thanks for the patch. However, your patch was missing some imports as
> well as in the meantime a new version was released.
>
> I also created one more patch to add prefix to all licenses in this
> module.
>
> Petr
>
> ----8<--------cut here ------------------>8------------
This blurb should go below the changelog...

Toggle quote (2 lines)
> * gnu/packages/markup.scm (lowdown): New variable.
>
Here after two dashes ("--")

Toggle quote (47 lines)
> diff --git a/gnu/packages/markup.scm b/gnu/packages/markup.scm
> index 368976bfde..720bdb178b 100644
> --- a/gnu/packages/markup.scm
> +++ b/gnu/packages/markup.scm
> @@ -7,6 +7,8 @@
> ;;; Copyright © 2020 Marius Bakke <mbakke@fastmail.com>
> ;;; Copyright © 2020 EuAndreh <eu@euandre.org>
> ;;; Copyright © 2021 Noisytoot <noisytoot@disroot.org>
> +;;; Copyright © 2021 Zhu Zihao <all_but_last@163.com>
> +;;; Copyright © 2021 Petr Hodina <phodina@protonmail.com>
> ;;;
> ;;; This file is part of GNU Guix.
> ;;;
> @@ -34,12 +36,14 @@ (define-module (gnu packages markup)
> #:use-module (guix build-system perl)
> #:use-module (guix build-system python)
> #:use-module (guix utils)
> + #:use-module (gnu packages base)
> #:use-module (gnu packages compression)
> #:use-module (gnu packages)
> #:use-module (gnu packages perl)
> #:use-module (gnu packages pkg-config)
> #:use-module (gnu packages python)
> - #:use-module (gnu packages web))
> + #:use-module (gnu packages web)
> + #:use-module ((guix licenses) #:prefix license:))
>
> (define-public hoedown
> (package
> @@ -114,6 +118,36 @@ (define-public markdown
> (license (non-copyleft "file://License.text"
> "See License.text in the
> distribution."))))
>
> +(define-public lowdown
> + (package
> + (name "lowdown")
> + (version "0.10.0")
> + (source
> + (origin
> + (method url-fetch)
> + (uri (string-append "
> https://kristaps.bsd.lv/lowdown/snapshots/lowdown-"
> + version ".tar.gz"))
> + (sha256
> + (base32
> "2f6lpyz5bbvwqadal8xcfjcm46zcycrgk5079isjyipg85zdyvb2"))))
Please provide a proper hash next time you update the version on
someone's behalf.
Toggle quote (3 lines)
> + (build-system gnu-build-system)
> + (arguments
> + `(#:tests? #f ;No test
There are actually regress tests.
Toggle quote (19 lines)
> + #:phases
> + (modify-phases %standard-phases
> + (replace 'configure
> + (lambda* (#:key outputs #:allow-other-keys)
> + (let ((out (assoc-ref outputs "out")))
> + (invoke "./configure"
> + (string-append "PREFIX=" out)
> + (string-append "MANDIR=" out
> "/share/man"))))))))
> + (native-inputs
> + `(("which" ,which)))
> + (home-page "https://kristaps.bsd.lv/lowdown/")
> + (synopsis "Simple Markdown translator")
> + (description "Lowdown is a Markdown translator producing HTML5,
> +roff documents in the ms and man formats, LaTeX, gemini, and
> terminal output.")
> + (license license:isc)))
> +

Cheers
L
L
Liliana Marie Prikler wrote on 5 Nov 2021 21:42
Re: [PATCH v2 2/2] gnu: Update license.
8ef10229242e683c0167ee407fc25b1180bdb51e.camel@gmail.com
Hi Petr,

Am Freitag, den 05.11.2021, 05:49 +0000 schrieb phodina:
Toggle quote (3 lines)
> * gnu/packages/markup.scm (hoedown, markdown, discount,
> perl-text-markdown-discount, cmark, smu, md4c, python-mistletoe)
> [license]: Add prefix license:.
Pushed with slight changes to commit message and ChangeLog, as well as

Toggle quote (10 lines)
> @@ -115,7 +115,7 @@ (define-public markdown
> "Markdown is a text-to-HTML conversion tool for web
> writers. It allows
> you to write using an easy-to-read, easy-to-write plain text format,
> then
> convert it to structurally valid XHTML (or HTML).")
> - (license (non-copyleft "file://License.text"
> + (license (license:non-copyleft "file://License.text"
> "See License.text in the
> distribution."))))
indented this hunk.

Also added the license use statement where the previous one was and
deleted the previous to enforce use of license:

Thanks
Closed
?