[PATCH] gnu: Add udftools.

  • Done
  • quality assurance status badge
Details
2 participants
  • Tobias Geerinckx-Rice
  • Ron Nazarov
Owner
unassigned
Submitted by
Ron Nazarov
Severity
normal
R
R
Ron Nazarov wrote on 2 Jun 2021 00:42
(address . guix-patches@gnu.org)(name . Ron Nazarov)(address . noisytoot@disroot.org)
20210601224250.30896-1-noisytoot@disroot.org
* gnu/packages/linux.scm (udftools): New variable.
---
gnu/packages/linux.scm | 28 ++++++++++++++++++++++++++++
1 file changed, 28 insertions(+)

Toggle diff (48 lines)
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index b803426b74..aaafd892a7 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -54,6 +54,7 @@
;;; Copyright © 2020 David Dashyan <mail@davie.li>
;;; Copyright © 2020 pukkamustard <pukkamustard@posteo.net>
;;; Copyright © 2021 B. Wilson <elaexuotee@wilsonb.com>
+;;; Copyright © 2021 Noisytoot <noisytoot@disroot.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -5226,6 +5227,33 @@ small devices. This version has additional features such as uncompressed
blocks and random block placement.")
(license license:gpl2+)))
+(define-public udftools
+ (package
+ (name "udftools")
+ (version "2.3")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/pali/udftools")
+ (commit version)))
+ (sha256
+ (base32
+ "1nl2s61znyzaap23zhbdg3znj6l6akr313fchn5wwvjzj8k70is9"))
+ (file-name (git-file-name name version))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("automake" ,automake)
+ ("autoconf" ,autoconf)
+ ("libtool" ,libtool)
+ ("pkg-config" ,pkg-config)))
+ (home-page "https://github.com/pali/udftools")
+ (synopsis "Tools to manage @acronym{UDF, Universal Disk Format} filesystems and DVD/CD-R(W) drives")
+ (description "@code{udftools} is a set of programs for reading
+and modifying @acronym{UDF, Universal Disk Format} filesystems.
+@acronym{UDF, Universal Disk Format} is a filesystem mostly used for DVDs and other optical media.
+It supports read-only media (DVD/CD-R) and rewritable media that wears out (DVD/CD-RW).")
+ (license license:gpl2+)))
+
(define-public compsize
(package
(name "compsize")
--
2.31.1
R
R
Ron Nazarov wrote on 2 Jun 2021 14:32
[PATCH v2] gnu: Add udftools.
(address . 48786@debbugs.gnu.org)(name . Ron Nazarov)(address . noisytoot@disroot.org)
20210602123245.14264-1-noisytoot@disroot.org
* gnu/packages/file-systems.scm (udftools): New variable.
---
gnu/packages/file-systems.scm | 29 +++++++++++++++++++++++++++++
1 file changed, 29 insertions(+)

Toggle diff (46 lines)
diff --git a/gnu/packages/file-systems.scm b/gnu/packages/file-systems.scm
index c64c0df727..f9fb256602 100644
--- a/gnu/packages/file-systems.scm
+++ b/gnu/packages/file-systems.scm
@@ -8,6 +8,7 @@
;;; Copyright © 2020 Morgan Smith <Morgan.J.Smith@outlook.com>
;;; Copyright © 2021 raid5atemyhomework <raid5atemyhomework@protonmail.com>
;;; Copyright © 2021 Stefan Reichör <stefan@xsteve.at>
+;;; Copyright © 2021 Noisytoot <noisytoot@disroot.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1526,3 +1527,31 @@ your put them. TMSU maintains its own database and you simply gain an
additional view, which you can mount where you like, based upon the tags you
set up.")
(license license:gpl3+)))
+
+(define-public udftools
+ (package
+ (name "udftools")
+ (version "2.3")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/pali/udftools")
+ (commit version)))
+ (sha256
+ (base32
+ "1nl2s61znyzaap23zhbdg3znj6l6akr313fchn5wwvjzj8k70is9"))
+ (file-name (git-file-name name version))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("automake" ,automake)
+ ("autoconf" ,autoconf)
+ ("libtool" ,libtool)
+ ("pkg-config" ,pkg-config)))
+ (home-page "https://github.com/pali/udftools")
+ (synopsis "Tools to manage UDF file systems and DVD/CD-R(W) drives")
+ (description "@code{udftools} is a set of programs for reading
+and modifying @acronym{UDF, Universal Disk Format} file systems.
+@acronym{UDF, Universal Disk Format} is a file system mostly used for DVDs
+and other optical media. It supports read-only media (DVD/CD-R)
+and rewritable media that wears out (DVD/CD-RW).")
+ (license license:gpl2+)))
--
2.31.1
T
T
Tobias Geerinckx-Rice wrote on 2 Jun 2021 15:42
(name . Ron Nazarov)(address . noisytoot@disroot.org)(address . 48786-done@debbugs.gnu.org)
87pmx4z8l9.fsf@nckx
Ron Nazarov via Guix-patches via ???
Toggle quote (2 lines)
> * gnu/packages/file-systems.scm (udftools): New variable.

Thanks! Pushed.

Kind regards,

T G-R
-----BEGIN PGP SIGNATURE-----

iIMEARYKACsWIQT12iAyS4c9C3o4dnINsP+IT1VteQUCYLeKwg0cbWVAdG9iaWFz
LmdyAAoJEA2w/4hPVW156e0BAIaVju14uh1rs/bKsHLKFfPFAk4SUkzc7YnVg0U/
4ZLAAQCN4gm7vSMr2XXeJw5WOwLzHVFRNFh9+GA4aqhFJuZfCw==
=rXp2
-----END PGP SIGNATURE-----

Closed
?