[PATCH] Add lingot

  • Done
  • quality assurance status badge
Details
3 participants
  • Efraim Flashner
  • Tobias Geerinckx-Rice
  • Rovanion Luckey
Owner
unassigned
Submitted by
Rovanion Luckey
Severity
normal
R
R
Rovanion Luckey wrote on 28 May 2021 17:21
(address . guix-patches@gnu.org)
CAAaf0CDHT4CJuDRcnkXYrVkiY2h-26=V=CF+sGYyr1zMKK4E8Q@mail.gmail.com
Added a tuner program to the package collection.
Attachment: file
From 248c6525564dabe71e130e4f6a48005201d2efdc Mon Sep 17 00:00:00 2001
From: Rovanion Luckey <rovanion.luckey@gmail.com>
Date: Fri, 28 May 2021 17:19:56 +0200
Subject: [PATCH] gnu: lingot: Add package lingot.

* gnu/packages/music.scm (lingot): Add package
---
gnu/packages/music.scm | 37 +++++++++++++++++++++++++++++++++++++
1 file changed, 37 insertions(+)

Toggle diff (47 lines)
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 7840e8399a..423c9bd3c7 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -6639,3 +6639,40 @@ It is provided as an LV2 plugin and as a standalone Jack application.")
framework.")
(home-page "http://shiru.untergrund.net/software.shtml")
(license license:wtfpl2))))
+
+(define-public lingot
+ (package
+ (name "lingot")
+ (version "1.1.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ibancg/lingot")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "04lcjzfhddbyskxr2068z609y6x0s2gjx1wl78w0dkxdi459zrn9"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("intltool" ,intltool)
+ ("cunit" ,cunit)
+ ("pkg-config" ,pkg-config)
+ ("libtool" ,libtool)))
+ (inputs
+ `(
+ ("alsa-lib" ,alsa-lib) ; for libasound2
+ ("fftw" ,fftw)
+ ("gtk+" ,gtk+)
+ ("glib" ,glib "bin") ; for GLIB_COMPILE_RESOURCES
+ ("jack" ,jack-2)
+ ("json-c" ,json-c)
+ ("pulseaudio" ,pulseaudio)))
+ (home-page "http://lingot.nongnu.org/")
+ (synopsis "An accurate, configurable musical instrument tuner")
+ (description "LINGOT is a musical instrument tuner. It’s accurate, easy to use, and highly configurable. Originally conceived to tune electric guitars, it can now be used to tune other instruments.
+
+It looks like an analogue tuner, with a gauge indicating the relative shift to a certain note, determined automatically as the closest note to the estimated frequency.")
+ (license license:gpl2)))
--
2.30.0
T
T
Tobias Geerinckx-Rice wrote on 28 May 2021 19:12
(name . Rovanion Luckey)(address . rovanion.luckey@gmail.com)
87y2byixzs.fsf@nckx
Rovanion Luckey ???
Toggle quote (2 lines)
> Added a tuner program to the package collection.

Thank you!

I should add a copyright line for you at the top of the file, once
you confirm which name & e-mail address to use.

I made the following changes (pay close attention, they might be
on the test):
- moved glib:bin to native-inputs, which means it can be run at
build time even when cross-building (and ‘guix gc --references’
indicates it won't be run at run time anyway),
- the licence is ‘GPL2 or later’,
- removed the leading ‘An’ from the synopsis (in a list, it's just
noise),
- wrapped all text to 80 characters and added a double space after
full stops.

Be sure to run ‘guix lint’ on new packages, it will warn you about
some of these and other cool mistakes.

These minor nitpicks will not be on the test but I applied them
anyway:
- reindented the package (specifically the source form was off?),
- ordered the inputs alphabetically, and put the package somewhere
similar,
- removed the libasound comment because that's 99% of why packages
use alsa-lib. Probably 100. Could the same be said for
glib:bin, which I kept? Perhaps! I am whimsy.

Kind regards,

T G-R
-----BEGIN PGP SIGNATURE-----

iIMEARYKACsWIQT12iAyS4c9C3o4dnINsP+IT1VteQUCYLEkZw0cbWVAdG9iaWFz
LmdyAAoJEA2w/4hPVW155EkA/RyAdndQ2nPFw8PlUSL9xxS/+ToQ5D/v2O3AWAgy
380pAQCuxDvSIVNJ6Gt4XDYVIlKpJJf+RbJZF68XQJcXB9+bDA==
=tmd/
-----END PGP SIGNATURE-----

R
R
Rovanion Luckey wrote on 28 May 2021 21:18
[PATCH] Add lingot
(address . 48717@debbugs.gnu.org)
CAAaf0CC3MS9ysbGCbAEHVs68G_MNpFh8uYVqgJkJoQ4OCbRP-Q@mail.gmail.com
You can use the following for the copyright line:

Rovanion Luckey <rovanion.luckey@gmail.com>

I gleaned the license info from GitHub, but I guess it was wrong. Should
really have run guix lint on the package though. Thank you for your
patience.
Attachment: file
R
R
Rovanion Luckey wrote on 30 Jul 2021 21:03
(address . 48717@debbugs.gnu.org)
CAAaf0CBws8wXJXOEh12daM0zjVrASxd2P_ky-9yBSYej-MBoHQ@mail.gmail.com
This patch has been included and this issue closed right?

Den fre 28 maj 2021 kl 21:18 skrev Rovanion Luckey <
rovanion.luckey@gmail.com>:

Toggle quote (8 lines)
> You can use the following for the copyright line:
>
> Rovanion Luckey <rovanion.luckey@gmail.com>
>
> I gleaned the license info from GitHub, but I guess it was wrong. Should
> really have run guix lint on the package though. Thank you for your
> patience.
>
Attachment: file
E
E
Efraim Flashner wrote on 2 Aug 2021 17:40
Re: [bug#48717] [PATCH] Add lingot
(name . Rovanion Luckey)(address . rovanion.luckey@gmail.com)(address . 48717-done@debbugs.gnu.org)
YQgR8TieSP5K5MVa@3900XT
On Fri, Jul 30, 2021 at 09:03:11PM +0200, Rovanion Luckey wrote:
Toggle quote (2 lines)
> This patch has been included and this issue closed right?

Looks like it was committed on May 30th. Closing the bug.


--
Efraim Flashner <efraim@flashner.co.il> ????? ?????
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAmEIEe4ACgkQQarn3Mo9
g1EkOw/+LAaUF0FA5iRj8L1gxnvICazWe6Ekg4mE+fk4XOFF6sB0wldMF9Yk2vb5
Pjjyu4P/7qnucfbfcL20yqj0ihRslF1/kf4l3spGOYbmZr4s5aCvfch1XuNskrpH
nAZXH37AORz9R8KFeQ7iQ+TyEZiKZQuA0fXAOkTvsvC399Q39aU4Q1Sgu75+YEVx
EH8LjaqFb+mvQThng5v+sHtnwpzaJCLtDhxGogk3bT9x0bPVQ59dxF1WHJvWdSsM
cDrFkfv43qVYuiOB0Ro8rdvzMQPfJfzgxI6W1WULjv5bcH6fpCtySz079incow8q
nq/riaFhynoEovgFJSKLrdRZaj1y2wqjnLON+4FrErQ85KbQ27w1oQdW/zMUYBdy
XgWA565IhGxj9KcI5VJsX6LnB9NBipyNJj5Gilq2TONpDODqUqVa7sotNyyh3q0e
v+5GdSJKFEM9pPkDVaqv22dvJ0nZPwyz509j88wiWP9+kRvqo/XhFmRTKfFmLdlb
4vJVv1FRfepMbDkKZjvAYl725VCWVYgp65b1i6yy/bO33Eh41PCIBxwRijJQ8YQr
VjlJMQUSswQtm4ojHyVdXTFZzmXHGIXbeD0lODvx6ymdyzk1/IutoIdyjXPPiU7p
2z/xvGlREh9qsVje1WUof1/J7SS0nfoJ8BArrsDzw6s8uLTimTk=
=b6x+
-----END PGP SIGNATURE-----


Closed
?