[PATCH] gnu: Add font-ipa-ex.

  • Done
  • quality assurance status badge
Details
2 participants
  • Leo Prikler
  • Maxim Cournoyer
Owner
unassigned
Submitted by
Leo Prikler
Severity
normal
L
L
Leo Prikler wrote on 24 May 2021 10:46
(address . guix-patches@gnu.org)
20210524084644.31047-1-leo.prikler@student.tugraz.at
* gnu/packages/fonts.scm (font-ipa-ex): New variable.
---
gnu/packages/fonts.scm | 43 ++++++++++++++++++++++++++++++++++++++++++
1 file changed, 43 insertions(+)

Toggle diff (56 lines)
diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
index 726bef183c..711344191c 100644
--- a/gnu/packages/fonts.scm
+++ b/gnu/packages/fonts.scm
@@ -2031,6 +2031,49 @@ orthography of Roman glyphs of Meera Inimai are also based on this
characteristic so that they sit smoothly with the Tamil glyphs.")
(license license:silofl1.1)))
+(define-public font-ipa-ex
+ (package
+ (name "font-ipa-ex")
+ (version "004.01")
+ (source (origin
+ (method url-fetch/zipbomb)
+ (uri (string-append "https://moji.or.jp/wp-content/ipafont/IPAexfont/"
+ "IPAexfont" (string-join (string-split version #\.) "")
+ ".zip"))
+ (sha256
+ (base32
+ "0jwpszgisrls1lsgq1ngcm99zjaikb8hshr02512qrzrnd53gy5w"))))
+ (build-system font-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'make-read-only
+ (lambda _
+ (for-each
+ (lambda (file)
+ (chmod file #o444))
+ (find-files "." #:directories? #f))
+ #t))
+ (add-after 'install 'install-doc
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((font+version (string-append
+ "IPAexfont"
+ ,(string-join (string-split version #\.) "")))
+ (doc-dir (string-append (assoc-ref outputs "out")
+ "/share/doc/font-ipa-ex")))
+ (with-directory-excursion font+version
+ (mkdir-p doc-dir)
+ (copy-file (string-append "Readme_" font+version ".txt")
+ (string-append doc-dir "/README"))
+ (copy-file "IPA_Font_License_Agreement_v1.0.txt"
+ (string-append doc-dir "/LICENSE")))
+ #t))))))
+ (home-page "https://moji.or.jp/ipafont/")
+ (synopsis "Japanese font from the Information-technology Promotion Agency")
+ (description "IPAex is fixed-width font that aims to improve the
+convenience of Japanese document creation.")
+ (license license:ipa)))
+
(define-public font-ipa-mj-mincho
(package
(name "font-ipa-mj-mincho")
--
2.31.1
M
M
Maxim Cournoyer wrote on 22 May 2022 06:12
(name . Leo Prikler)(address . leo.prikler@student.tugraz.at)(address . 48620-done@debbugs.gnu.org)
87wnee6w9o.fsf@gmail.com
Hello!

Leo Prikler <leo.prikler@student.tugraz.at> writes:

Toggle quote (60 lines)
> * gnu/packages/fonts.scm (font-ipa-ex): New variable.
> ---
> gnu/packages/fonts.scm | 43 ++++++++++++++++++++++++++++++++++++++++++
> 1 file changed, 43 insertions(+)
>
> diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
> index 726bef183c..711344191c 100644
> --- a/gnu/packages/fonts.scm
> +++ b/gnu/packages/fonts.scm
> @@ -2031,6 +2031,49 @@ orthography of Roman glyphs of Meera Inimai are also based on this
> characteristic so that they sit smoothly with the Tamil glyphs.")
> (license license:silofl1.1)))
>
> +(define-public font-ipa-ex
> + (package
> + (name "font-ipa-ex")
> + (version "004.01")
> + (source (origin
> + (method url-fetch/zipbomb)
> + (uri (string-append "https://moji.or.jp/wp-content/ipafont/IPAexfont/"
> + "IPAexfont" (string-join (string-split version #\.) "")
> + ".zip"))
> + (sha256
> + (base32
> + "0jwpszgisrls1lsgq1ngcm99zjaikb8hshr02512qrzrnd53gy5w"))))
> + (build-system font-build-system)
> + (arguments
> + `(#:phases
> + (modify-phases %standard-phases
> + (add-after 'unpack 'make-read-only
> + (lambda _
> + (for-each
> + (lambda (file)
> + (chmod file #o444))
> + (find-files "." #:directories? #f))
> + #t))
> + (add-after 'install 'install-doc
> + (lambda* (#:key outputs #:allow-other-keys)
> + (let ((font+version (string-append
> + "IPAexfont"
> + ,(string-join (string-split version #\.) "")))
> + (doc-dir (string-append (assoc-ref outputs "out")
> + "/share/doc/font-ipa-ex")))
> + (with-directory-excursion font+version
> + (mkdir-p doc-dir)
> + (copy-file (string-append "Readme_" font+version ".txt")
> + (string-append doc-dir "/README"))
> + (copy-file "IPA_Font_License_Agreement_v1.0.txt"
> + (string-append doc-dir "/LICENSE")))
> + #t))))))
> + (home-page "https://moji.or.jp/ipafont/")
> + (synopsis "Japanese font from the Information-technology Promotion Agency")
> + (description "IPAex is fixed-width font that aims to improve the
> +convenience of Japanese document creation.")
> + (license license:ipa)))
> +
> (define-public font-ipa-mj-mincho
> (package
> (name "font-ipa-mj-mincho")

I made the following changes:

Toggle snippet (88 lines)
1 file changed, 33 insertions(+), 28 deletions(-)
gnu/packages/fonts.scm | 61 +++++++++++++++++++++++++++++++++----------------------------

modified gnu/packages/fonts.scm
@@ -48,6 +48,7 @@
;;; Copyright © 2021 Wamm K. D. <jaft.r@outlook.com>
;;; Copyright © 2022 Jai Vetrivelan <jaivetrivelan@gmail.com>
;;; Copyright © 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2021 Liliana Marie Prikler <liliana.prikler@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -2256,41 +2257,45 @@ (define-public font-ipa-ex
(version "004.01")
(source (origin
(method url-fetch/zipbomb)
- (uri (string-append "https://moji.or.jp/wp-content/ipafont/IPAexfont/"
- "IPAexfont" (string-join (string-split version #\.) "")
- ".zip"))
+ (uri (string-append
+ "https://moji.or.jp/wp-content/ipafont/IPAexfont/"
+ "IPAexfont" (string-join (string-split version #\.) "")
+ ".zip"))
(sha256
(base32
"0jwpszgisrls1lsgq1ngcm99zjaikb8hshr02512qrzrnd53gy5w"))))
(build-system font-build-system)
(arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'make-read-only
- (lambda _
- (for-each
- (lambda (file)
- (chmod file #o444))
- (find-files "." #:directories? #f))
- #t))
- (add-after 'install 'install-doc
- (lambda* (#:key outputs #:allow-other-keys)
- (let ((font+version (string-append
- "IPAexfont"
- ,(string-join (string-split version #\.) "")))
- (doc-dir (string-append (assoc-ref outputs "out")
- "/share/doc/font-ipa-ex")))
- (with-directory-excursion font+version
- (mkdir-p doc-dir)
- (copy-file (string-append "Readme_" font+version ".txt")
- (string-append doc-dir "/README"))
- (copy-file "IPA_Font_License_Agreement_v1.0.txt"
- (string-append doc-dir "/LICENSE")))
- #t))))))
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'make-read-only
+ (lambda _
+ ;; Otherwise the files have the executable bit set.
+ (for-each (lambda (file)
+ (chmod file #o444))
+ (find-files "." #:directories? #f))))
+ (add-after 'install 'install-doc
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((font+version
+ #$(string-append
+ "IPAexfont"
+ (string-join (string-split version #\.) "")))
+ (doc-dir (string-append #$output "/share/doc/" #$name)))
+ (with-directory-excursion font+version
+ (mkdir-p doc-dir)
+ (copy-file (string-append "Readme_" font+version ".txt")
+ (string-append doc-dir "/README"))
+ (copy-file "IPA_Font_License_Agreement_v1.0.txt"
+ (string-append doc-dir "/LICENSE")))))))))
(home-page "https://moji.or.jp/ipafont/")
(synopsis "Japanese font from the Information-technology Promotion Agency")
- (description "IPAex is fixed-width font that aims to improve the
-convenience of Japanese document creation.")
+ (description "IPAex Fonts are suitable for both display and printing.
+This is a modernized version of IPA Fonts that aims to provide a good balance
+for authoring Japanese documents mixed with Western characters, while
+following Japanese printing tradition. Japanese characters (Kanji, Kana and
+punctuation marks) are full width mono-space pitch, and Western characters are
+proportional pitch.")
(license license:ipa)))
(define-public font-ipa-mj-mincho

mostly improving the description, and pushed as 6e0b2adf5f.

Thanks!

Maxim
Closed
?