[PATCH 0/2] gnu: botan: Update and respect #:tests?

  • Done
  • quality assurance status badge
Details
2 participants
  • Jack Hill
  • Leo Famulari
Owner
unassigned
Submitted by
Jack Hill
Severity
normal
J
J
Jack Hill wrote on 21 May 2021 21:35
(address . guix-patches@gnu.org)
alpine.DEB.2.21.2105211508300.2109@marsh.hcoop.net
This seriers updates botan to the newest release, and improves the check
phase to respect #:tests?

I've tested that it builds reproducably on x86_64-linux and that it builds
(via qemu) for aarch64-linux. `guix refresh -l` reports one dependent
package, rnp, which builds with this update.

Jack Hill (2):
gnu: botan: Update to 2.18.1.
gnu: botan: Respect #:tests?.

gnu/packages/crypto.scm | 8 +++++---
1 file changed, 5 insertions(+), 3 deletions(-)

--
2.31.1

Best,
Jack
J
J
Jack Hill wrote on 21 May 2021 21:40
[PATCH 2/2] gnu: botan: Respect #:tests?.
(address . 48573@debbugs.gnu.org)
20210521194039.8032-2-jackhill@jackhill.us
* gnu/packages/crypto.scm (botan)[arguments]: Respect #:tests? in the 'check
phase.
---
gnu/packages/crypto.scm | 4 +++-
1 file changed, 3 insertions(+), 1 deletion(-)

Toggle diff (17 lines)
diff --git a/gnu/packages/crypto.scm b/gnu/packages/crypto.scm
index f333aced1b..674cb05801 100644
--- a/gnu/packages/crypto.scm
+++ b/gnu/packages/crypto.scm
@@ -976,7 +976,9 @@ SHA256, SHA512, SHA3, AICH, ED2K, Tiger, DC++ TTH, BitTorrent BTIH, GOST R
(add-before 'check 'library-path-for-tests
(lambda _ (setenv "LD_LIBRARY_PATH" (getcwd))))
(replace 'check
- (lambda _ (invoke "./botan-test"))))))
+ (lambda* (#:key tests? #:allow-other-keys)
+ (if tests?
+ (invoke "./botan-test")))))))
(native-inputs
`(("python" ,python-wrapper)
("python-docutils" ,python-docutils)))
--
2.31.1
J
J
Jack Hill wrote on 21 May 2021 21:40
[PATCH 1/2] gnu: botan: Update to 2.18.1.
(address . 48573@debbugs.gnu.org)
20210521194039.8032-1-jackhill@jackhill.us
* gnu/packages/crypto.scm (botan): Update to 2.18.1.
---
gnu/packages/crypto.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (23 lines)
diff --git a/gnu/packages/crypto.scm b/gnu/packages/crypto.scm
index 2658c38cb4..f333aced1b 100644
--- a/gnu/packages/crypto.scm
+++ b/gnu/packages/crypto.scm
@@ -944,14 +944,14 @@ SHA256, SHA512, SHA3, AICH, ED2K, Tiger, DC++ TTH, BitTorrent BTIH, GOST R
(define-public botan
(package
(name "botan")
- (version "2.17.3")
+ (version "2.18.1")
(source (origin
(method url-fetch)
(uri (string-append "https://botan.randombit.net/releases/"
"Botan-" version ".tar.xz"))
(sha256
(base32
- "121vn1aryk36cpks70kk4c4cfic5g0qs82bf92xap9258ijkn4kr"))))
+ "0adf53drhk1hlpfih0175c9081bqpclw6p2afn51cmx849ib9izq"))))
(build-system gnu-build-system)
(arguments
'(#:phases
--
2.31.1
L
L
Leo Famulari wrote on 27 May 2021 19:56
Re: [bug#48573] [PATCH 0/2] gnu: botan: Update and respect #:tests?
(name . Jack Hill)(address . jackhill@jackhill.us)(address . 48573-done@debbugs.gnu.org)
YK/dWLrF3QJCWYz3@jasmine.lan
On Fri, May 21, 2021 at 03:35:05PM -0400, Jack Hill wrote:
Toggle quote (7 lines)
> This seriers updates botan to the newest release, and improves the check
> phase to respect #:tests?
>
> I've tested that it builds reproducably on x86_64-linux and that it builds
> (via qemu) for aarch64-linux. `guix refresh -l` reports one dependent
> package, rnp, which builds with this update.

Thanks for the patch and for mentioning how you tested it! That's very
helpful.

Pushed as d1b3b5b73da9a87991246ec40f6fd64e70b4e33a
Closed
?