[PATCH] gnu: Add python-playsound.

  • Open
  • quality assurance status badge
Details
2 participants
  • Hartmut Goebel
  • Adam Kandur
Owner
unassigned
Submitted by
Adam Kandur
Severity
normal
A
A
Adam Kandur wrote on 19 May 2021 01:02
(name . Guix Patches)(address . guix-patches@gnu.org)
Ma0hilj--3-2@tuta.io
From 812f4897ab8f32f2a9c716246a48b03892d25798 Mon Sep 17 00:00:00 2001
From: Adam Kandur <rndd@tuta.io>
Date: Wed, 19 May 2021 01:58:16 +0300
Subject: [PATCH] gnu: Add python-playsound.

* gnu/packages/python-xyz.scm (python-playsound): New variable.
---
gnu/packages/python-xyz.scm | 21 +++++++++++++++++++++
1 file changed, 21 insertions(+)

Toggle diff (32 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index f79fc54e24..66d281144a 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -12409,6 +12409,27 @@ Pytest but stripped of Pytest specific details.")
code.")
     (license license:expat)))

+(define-public python-playsound
+  (let ((revision "0")
+        (commit "907f1fe73375a2156f7e0900c4b42c0a60fa1d00"))
+    (package
+      (name "python-playsound")
+      (version (git-version "0.0.0" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+        (url "https://github.com/TaylorSMarks/playsound")
+        (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "1fh3m115h0c57lj2pfhhqhmsh5awzblb7csi1xc5a6f6slhl059k"))))
+      (build-system python-build-system)
+      (home-page "https://github.com/TaylorSMarks/playsound")
+      (synopsis "Function module for playing sounds")
+      (description "Pure Python, cross platform, single function module with no dependencies for playing sounds.")
+      (license license:expat))))
+
(define-public python-deprecation
   (package
     (name "python-deprecation")
--
2.31.1
A
A
Adam Kandur wrote on 19 May 2021 15:02
add input
(address . 48512@debbugs.gnu.org)
Ma3i3_L--7-2@tuta.io
From 8d5e8093b3996ccb95b0f2624c384909299501a2 Mon Sep 17 00:00:00 2001
From: Adam Kandur <rndd@tuta.io>
Date: Wed, 19 May 2021 16:00:58 +0300
Subject: [PATCH] gnu: Add python-playsound.

* gnu/packages/python-xyz.scm (python-playsound): New variable.
---
gnu/packages/python-xyz.scm | 23 +++++++++++++++++++++++
1 file changed, 23 insertions(+)

Toggle diff (34 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index ddaa51b..67d0791 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -12408,6 +12408,29 @@ Pytest but stripped of Pytest specific details.")
code.")
     (license license:expat)))

+(define-public python-playsound
+  (let ((revision "0")
+        (commit "907f1fe73375a2156f7e0900c4b42c0a60fa1d00"))
+    (package
+      (name "python-playsound")
+      (version (git-version "0.0.0" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+        (url "https://github.com/TaylorSMarks/playsound")
+        (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "1fh3m115h0c57lj2pfhhqhmsh5awzblb7csi1xc5a6f6slhl059k"))))
+      (build-system python-build-system)
+      (propagated-inputs
+       `(("python-pygobject" ,python-pygobject)))
+      (home-page "https://github.com/TaylorSMarks/playsound")
+      (synopsis "Function module for playing sounds")
+      (description "Pure Python, cross platform, single function module with no dependencies for playing sounds.")
+      (license license:expat))))
+
(define-public python-deprecation
   (package
     (name "python-deprecation")
--
2.31.1
H
H
Hartmut Goebel wrote on 15 Feb 09:48 +0100
[PATCH] gnu: Add python-playsound.
(address . 48512@debbugs.gnu.org)
65c6de20-387f-bb8a-3bde-0f0e36d0a9ce@crazy-compilers.com
Hi,

this software seems to have some release. Why are you not using this
version but call it "0.0.0"? What random commit is it? Please add a comment.

Anyhow, I'm in favor of *not* including this package at all, since it
seems to be unmaintained since three years. And we should not include
dead software.

--
Regards
Hartmut Goebel

| Hartmut Goebel | h.goebel@crazy-compilers.com |
| www.crazy-compilers.com | compilers which you thought are impossible |
?