[PATCH 0/2] Add sendgmail.

  • Done
  • quality assurance status badge
Details
2 participants
  • Sarah Morgensen
  • Philip McGrath
Owner
unassigned
Submitted by
Philip McGrath
Severity
normal
P
P
Philip McGrath wrote on 16 May 2021 23:44
(address . guix-patches@gnu.org)(name . Philip McGrath)(address . philip@philipmcgrath.com)
20210516214435.692046-1-philip@philipmcgrath.com
This patch series adds a package for the `sendgmail` command, a `sendmail`
imitation that facilitates using `git send-email` with Gmail via OAuth2.

Philip McGrath (2):
gnu: Add go-cloud-google-com-go-compute-metadata.
gnu: Add go-github-com-google-gmail-oauth2-tools-go-sendgmail.

gnu/packages/golang.scm | 62 +++++++++++++++++++++++++++++++++++++++++
1 file changed, 62 insertions(+)

--
2.30.2
P
P
Philip McGrath wrote on 16 May 2021 23:49
[PATCH 1/2] gnu: Add go-cloud-google-com-go-compute-metadata.
(address . 48475@debbugs.gnu.org)(name . Philip McGrath)(address . philip@philipmcgrath.com)
20210516214950.696550-1-philip@philipmcgrath.com
* gnu/packages/golang.scm (go-cloud-google-com-go-compute-metadata): New
variable.
---
gnu/packages/golang.scm | 27 +++++++++++++++++++++++++++
1 file changed, 27 insertions(+)

Toggle diff (40 lines)
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 8c3c81ceda..265b1b4a54 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -1584,6 +1584,33 @@ developers to use @code{http} methods explicitly and in a way that's consistent
with the HTTP protocol definition.")
(license license:expat)))
+(define-public go-cloud-google-com-go-compute-metadata
+ (package
+ (name "go-cloud-google-com-go-compute-metadata")
+ (version "0.81.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/googleapis/google-cloud-go")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "15jgynqb5pbxqbj3a7ii970yn4srsw1dbxzxnhpkfkmplalpgyh3"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:unpack-path "cloud.google.com/go"
+ #:import-path "cloud.google.com/go/compute/metadata"))
+ (home-page
+ "https://pkg.go.dev/cloud.google.com/go/compute/metadata")
+ (synopsis
+ "Go wrapper for Google Compute Engine metadata service")
+ (description
+ "This package provides access to Google Compute Engine (GCE) metadata and
+API service accounts for Go.")
+ (license license:asl2.0)))
+
(define-public go-github-com-google-cadvisor
(let ((commit "2ed7198f77395ee9a172878a0a7ab92ab59a2cfd")
(revision "0"))
--
2.30.2
P
P
Philip McGrath wrote on 16 May 2021 23:49
[PATCH 2/2] gnu: Add go-github-com-google-gmail-oauth2-tools-go-sendgmail.
(address . 48475@debbugs.gnu.org)(name . Philip McGrath)(address . philip@philipmcgrath.com)
20210516214950.696550-2-philip@philipmcgrath.com
* gnu/packages/golang.scm
(go-github-com-google-gmail-oauth2-tools-go-sendgmail): New variable.
---
gnu/packages/golang.scm | 35 +++++++++++++++++++++++++++++++++++
1 file changed, 35 insertions(+)

Toggle diff (48 lines)
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 265b1b4a54..48c46ee5bf 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -1611,6 +1611,41 @@ with the HTTP protocol definition.")
API service accounts for Go.")
(license license:asl2.0)))
+(define-public go-github-com-google-gmail-oauth2-tools-go-sendgmail
+ (let ((commit "e3229155a4037267ce40f1a3a681f53221aa4d8d")
+ (revision "0"))
+ (package
+ (name "go-github-com-google-gmail-oauth2-tools-go-sendgmail")
+ (version (git-version "0.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/google/gmail-oauth2-tools")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1cxpkiaajhq1gjsg47r2b5xgck0r63pvkyrkm7af8c8dw7fyn64f"))))
+ (propagated-inputs
+ `(("go-golang-org-x-oauth2" ,go-golang-org-x-oauth2)
+ ("go-cloud-google-com-go-compute-metadata"
+ ,go-cloud-google-com-go-compute-metadata)))
+ (build-system go-build-system)
+ (arguments
+ '(#:unpack-path "github.com/google/gmail-oauth2-tools"
+ #:import-path "github.com/google/gmail-oauth2-tools/go/sendgmail"))
+ (home-page
+ "https://github.com/google/gmail-oauth2-tools/tree/master/go/sendgmail")
+ (synopsis
+ "Sendmail-compatible tool for using Gmail with @code{git send-email}")
+ (description
+ "The @command{sendgmail} command provides a minimal sendmail-compatible
+front-end that connects to Gmail using OAuth2. It is specifically designed
+for use with @code{git send-email}. The command needs a Gmail API key to
+function.")
+ (license license:asl2.0))))
+
(define-public go-github-com-google-cadvisor
(let ((commit "2ed7198f77395ee9a172878a0a7ab92ab59a2cfd")
(revision "0"))
--
2.30.2
S
S
Sarah Morgensen wrote on 23 Sep 2021 21:36
control message for bug #48475
(address . control@debbugs.gnu.org)
E1mTUW0-0003R7-JV@debbugs.gnu.org
close 48475
quit
?