[PATCH] gnu: Add jumpapp.

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Renzo Poddighe
Owner
unassigned
Submitted by
Renzo Poddighe
Severity
normal
R
R
Renzo Poddighe wrote on 15 May 2021 20:46
(address . guix-patches@gnu.org)
2857b361-0a36-47a4-aedc-b729510879cc@www.fastmail.com
From 55e4bfbac15074b0db604461b8c64b4e3daa15dc Mon Sep 17 00:00:00 2001
From: Renzo Poddighe <renzo@poddighe.nl>
Date: Sat, 15 May 2021 20:27:25 +0200
Subject: [PATCH] gnu: Add jumpapp.
To: guix-patches@gnu.org

* gnu/packages/xdisorg.scm (jumpapp-1.1): New variable.

Signed-off-by: Renzo Poddighe <renzo@poddighe.nl>
---
gnu/packages/xdisorg.scm | 41 ++++++++++++++++++++++++++++++++++++++++
1 file changed, 41 insertions(+)

Toggle diff (51 lines)
diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index b5bacd3d97..1d9366eeba 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -2796,3 +2796,44 @@ and execute @file{.desktop} files of the Application type.")
"The @command{hsetroot} command composes wallpapers for X.
This package is the fork of hsetroot by Hyriand.")
(license license:gpl2+)))
+
+(define-public jumpapp
+ (package
+ (name "jumpapp")
+ (version "1.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/mkropat/jumpapp")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1jrk4mm42sz6ca2gkb6w3dad53d4im4shpgsq8s4vr6xpl3b43ry"))))
+ (build-system gnu-build-system)
+ (arguments `(#:phases
+ (modify-phases %standard-phases
+ (delete 'configure)
+ (delete 'check)
+ (add-before 'install 'set-prefix-in-makefile
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ (substitute* "Makefile"
+ (("PREFIX =.*")
+ (string-append "PREFIX = " out "\n")))
+ #true))))))
+ (propagated-inputs
+ `(("wmctrl" ,wmctrl)
+ ("xdotool" ,xdotool)
+ ("xprop" ,xprop)))
+ (native-inputs
+ `(("pandoc" ,pandoc)
+ ("perl" ,perl)))
+ (synopsis "Run-or-raise application switcher for any X11 desktop")
+ (description
+ "Bind a key for any given application that will launch the application,
+if it's not already running, or focus the application's window,if it is running.
+Pressing the key again will cycle to the application's next window,
+if there's more than one.")
+ (home-page "https://github.com/mkropat/jumpapp")
+ (license license:expat)))
--
2.31.1
L
L
Ludovic Courtès wrote on 22 May 2021 23:44
(name . Renzo Poddighe)(address . renzo@poddighe.nl)(address . 48450-done@debbugs.gnu.org)
87v97a5tqy.fsf@gnu.org
Hi,

"Renzo Poddighe" <renzo@poddighe.nl> skribis:

Toggle quote (10 lines)
>>From 55e4bfbac15074b0db604461b8c64b4e3daa15dc Mon Sep 17 00:00:00 2001
> From: Renzo Poddighe <renzo@poddighe.nl>
> Date: Sat, 15 May 2021 20:27:25 +0200
> Subject: [PATCH] gnu: Add jumpapp.
> To: guix-patches@gnu.org
>
> * gnu/packages/xdisorg.scm (jumpapp-1.1): New variable.
>
> Signed-off-by: Renzo Poddighe <renzo@poddighe.nl>

I added a copyright line for you (let me know if I got it wrong) and
committed. Thanks!

Ludo’.
Closed
?