[PATCH] gnu: Add schiffbruch.

  • Done
  • quality assurance status badge
Details
2 participants
  • Felix Gruber
  • Ludovic Courtès
Owner
unassigned
Submitted by
Felix Gruber
Severity
normal
F
F
Felix Gruber wrote on 15 May 2021 15:45
(address . guix-patches@gnu.org)(name . Felix Gruber)(address . felgru@posteo.net)
20210515134540.44089-1-felgru@posteo.net
* gnu/packages/games.scm (schiffbruch): New variable.
---
gnu/packages/games.scm | 36 ++++++++++++++++++++++++++++++++++++
1 file changed, 36 insertions(+)

Toggle diff (53 lines)
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 731c0cbc4a..37065dec09 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -60,6 +60,7 @@
;;; Copyright © 2021 Stefan Reichör <stefan@xsteve.at>
;;; Copyright © 2021 Greg Hogan <code@greghogan.com>
;;; Copyright © 2021 David Pflug <david@pflug.io>
+;;; Copyright © 2021 Felix Gruber <felgru@posteo.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -12472,3 +12473,38 @@ game FPS.")
implemented using ncurses user interface. An SDL graphical version is also
available.")
(license license:gpl3+)))
+
+(define-public schiffbruch
+ (package
+ (name "schiffbruch")
+ (version "1.2.1-git-e41916d")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/sandsmark/Schiffbruch")
+ ; There haven't been any releases for several years, so
+ ; I've taken the most recent commit from the master branch
+ ; that didn't fail to build (the last commit gave me a compile
+ ; error).
+ (commit "e41916d15d87749c82c5005cbb42d1bb079b43d9")))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0lg3rqacrapf6c4sxi12cm9bmg43mlbclway1zxcm848pi1xkzwv"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:tests? #f ; no tests
+ #:build-type "Release"))
+ (native-inputs
+ `(("gcc" ,gcc-11))) ; need C++20-compatible compiler
+ (inputs
+ `(("sfml" ,sfml)))
+ (home-page "https://github.com/sandsmark/Schiffbruch/")
+ (synopsis "Pixelart survival game")
+ (description
+ "Schiffbruch is a mix of building, strategy and adventure and gets played
+with a two-dimensional view. The game deals with the consequences of a ship
+wreckage. You're stranded on a desert island and have to survive. In order to
+do so you need to explore the island, find food, build a shelter and try to
+get attention, so you get found.")
+ (license (list license:cc-by4.0))))
--
2.30.2
L
L
Ludovic Courtès wrote on 19 May 2021 23:15
(name . Felix Gruber)(address . felgru@posteo.net)(address . 48441-done@debbugs.gnu.org)
87zgwq4e7q.fsf@gnu.org
Hi,

Felix Gruber <felgru@posteo.net> skribis:

Toggle quote (2 lines)
> * gnu/packages/games.scm (schiffbruch): New variable.

Pushed with the cosmetic changes below: using ‘git-version’ to compute
the version string, avoiding (list …) for the license, and using two
semicolons for block comments.

Thanks!

Ludo’.
Toggle diff (70 lines)
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 37065dec09..6908d115f2 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -12475,36 +12475,36 @@ available.")
(license license:gpl3+)))
(define-public schiffbruch
- (package
- (name "schiffbruch")
- (version "1.2.1-git-e41916d")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/sandsmark/Schiffbruch")
- ; There haven't been any releases for several years, so
- ; I've taken the most recent commit from the master branch
- ; that didn't fail to build (the last commit gave me a compile
- ; error).
- (commit "e41916d15d87749c82c5005cbb42d1bb079b43d9")))
- (file-name (git-file-name name version))
- (sha256
- (base32 "0lg3rqacrapf6c4sxi12cm9bmg43mlbclway1zxcm848pi1xkzwv"))))
- (build-system cmake-build-system)
- (arguments
- `(#:tests? #f ; no tests
- #:build-type "Release"))
- (native-inputs
- `(("gcc" ,gcc-11))) ; need C++20-compatible compiler
- (inputs
- `(("sfml" ,sfml)))
- (home-page "https://github.com/sandsmark/Schiffbruch/")
- (synopsis "Pixelart survival game")
- (description
- "Schiffbruch is a mix of building, strategy and adventure and gets played
+ ;; There haven't been any releases for several years, so I've taken the most
+ ;; recent commit from the master branch that didn't fail to build (the last
+ ;; commit gave me a compile error).
+ (let ((commit "e41916d15d87749c82c5005cbb42d1bb079b43d9"))
+ (package
+ (name "schiffbruch")
+ (version (git-version "1.2.1" "0" commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/sandsmark/Schiffbruch")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0lg3rqacrapf6c4sxi12cm9bmg43mlbclway1zxcm848pi1xkzwv"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:tests? #f ; no tests
+ #:build-type "Release"))
+ (native-inputs
+ `(("gcc" ,gcc-11))) ; need C++20-compatible compiler
+ (inputs
+ `(("sfml" ,sfml)))
+ (home-page "https://github.com/sandsmark/Schiffbruch/")
+ (synopsis "Pixelart survival game")
+ (description
+ "Schiffbruch is a mix of building, strategy and adventure and gets played
with a two-dimensional view. The game deals with the consequences of a ship
wreckage. You're stranded on a desert island and have to survive. In order to
do so you need to explore the island, find food, build a shelter and try to
get attention, so you get found.")
- (license (list license:cc-by4.0))))
+ (license license:cc-by4.0))))
Closed
?