[PATCH 2/5] gnu: Add python-easy-ansi.

  • Done
  • quality assurance status badge
Details
2 participants
  • Nicolas Goaziou
  • Stefan Reichör
Owner
unassigned
Submitted by
Stefan Reichör
Severity
normal
S
S
Stefan Reichör wrote on 14 May 2021 23:17
(address . guix-patches@gnu.org)(name . Stefan Reichör)(address . stefan@xsteve.at)
20210514211746.143145-2-stefan@xsteve.at
* gnu/packages/python-xyz.scm (python-easy-ansi): New variable.
---
gnu/packages/python-xyz.scm | 25 +++++++++++++++++++++++++
1 file changed, 25 insertions(+)

Toggle diff (38 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index cf0eba3234..98368129ed 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -16499,6 +16499,31 @@ converting text with ANSI color codes to HTML or LaTeX.")
(define-public python2-ansi2html
(package-with-python2 python-ansi2html))
+(define-public python-easy-ansi
+ (package
+ (name "python-easy-ansi")
+ (version "0.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "easy-ansi" version))
+ (sha256
+ (base32
+ "06ind48rb6bc8givysnak60g3rhk0zmch9ar80r00gzc6k6bgqfp"))))
+ (build-system python-build-system)
+ (home-page
+ "https://gitlab.com/joeysbytes/easy-ansi")
+ (synopsis
+ "Terminal framework API to give you an easy way to use colors, cursor
+control movements, and line/box drawing.")
+ (description
+ "Easy ANSI is a terminal framework API to give you an easy way to use
+colors, cursor control movements, and line/box drawing. It is not meant as a
+replacement to more full-featured frameworks (such as curses or urwid), but as
+a tool to quickly create nice-looking screens in your terminal window. You
+can even create animations with the cursor controls.")
+ (license license:expat)))
+
(define-public python-ddt
(package
(name "python-ddt")
--
2.25.1
S
S
Stefan Reichör wrote on 29 May 2021 22:28
[PATCH] gnu: Add python-easy-ansi.
(address . 48426@debbugs.gnu.org)(name . Stefan Reichör)(address . stefan@xsteve.at)
20210529202837.147041-1-stefan@xsteve.at
* gnu/packages/python-xyz.scm (python-easy-ansi): New variable.
---
I switched the source location to gitlab (from pypi).
However I was not able to find out how to run the tests

gnu/packages/python-xyz.scm | 25 +++++++++++++++++++++++++
1 file changed, 25 insertions(+)

Toggle diff (38 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index d978942402..9b9510f043 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -16551,6 +16551,31 @@ converting text with ANSI color codes to HTML or LaTeX.")
(define-public python2-ansi2html
(package-with-python2 python-ansi2html))
+(define-public python-easy-ansi
+ (package
+ (name "python-easy-ansi")
+ (version "0.3")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.com/joeysbytes/easy-ansi")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0albh55ynzs98qy9pln4qaxw5qhhh3lk09jy9bx19gycrp1c3lc3"))))
+ (build-system python-build-system)
+ (home-page "https://gitlab.com/joeysbytes/easy-ansi")
+ (synopsis "Terminal framework API to give you an easy way to use colors, cursor
+control movements, and line/box drawing.")
+ (description
+ "Easy ANSI is a terminal framework API to give you an easy way to use
+colors, cursor control movements, and line/box drawing. It is not meant as a
+replacement to more full-featured frameworks (such as curses or urwid), but as
+a tool to quickly create nice-looking screens in your terminal window. You
+can even create animations with the cursor controls.")
+ (license license:expat)))
+
(define-public python-ddt
(package
(name "python-ddt")
--
2.25.1
N
N
Nicolas Goaziou wrote on 31 May 2021 21:05
(name . Stefan Reichör)(address . stefan@xsteve.at)(address . 48426-done@debbugs.gnu.org)
87o8cqlo5j.fsf@nicolasgoaziou.fr
Hello,

Stefan Reichör <stefan@xsteve.at> writes:

Toggle quote (2 lines)
> * gnu/packages/python-xyz.scm (python-easy-ansi): New variable.

I drastically shortened synopsis and applied your patch. Thank you.

Regards,
--
Nicolas Goaziou
Closed
?