[PATCH] gnu: sameboy: Update to 0.14.3

  • Done
  • quality assurance status badge
Details
2 participants
  • Felix Gruber
  • Roel Janssen
Owner
unassigned
Submitted by
Felix Gruber
Severity
normal
F
F
Felix Gruber wrote on 14 May 2021 16:05
(address . guix-patches@gnu.org)(name . Felix Gruber)(address . felgru@posteo.net)
20210514140514.7311-1-felgru@posteo.net
* gnu/packages/emulators.scm (sameboy): Update to 0.14.3.
[native-inputs]: Remove gcc-9.
[arguments]: Use cc-for-target instead of hard-coding gcc.
---
gnu/packages/emulators.scm | 9 +++++----
1 file changed, 5 insertions(+), 4 deletions(-)

Toggle diff (44 lines)
diff --git a/gnu/packages/emulators.scm b/gnu/packages/emulators.scm
index 4367c23a6b..30cd2daf55 100644
--- a/gnu/packages/emulators.scm
+++ b/gnu/packages/emulators.scm
@@ -14,6 +14,7 @@
;;; Copyright © 2020 Jakub K?dzio?ka <kuba@kadziolka.net>
;;; Copyright © 2020 Christopher Howard <christopher@librehacker.com>
;;; Copyright © 2021 Felipe Balbi <balbi@kernel.org>
+;;; Copyright © 2021 Felix Gruber <felgru@posteo.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -637,7 +638,7 @@ and Game Boy Color games.")
(define-public sameboy
(package
(name "sameboy")
- (version "0.13.6")
+ (version "0.14.3")
(source
(origin
(method git-fetch)
@@ -646,17 +647,17 @@ and Game Boy Color games.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "04w8lybi7ssnax37ka4qw7pmcm7cgnmk90p9m73zbyp5chgpqqzc"))))
+ (base32 "1dipidx12ai62hnzf0pvnsk1cgjcmw1h5x2r7ilxq0k0pkia5b7a"))))
(build-system gnu-build-system)
(native-inputs
`(("rgbds" ,rgbds)
- ("gcc" ,gcc-9)
("pkg-config" ,pkg-config)))
(inputs
`(("sdl2" ,sdl2)))
(arguments
`(#:tests? #f ; There are no tests
- #:make-flags `("CC=gcc" "NATIVE_CC=gcc" "CONF=release"
+ #:make-flags `(,(string-append "CC=" ,(cc-for-target))
+ "NATIVE_CC=gcc" "CONF=release"
,(string-append "DATA_DIR="
(assoc-ref %outputs "out")
"/share/sameboy/"))
--
2.30.2
R
R
Roel Janssen wrote on 21 May 2021 13:11
75e4138959d7c235e5210095caae17d876765693.camel@gnu.org
Hi Felix,

On Fri, 2021-05-14 at 14:05 +0000, Felix Gruber wrote:
Toggle quote (53 lines)
> * gnu/packages/emulators.scm (sameboy): Update to 0.14.3.
> [native-inputs]: Remove gcc-9.
> [arguments]: Use cc-for-target instead of hard-coding gcc.
> ---
>  gnu/packages/emulators.scm | 9 +++++----
>  1 file changed, 5 insertions(+), 4 deletions(-)
>
> diff --git a/gnu/packages/emulators.scm b/gnu/packages/emulators.scm
> index 4367c23a6b..30cd2daf55 100644
> --- a/gnu/packages/emulators.scm
> +++ b/gnu/packages/emulators.scm
> @@ -14,6 +14,7 @@
>  ;;; Copyright © 2020 Jakub K?dzio?ka <kuba@kadziolka.net>
>  ;;; Copyright © 2020 Christopher Howard
> <christopher@librehacker.com>
>  ;;; Copyright © 2021 Felipe Balbi <balbi@kernel.org>
> +;;; Copyright © 2021 Felix Gruber <felgru@posteo.net>
>  ;;;
>  ;;; This file is part of GNU Guix.
>  ;;;
> @@ -637,7 +638,7 @@ and Game Boy Color games.")
>  (define-public sameboy
>    (package
>      (name "sameboy")
> -    (version "0.13.6")
> +    (version "0.14.3")
>      (source
>       (origin
>         (method git-fetch)
> @@ -646,17 +647,17 @@ and Game Boy Color games.")
>               (commit (string-append "v" version))))
>         (file-name (git-file-name name version))
>         (sha256
> -        (base32
> "04w8lybi7ssnax37ka4qw7pmcm7cgnmk90p9m73zbyp5chgpqqzc"))))
> +        (base32
> "1dipidx12ai62hnzf0pvnsk1cgjcmw1h5x2r7ilxq0k0pkia5b7a"))))
>      (build-system gnu-build-system)
>      (native-inputs
>       `(("rgbds" ,rgbds)
> -       ("gcc" ,gcc-9)
>         ("pkg-config" ,pkg-config)))
>      (inputs
>       `(("sdl2" ,sdl2)))
>      (arguments
>       `(#:tests? #f                      ; There are no tests
> -       #:make-flags `("CC=gcc" "NATIVE_CC=gcc" "CONF=release"
> +       #:make-flags `(,(string-append "CC=" ,(cc-for-target))
> +                      "NATIVE_CC=gcc" "CONF=release"
>                        ,(string-append "DATA_DIR="
>                                        (assoc-ref %outputs "out")
>                                        "/share/sameboy/"))

LGTM and pushed in 4bf2637c4947ad874821c58ca0eb2583753f5631.

Thank you!

Kind regards,
Roel Janssen
Closed
?