[PATCH 0/2] Add wfview

  • Done
  • quality assurance status badge
Details
One participant
  • Guillaume Le Vaillant
Owner
unassigned
Submitted by
Guillaume Le Vaillant
Severity
normal
G
G
Guillaume Le Vaillant wrote on 14 May 2021 09:27
(address . guix-patches@gnu.org)
87h7j5hj1f.fsf@kitej
Hi,

Here are patches adding qcustomplot and wfview.

For some reason upstream puts the sources and the makefile of
qcustomplot in different tarballs. I put the archive with the makefile
as native input using ",(origin (method url-fetch )...)".
Would you do it differently?

These two packages also have custom 'install' phases because the default
ones didn't install everything, or tried to install using a custom
script with hard-coded "/usr/..." paths.
-----BEGIN PGP SIGNATURE-----

iIUEAREKAC0WIQTLxZxm7Ce5cXlAaz5r6CCK3yH+PwUCYJ4mXA8cZ2x2QHBvc3Rl
by5uZXQACgkQa+ggit8h/j+abgD9Hp0qf2VraFSRRDIL999STxOLoiqRLwfiM/BT
7tE8L80BAJ4GYT7MB9sC1Tu0mzSWTWfJuq9O/HNfu+zRDevgWNHq
=4QPb
-----END PGP SIGNATURE-----

G
G
Guillaume Le Vaillant wrote on 14 May 2021 09:31
[PATCH 1/2] gnu: Add qcustomplot.
(address . 48411@debbugs.gnu.org)(name . Guillaume Le Vaillant)(address . glv@posteo.net)
20210514073139.5906-1-glv@posteo.net
* gnu/packages/qt.scm (qcustomplot): New variable.
---
gnu/packages/qt.scm | 51 +++++++++++++++++++++++++++++++++++++++++++++
1 file changed, 51 insertions(+)

Toggle diff (71 lines)
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index b206deaeba..55855fb68a 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -21,6 +21,7 @@
;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
;;; Copyright © 2020 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2021 Brendan Tildesley <mail@brendan.scot>
+;;; Copyright © 2021 Guillaume Le Vaillant <glv@posteo.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -2604,6 +2605,56 @@ color-related widgets.")
;; Includes a license exception for combining with GPL2 code.
(license license:lgpl3+))))
+(define-public qcustomplot
+ (package
+ (name "qcustomplot")
+ (version "2.1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://www.qcustomplot.com/release/"
+ version "fixed" "/QCustomPlot.tar.gz"))
+ (sha256
+ (base32 "1324kqyj1v1f8k8d7b15gc3apwz9qxx52p86hvchg33hjdlqhskx"))))
+ (native-inputs
+ `(("qcustomplot-sharedlib"
+ ,(origin
+ (method url-fetch)
+ (uri (string-append "https://www.qcustomplot.com/release/"
+ version "fixed" "/QCustomPlot-sharedlib.tar.gz"))
+ (sha256
+ (base32 "0vp8lpxvd1nlp4liqrlvslpqrgfn0wpiwizzdsjbj22zzb8vxikc"))))))
+ (inputs
+ `(("qtbase" ,qtbase)))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'unpack-extra-files
+ (lambda* (#:key inputs #:allow-other-keys)
+ (invoke "tar" "-xvf" (assoc-ref inputs "qcustomplot-sharedlib"))))
+ (replace 'configure
+ (lambda* (#:key outputs #:allow-other-keys)
+ (chdir "qcustomplot-sharedlib/sharedlib-compilation")
+ (substitute* "sharedlib-compilation.pro"
+ ;; Don't build debug library.
+ (("debug_and_release")
+ "release"))
+ (invoke "qmake"
+ (string-append "DESTDIR="
+ (assoc-ref outputs "out")
+ "/lib"))))
+ (add-after 'install 'install-header
+ (lambda* (#:key outputs #:allow-other-keys)
+ (install-file "../../qcustomplot.h"
+ (string-append (assoc-ref outputs "out")
+ "/include")))))))
+ (home-page "https://www.qcustomplot.com/")
+ (synopsis "Qt widget for plotting and data visualization")
+ (description
+ "QCustomPlot is a Qt C++ widget providing 2D plots, graphs and charts.")
+ (license license:gpl3+)))
+
(define-public python-shiboken-2
(package
(name "python-shiboken-2")
--
2.31.1
G
G
Guillaume Le Vaillant wrote on 14 May 2021 09:31
[PATCH 2/2] gnu: Add wfview.
(address . 48411@debbugs.gnu.org)(name . Guillaume Le Vaillant)(address . glv@posteo.net)
20210514073139.5906-2-glv@posteo.net
* gnu/packages/radio.scm (wfview): New variable.
---
gnu/packages/radio.scm | 69 ++++++++++++++++++++++++++++++++++++++++++
1 file changed, 69 insertions(+)

Toggle diff (79 lines)
diff --git a/gnu/packages/radio.scm b/gnu/packages/radio.scm
index c0898657a5..c142e5dfaf 100644
--- a/gnu/packages/radio.scm
+++ b/gnu/packages/radio.scm
@@ -1815,3 +1815,72 @@ voice formats.")
"SDRangel is a Qt software defined radio and signal analyzer frontend for
various hardware.")
(license license:gpl3+)))
+
+(define-public wfview
+ ;; No tagged release, use commit directly.
+ (let ((commit "274e905d214a7360e8cf2dd0421dbe3712a0ddcc")
+ (revision "1"))
+ (package
+ (name "wfview")
+ (version (git-version "20210511" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.com/eliggett/wfview")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1dmxn15xs63wx1y4mh1mlv8qc1xz32vgbyl3rk82gf6knw518svp"))))
+ (build-system qt-build-system)
+ (inputs
+ `(("qcustomplot" ,qcustomplot)
+ ("qtbase" ,qtbase)
+ ("qtmultimedia" ,qtmultimedia)
+ ("qtserialport" ,qtserialport)))
+ (arguments
+ `(#:tests? #f ; No test suite.
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'fix-paths
+ (lambda* (#:key outputs #:allow-other-keys)
+ (substitute* "wfview.pro"
+ (("\\.\\./wfview/")
+ "../"))
+ (substitute* '("wfmain.cpp")
+ (("/usr/share")
+ (string-append (assoc-ref outputs "out") "/share")))))
+ (replace 'configure
+ (lambda _
+ (mkdir-p "build")
+ (chdir "build")
+ (invoke "qmake" "../wfview.pro")))
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out")))
+ (install-file "wfview"
+ (string-append out "/bin"))
+ (install-file "wfview.png"
+ (string-append out "/share/pixmaps"))
+ (install-file "wfview.desktop"
+ (string-append out "/share/applications"))
+ (let ((dir (string-append
+ out "/share/wfview/stylesheets/qdarkstyle")))
+ (mkdir-p dir)
+ (copy-recursively "qdarkstyle" dir))))))))
+ (home-page "https://wfview.org/")
+ (synopsis "Software to control Icom radios")
+ (description
+ "@code{wfview} is a program to control modern Icom radios and view the
+spectrum waterfall. It supports at least the following models:
+
+@itemize
+@item IC-705
+@item IC-7300
+@item IC-7610
+@item IC-7850
+@item IC-7851
+@item IC-9700
+@end itemize\n")
+ (license (list license:expat
+ license:gpl3)))))
--
2.31.1
G
G
Guillaume Le Vaillant wrote on 19 May 2021 10:07
Re: [bug#48411] [PATCH 1/2] gnu: Add qcustomplot.
(address . 48411-done@debbugs.gnu.org)
87fsyj2ll8.fsf@kitej
Patches pushed as de444e0294ca3c4186cf9409a6d8a551434083ce and
following. Closing.
-----BEGIN PGP SIGNATURE-----

iIUEAREKAC0WIQTLxZxm7Ce5cXlAaz5r6CCK3yH+PwUCYKTHMw8cZ2x2QHBvc3Rl
by5uZXQACgkQa+ggit8h/j8v7wD/VtNU3zOG/HN0o9PEyJb8gk0YsPVU0u/eEc5Z
Nf4YVusA/2p+5Z1115AS3bBGBA7IDsEvImXhMxmdq/DTXed0bims
=CVCy
-----END PGP SIGNATURE-----

Closed
?