Guix 1.3 installer restarts after Partitioning Scheme

OpenSubmitted by alphantom.
Details
3 participants
  • alphantom
  • Ludovic Courtès
  • Mathieu Othacehe
Owner
unassigned
Severity
important
A
A
alphantom wrote on 12 May 16:23 +0200
(address . bug-guix@gnu.org)
M_Vxaqg--3-2@tutanota.com
Here's how I reproduced the possible bug:
Locale: EnglishLocale Location: United StatesChoose Graphical InstallTimezone: *not included due to privacy*Layout: English (US)Variant: English (US)Hostname: *Anything*Internet Access: WifiSubstitute server discovery: DisableSystem Admin PasswordUser CreationDesktop Environment: Emacs EXWMNetwork Service: OpenSSH, Mozilla NSS CertPartitioning Method: Guided - using entire disk with encryptionDisk: select hard drivePartitioning Scheme: Everything in one partition
** It then goes black**
You end up on back on Locale
-- Sent with Tutanota, the secure & ad-free mailbox: https://tutanota.com
Attachment: file
M
M
Mathieu Othacehe wrote on 13 May 10:49 +0200
(name . alphantom--- via Bug reports for GNU Guix)(address . bug-guix@gnu.org)
87im3nxbld.fsf@gnu.org
Hello,
Toggle quote (3 lines)> Disk: select hard drive> Partitioning Scheme: Everything in one partition
Thanks for the bug report. I definitely looks like an installercrash. Could you share the initial formatting of your disk (MSDOS orGPT and existing partitions) ?
Mathieu
L
L
Ludovic Courtès wrote on 13 May 22:56 +0200
control message for bug #48380
(address . control@debbugs.gnu.org)
87im3ms67j.fsf@gnu.org
severity 48380 importantquit
A
A
alphantom wrote on 15 May 11:11 +0200
Re: bug#48380: Guix 1.3 installer restarts after Partitioning Scheme
(name . Mathieu Othacehe)(address . othacehe@gnu.org)
M_jHo29--N-2@tutanota.com
Hi Mattheiu,
I'm using the default partitioning on the graphical installer. Apologies as I'm not really that familiar with disk formatting that's why I used the defaults of the installer.
-- Sent with Tutanota, the secure & ad-free mailbox: https://tutanota.com

May 13, 2021, 16:49 by othacehe@gnu.org:
Toggle quote (13 lines)>> Hello,>>> Disk: select hard drive>> Partitioning Scheme: Everything in one partition>>>> Thanks for the bug report. I definitely looks like an installer> crash. Could you share the initial formatting of your disk (MSDOS or> GPT and existing partitions) ?>> Mathieu>
Attachment: file
M
M
Mathieu Othacehe wrote 18 hours ago
(address . alphantom@tutanota.com)(address . 48380@debbugs.gnu.org)
87tum2gf1g.fsf@gnu.org
Hello,
This could be fixed by 154a4e046281c28e39b5016e965d3d937a2ea4a1.
Would it be possible for you to try to reproduce the issue with thisinstallation image: https://ci.guix.gnu.org/download/331?
It would also be great if you could switch to a TTY (cltr-alt-f3), run"fdisk -l" and report the output.
Thanks for your help,
Mathieu
?