[PATCH] gnu: racket: Update to 8.1.

  • Done
  • quality assurance status badge
Details
3 participants
  • Efraim Flashner
  • Jack Hill
  • Philip McGrath
Owner
unassigned
Submitted by
Philip McGrath
Severity
normal
P
P
Philip McGrath wrote on 9 May 2021 09:28
(address . guix-patches@gnu.org)(name . Philip McGrath)(address . philip@philipmcgrath.com)
20210509072852.1699567-1-philip@philipmcgrath.com
* gnu/packages/racket.scm (racket-minimal): Update to 8.1.
[arguments](#:phases): Remove 'patch-chez-configure: fixes applied upstream.
(racket): Update to 8.1.
---
gnu/packages/racket.scm | 36 +++---------------------------------
1 file changed, 3 insertions(+), 33 deletions(-)

Toggle diff (69 lines)
diff --git a/gnu/packages/racket.scm b/gnu/packages/racket.scm
index f2bbf28564..18af14b2ec 100644
--- a/gnu/packages/racket.scm
+++ b/gnu/packages/racket.scm
@@ -66,14 +66,14 @@
(define-public racket-minimal
(package
(name "racket-minimal")
- (version "8.0") ; note: remember to also update racket!
+ (version "8.1") ; note: remember to also update racket!
(source
(origin
(method url-fetch)
(uri (map (lambda (base)
(string-append base version "/racket-minimal-src.tgz"))
%installer-mirrors))
- (sha256 "0mwyffw4gcci8wmzxa3j28h03h0gsz55aard8qrk3lri8r2xyg21")
+ (sha256 "04zzqybpxss50n1jrwwq98539gw0y0ygpw9civl2sq3s4ww7m8l3")
(patches (search-patches
"racket-sh-via-rktio.patch"))))
(home-page "https://racket-lang.org")
@@ -100,36 +100,6 @@
(srfi srfi-1))
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'patch-chez-configure
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (substitute* "src/cs/c/Makefile.in"
- (("/bin/sh") (which "sh")))
- ;; TODO: Racket CS uses a fork of Chez Scheme.
- ;; Most of this is copy-pasted from the "chez.scm",
- ;; but maybe there's a way to reuse more directly.
- (with-directory-excursion "src/ChezScheme"
- (substitute* (find-files "mats" "Mf-.*")
- (("^[[:space:]]+(cc ) *") "\tgcc "))
- (substitute*
- (find-files "." (string-append
- "("
- "Mf-[a-zA-Z0-9.]+"
- "|Makefile[a-zA-Z0-9.]*"
- "|checkin"
- "|stex\\.stex"
- "|newrelease"
- "|workarea"
- "|unix\\.ms"
- "|^6\\.ms"
- ;;"|[a-zA-Z0-9.]+\\.ms" ; guile can't read
- ")"))
- (("/bin/rm") (which "rm"))
- (("/bin/ln") (which "ln"))
- (("/bin/cp") (which "cp"))
- (("/bin/echo") (which "echo")))
- (substitute* "makefiles/installsh"
- (("/bin/true") (which "true"))))
- #t))
(add-before 'configure 'pre-configure-minimal
(lambda* (#:key inputs #:allow-other-keys)
(chdir "src")
@@ -215,7 +185,7 @@ DrRacket IDE, are not included.")
%installer-mirrors))
(sha256
(base32
- "047wpjblfzmf1msz7snrp2c2h0zxyzlmbsqr9bwsyvz3frcg0888"))))
+ "0xdqwrwm604bbnr97h75dps2ixxz2svlw0fn0f674bn04dcfd60f"))))
(inputs
`(;; sqlite and libraries for `racket/draw' are needed to build the doc.
("cairo" ,cairo)
--
2.30.2
J
J
Jack Hill wrote on 9 May 2021 22:34
(name . Philip McGrath)(address . philip@philipmcgrath.com)(address . 48308@debbugs.gnu.org)
alpine.DEB.2.21.2105091630040.2109@marsh.hcoop.net
On Sun, 9 May 2021, Philip McGrath wrote:

Toggle quote (4 lines)
> * gnu/packages/racket.scm (racket-minimal): Update to 8.1.
> [arguments](#:phases): Remove 'patch-chez-configure: fixes applied upstream.
> (racket): Update to 8.1.

Thanks for making the update. I tested building both racket and
racket-minimal on x86_64, and was able to do a lite REPL session in each
one without problems.

Its nice that you CS building patch made it into upstream.
Congratulations.

Not related to the update, but I noticed `guix lint` complain about the
racket synopsis (it begins with an article). I think we could just drop
the 'a' and leave the rest of it as is and it would still make sense and
satisfy the linter.

Best,
Jack
P
P
Philip McGrath wrote on 9 May 2021 23:06
(name . Jack Hill)(address . jackhill@jackhill.us)(address . 48308@debbugs.gnu.org)
f4914fac-f493-2f08-6f15-e99ba1f37e0a@philipmcgrath.com
On 5/9/21 4:34 PM, Jack Hill wrote:
Toggle quote (5 lines)
> Not related to the update, but I noticed `guix lint` complain about the
> racket synopsis (it begins with an article). I think we could just drop
> the 'a' and leave the rest of it as is and it would still make sense and
> satisfy the linter.

Ah, yes, I had noticed that. It's not a big deal and I'm happy to defer
to community consensus. I had kept the "a" because it's a reference to
Felleisen et. al.'s "A Programmable Programming Language"
(Communications of the ACM, March 2018) [1], the title of which in turn
is a quote Foderaro's "LISP: Introduction" (Communications of the ACM,
September 1991) [2]:

> When Lisp adopts a new paradigm, it not only replicates
> existing practice, but goes beyond it to become a testbed
> for advancing the state of the art. Why has Lisp been able
> to adapt so easily when other languages have not? One
> reason is that Lisp is a *programmable* programming language.
> Not only can you program *in* Lisp (that makes it a programming
> language) but you can program the language itself.

[1]:

-Philip
E
E
Efraim Flashner wrote on 10 May 2021 15:13
(name . Jack Hill)(address . jackhill@jackhill.us)
YJkxcBlGCkxQVv+q@3900XT
On Sun, May 09, 2021 at 04:34:02PM -0400, Jack Hill wrote:
Toggle quote (18 lines)
> On Sun, 9 May 2021, Philip McGrath wrote:
>
> > * gnu/packages/racket.scm (racket-minimal): Update to 8.1.
> > [arguments](#:phases): Remove 'patch-chez-configure: fixes applied upstream.
> > (racket): Update to 8.1.
>
> Thanks for making the update. I tested building both racket and
> racket-minimal on x86_64, and was able to do a lite REPL session in each one
> without problems.
>
> Its nice that you CS building patch made it into upstream. Congratulations.
>
> Not related to the update, but I noticed `guix lint` complain about the
> racket synopsis (it begins with an article). I think we could just drop the
> 'a' and leave the rest of it as is and it would still make sense and satisfy
> the linter.
>

Thank you both, I'm taking this as confirmation that the package works.

Patch pushed!

--
Efraim Flashner <efraim@flashner.co.il> ????? ?????
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAmCZMW8ACgkQQarn3Mo9
g1HbzQ//fY1Ejn3c4HkCyVnwWVH7yeO5IPpC0IFZWunGRIHnWxiruiKUOdOosVsH
fDQ3wB/9t31NQfs/xsllRccqDZzJj6z39ULMewB402DQRGSUQkHKWAXK1VfyEsdn
YCuKDBxqK62/QJGk7ghzHNeKXL4UCa7/tyM+KMhal3LpCDYYryDwfcXgqe16ebZd
rSu7iera6tn8fbpj7RIOMDfp5mK20WSPr0MH9Yfl7P5wVHkhgsDQjcWpsiGo4nXL
cm+Rfd6FYUwdl3KekOaWFVo6I9tyZja7Ie0tB4wVcR8mLfVYrNwWCcvAcTXeYjOy
J+P7EUBwOKk7wQ4iIM/RzVIxT7N0wH2SZgd8uMBYm+dWJRfSYXK+2ZevY9myjvOc
pCXLLF3rZ+69/fYsprnnGUmjVW9iCrh3EWRz2EcBu9ox2IrhHofdce25PhptCmeV
oDMWBwWyNW/s759CRiuFX5cX/gBSSJdBRbtpWAzk1RqNkgCCW/jdPsadBVGaJaPu
BAiOXPAB915z87jb+aMA4aX6cqQP7dpwaqc5FhFEAwsHBfJybi0QipPk6flkUiAE
UXeUJ38+TF7XUWss854oushtXVkTf4261+UGOtAXCoXKLf5DinqNfbBoVubQqJl0
EwJPyrMhc+ydUiSJNvNNaYQo9rDD57nAaj2u+BWUDFIfugvt4CE=
=gPOw
-----END PGP SIGNATURE-----


Closed
?