[PATCH] gnu: Add xdg-desktop-portal-wlr.

  • Done
  • quality assurance status badge
Details
2 participants
  • Giacomo Leidi
  • Ludovic Courtès
Owner
unassigned
Submitted by
Giacomo Leidi
Severity
normal
G
G
Giacomo Leidi wrote on 8 May 2021 17:29
(address . guix-patches@gnu.org)(name . Giacomo Leidi)(address . goodoldpaul@autistici.org)
20210508152945.17190-1-goodoldpaul@autistici.org
* gnu/packages/freedesktop.scm (xdg-desktop-portal-wlr): New variable.
---
gnu/packages/freedesktop.scm | 33 +++++++++++++++++++++++++++++++++
1 file changed, 33 insertions(+)

Toggle diff (50 lines)
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index c82ad230d7..7f8da7f3e4 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -95,6 +95,7 @@
#:use-module (gnu packages python)
#:use-module (gnu packages python-crypto)
#:use-module (gnu packages python-xyz)
+ #:use-module (gnu packages samba)
#:use-module (gnu packages sqlite)
#:use-module (gnu packages valgrind)
#:use-module (gnu packages video)
@@ -2330,3 +2331,35 @@ which uses GTK+ and various pieces of GNOME infrastructure, such as the
@code{org.gnome.Shell.Screenshot} or @code{org.gnome.SessionManager} D-Bus
interfaces.")
(license license:lgpl2.1+)))
+
+(define-public xdg-desktop-portal-wlr
+ (package
+ (name "xdg-desktop-portal-wlr")
+ (version "0.3.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/emersion/xdg-desktop-portal-wlr")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "18nlkqqxgxh7k0r2nk867wnp2nmaiinl6z67lrfv7rmiym0x82p8"))))
+ (build-system meson-build-system)
+ (native-inputs
+ `(("cmake" ,cmake)
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("elogind" ,elogind)
+ ("iniparser" ,iniparser)
+ ("pipewire" ,pipewire-0.3)
+ ("wayland" ,wayland)
+ ("wayland-protocols" ,wayland-protocols)))
+ (home-page "https://github.com/emersion/xdg-desktop-portal-wlr")
+ (synopsis "@code{xdg-desktop-portal} backend for wlroots")
+ (description
+ "This package provides @code{xdg-desktop-portal-wlr}. This project
+seeks to add support for the screenshot, screencast, and possibly
+remote-desktop @code{xdg-desktop-portal} interfaces for wlroots based
+compositors.")
+ (license license:expat)))
--
2.31.1
L
L
Ludovic Courtès wrote on 14 May 2021 12:21
(name . Giacomo Leidi)(address . goodoldpaul@autistici.org)(address . 48288-done@debbugs.gnu.org)
875yzlpqdi.fsf@gnu.org
Hi Giacomo,

Giacomo Leidi <goodoldpaul@autistici.org> skribis:

Toggle quote (2 lines)
> * gnu/packages/freedesktop.scm (xdg-desktop-portal-wlr): New variable.

Applied, thanks!

Ludo’.
Closed
?