[PATCH] gnu: Add guile-raw-strings.

  • Done
  • quality assurance status badge
Details
3 participants
  • Ludovic Courtès
  • Maxime Devos
  • Xinglu Chen
Owner
unassigned
Submitted by
Xinglu Chen
Severity
normal
X
X
Xinglu Chen wrote on 8 May 2021 16:01
(address . guix-patches@gnu.org)
97bc884cb5366248ad26aaac6a4c573a4a159a7d.1620482502.git.public@yoctocell.xyz
* gnu/packages/guile-xyz.scm (guile-raw-strings): New variable.
---
gnu/packages/guile-xyz.scm | 31 +++++++++++++++++++++++++++++++
1 file changed, 31 insertions(+)

Toggle diff (46 lines)
diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index f908fb8a3b..f596defe44 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -2106,6 +2106,37 @@ microAdapton. Both miniAdapton and microAdapton are designed to be easy to
understand, extend, and port to host languages other than Scheme.")
(license license:expat))))
+(define-public guile-raw-strings
+ (let ((commit "aa1cf783f2542811b473f797e12490920b779baa")
+ (revision "0"))
+ (package
+ (name "guile-raw-strings")
+ (version (git-version "0.0.0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/lloda/guile-raw-strings")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1r2gx86zw5hb6byllra3nap3fw9p7q7rvdmg6qn9myrdxyjpns3l"))))
+ (build-system guile-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'build 'check
+ (lambda _
+ (invoke "guile" "-L" "." "-s" "test.scm"))))))
+ (native-inputs
+ `(("guile" ,guile-3.0)))
+ (home-page "https://github.com/lloda/guile-raw-strings")
+ (synopsis "Guile reader extension for `raw strings'")
+ (description "This package provides A Guile reader extension for `raw
+strings', it lets you write verbatim strings without having to escape double
+quotes. ")
+ (license license:public-domain))))
+
(define-public guile-reader
(package
(name "guile-reader")

base-commit: e5adaf6c2de917f33f90e24b551a8991e55b3eb6
--
2.31.1
M
M
Maxime Devos wrote on 8 May 2021 23:18
911027b2494e5523fcd3a15a77a08a3fdc7d784c.camel@telenet.be
Toggle quote (4 lines)
> + (add-after 'build 'check
> + (lambda _
> + (invoke "guile" "-L" "." "-s" "test.scm"))))))

To support "guix build --without-tests", make this

Toggle quote (5 lines)
> + (add-after 'build 'check
> + (lambda* (#:key tests? #:allow-other-keys)
> + (when tests?
> + (invoke "guile" "-L" "." "-s" "test.scm")))))))

Greetings,Maxime.
-----BEGIN PGP SIGNATURE-----

iI0EABYKADUWIQTB8z7iDFKP233XAR9J4+4iGRcl7gUCYJcAOhccbWF4aW1lZGV2
b3NAdGVsZW5ldC5iZQAKCRBJ4+4iGRcl7tzzAQCDF2PV2fWCJ5zoXWhcOm+pkj7S
bx47NuhyFV78N44oJAD9HkKbahbgSxdbv7/l/kf59xwxNX2ISQO/eYfo+LXcMAI=
=N1qs
-----END PGP SIGNATURE-----


X
X
Xinglu Chen wrote on 9 May 2021 10:12
871ragiav7.fsf@yoctocell.xyz
On Sat, May 08 2021, Maxime Devos wrote:

Toggle quote (11 lines)
>> + (add-after 'build 'check
>> + (lambda _
>> + (invoke "guile" "-L" "." "-s" "test.scm"))))))
>
> To support "guix build --without-tests", make this
>
>> + (add-after 'build 'check
>> + (lambda* (#:key tests? #:allow-other-keys)
>> + (when tests?
>> + (invoke "guile" "-L" "." "-s" "test.scm")))))))

Thanks for taking a look. :)
X
X
Xinglu Chen wrote on 9 May 2021 10:18
[PATCH v2] gnu: Add guile-raw-strings.
(address . 48287@debbugs.gnu.org)
cc745e1e813d31ed96639c90c86eb45fb1032b1e.1620548230.git.public@yoctocell.xyz
* gnu/packages/guile-xyz.scm (guile-raw-strings): New variable.
---
Changes since v1:
- Respect the ‘--without-tests’ package tranformation.

gnu/packages/guile-xyz.scm | 32 ++++++++++++++++++++++++++++++++
1 file changed, 32 insertions(+)

Toggle diff (47 lines)
diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index f908fb8a3b..35e580a804 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -2106,6 +2106,38 @@ microAdapton. Both miniAdapton and microAdapton are designed to be easy to
understand, extend, and port to host languages other than Scheme.")
(license license:expat))))
+(define-public guile-raw-strings
+ (let ((commit "aa1cf783f2542811b473f797e12490920b779baa")
+ (revision "0"))
+ (package
+ (name "guile-raw-strings")
+ (version (git-version "0.0.0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/lloda/guile-raw-strings")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1r2gx86zw5hb6byllra3nap3fw9p7q7rvdmg6qn9myrdxyjpns3l"))))
+ (build-system guile-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'build 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "guile" "-L" "." "-s" "test.scm")))))))
+ (native-inputs
+ `(("guile" ,guile-3.0)))
+ (home-page "https://github.com/lloda/guile-raw-strings")
+ (synopsis "Guile reader extension for `raw strings'")
+ (description "This package provides A Guile reader extension for `raw
+strings', it lets you write verbatim strings without having to escape double
+quotes. ")
+ (license license:public-domain))))
+
(define-public guile-reader
(package
(name "guile-reader")

base-commit: e5adaf6c2de917f33f90e24b551a8991e55b3eb6
--
2.31.1
L
L
Ludovic Courtès wrote on 14 May 2021 12:14
Re: bug#48287: [PATCH] gnu: Add guile-raw-strings.
(name . Xinglu Chen)(address . public@yoctocell.xyz)(address . 48287-done@debbugs.gnu.org)
87pmxtpqpj.fsf_-_@gnu.org
Hi,

Xinglu Chen <public@yoctocell.xyz> skribis:

Toggle quote (2 lines)
> * gnu/packages/guile-xyz.scm (guile-raw-strings): New variable.

Applied! Thank you, and thanks, Maxime!

Ludo’.
Closed
?