[PATCH] gnu: Add emacs-cwl-mode.

  • Done
  • quality assurance status badge
Details
2 participants
  • Arun Isaac
  • Xinglu Chen
Owner
unassigned
Submitted by
Arun Isaac
Severity
normal
A
A
Arun Isaac wrote on 8 May 2021 15:29
(address . guix-patches@gnu.org)(name . Arun Isaac)(address . arunisaac@systemreboot.net)
20210508132910.3930-1-arunisaac@systemreboot.net
* gnu/packages/emacs-xyz.scm (emacs-cwl-mode): New variable.
---
gnu/packages/emacs-xyz.scm | 25 ++++++++++++++++++++++++-
1 file changed, 24 insertions(+), 1 deletion(-)

Toggle diff (42 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 869f8c3c7b..7ba9ef4148 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -16,7 +16,7 @@
;;; Copyright © 2016, 2019 Alex Griffin <a@ajgrf.com>
;;; Copyright © 2016, 2017, 2018, 2019, 2020, 2021 Nicolas Goaziou <mail@nicolasgoaziou.fr>
;;; Copyright © 2016, 2017, 2018 Alex Vong <alexvong1995@gmail.com>
-;;; Copyright © 2016, 2017, 2018, 2019, 2020 Arun Isaac <arunisaac@systemreboot.net>
+;;; Copyright © 2016, 2017, 2018, 2019, 2020, 2021 Arun Isaac <arunisaac@systemreboot.net>
;;; Copyright © 2017 Christopher Baines <mail@cbaines.net>
;;; Copyright © 2017, 2018, 2019, 2020 Mathieu Othacehe <m.othacehe@gmail.com>
;;; Copyright © 2017, 2018, 2019, 2020, 2021 Clément Lassieur <clement@lassieur.org>
@@ -27881,3 +27881,26 @@ files, providing syntax highlighting and indentation rules.")
quasi-prefix map, with many useful bindings. These bindings are
shorter than usual, using mostly unprefixed keys.")
(license license:gpl3+)))
+
+(define-public emacs-cwl-mode
+ (package
+ (name "emacs-cwl-mode")
+ (version "0.2.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/tom-tan/cwl-mode")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "04xqnm27y1h9z8csjpys4v3lkgn5kvpw9n4q94pbrvjgmz0qfp58"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ `(("emacs-yaml-mode" ,emacs-yaml-mode)))
+ (home-page "https://github.com/tom-tan/cwl-mode")
+ (synopsis "Emacs mode for Common Workflow Language (CWL) files")
+ (description "This packages provides a major mode for editing Common
+Workflow Language (CWL) files.")
+ (license license:gpl3+)))
--
2.31.0
X
X
Xinglu Chen wrote on 8 May 2021 16:16
(name . Arun Isaac)(address . arunisaac@systemreboot.net)
878s4pia4w.fsf@yoctocell.xyz
On Sat, May 08 2021, Arun Isaac wrote:

Toggle quote (8 lines)
> * gnu/packages/emacs-xyz.scm (emacs-cwl-mode): New variable.
>
> [...]
>
> + (synopsis "Emacs mode for Common Workflow Language (CWL) files")
> + (description "This packages provides a major mode for editing Common
> +Workflow Language (CWL) files.")

Nitpick: use @acronym{} maybe?

Builds fine on my end. :)
A
A
Arun Isaac wrote on 8 May 2021 19:51
87fsyxyuz7.fsf@systemreboot.net
Toggle quote (2 lines)
> Nitpick: use @acronym{} maybe?

That's a good suggestion. I added @acronym, updated the package and
pushed to master. Thanks for the review! :-)
-----BEGIN PGP SIGNATURE-----

iQFPBAEBCAA5FiEEf3MDQ/Lwnzx3v3nTLiXui2GAK7MFAmCWz6wbHGFydW5pc2Fh
Y0BzeXN0ZW1yZWJvb3QubmV0AAoJEC4l7othgCuz6eAH/iLEN4+H2fKqCLUljUnS
6XNWcKUIhlpaoycJ5JVBLiEUzwjRZ4ZR9t51Dpgckl4RqoYR6F4B8fHSWyEqh8Vc
lqZVf5YSfYdX8IlWC8NVex5OSFtM/sxk4jn3bkG85OpDFOJjFgqCSErjWlRva4KG
FuXjpHIleEfnA+2oS4ZjWWHL52hqG1IiWUm/kCf9kcq77w/XGU40xkKDgTqG+fP6
+UvE+ynzGXSdCgO86cJ5seKVPHAWV0mJ6dxsSU1zjUWurN+SHLEGf0IP3FCQ5Q5C
uBJcwAnZRswrf0r8Vta2shqVoXPKsQcBEQHDEdIw6vMVQhCn3xIy/R38Dl8NiZA7
5Zo=
=mHDQ
-----END PGP SIGNATURE-----

Closed
?