[PATCH] gnu: Add interbench.

  • Done
  • quality assurance status badge
Details
2 participants
  • Arun Isaac
  • Ludovic Courtès
Owner
unassigned
Submitted by
Arun Isaac
Severity
normal
A
A
Arun Isaac wrote on 8 May 2021 15:13
(address . guix-patches@gnu.org)(name . Arun Isaac)(address . arunisaac@systemreboot.net)
20210508131357.3012-1-arunisaac@systemreboot.net
* gnu/packages/benchmark.scm (interbench): New variable.
---
gnu/packages/benchmark.scm | 39 ++++++++++++++++++++++++++++++++++++++
1 file changed, 39 insertions(+)

Toggle diff (56 lines)
diff --git a/gnu/packages/benchmark.scm b/gnu/packages/benchmark.scm
index 2fc4082ed1..b7bb332fc7 100644
--- a/gnu/packages/benchmark.scm
+++ b/gnu/packages/benchmark.scm
@@ -10,6 +10,7 @@
;;; Copyright © 2020 malte Frank Gerdes <malte.f.gerdes@gmail.com>
;;; Copyright © 2020, 2021 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2020 Greg Hogan <code@greghogan.com>
+;;; Copyright © 2021 Arun Isaac <arunisaac@systemreboot.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -353,3 +354,41 @@ Note: Locust will complain if the available open file descriptors limit for
the user is too low. To raise such limit on a Guix System, refer to
@samp{info guix --index-search=pam-limits-service}.")
(license license:expat)))
+
+(define-public interbench
+ (package
+ (name "interbench")
+ (version "0.31")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ckolivas/interbench")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0ifnw8vnkcgrksx7g5d9ii4kjppqnk32lvrybdybmibyvag6zfdc"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ; no tests
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'fix-broken-makefile
+ (lambda _
+ ;; Remove erroneous "-lm" target
+ (substitute* "Makefile"
+ (("hackbench.o -lm") "hackbench.o"))))
+ (delete 'configure)
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ (install-file "interbench" (string-append out "/bin"))
+ (install-file "interbench.8" (string-append out "/share/man/man8"))))))))
+ (home-page "http://users.on.net/~ckolivas/interbench/")
+ (synopsis "Interactivity benchmark")
+ (description "interbench is designed to benchmark interactivity on Linux.
+It is designed to measure the effect of changes in Linux kernel design or
+system configuration changes such as CPU, I/O scheduler and filesystem changes
+and options. With careful benchmarking, different hardware can be compared.")
+ (license license:gpl2+)))
--
2.31.0
L
L
Ludovic Courtès wrote on 14 May 2021 12:19
(name . Arun Isaac)(address . arunisaac@systemreboot.net)(address . 48285@debbugs.gnu.org)
87czttpqhz.fsf@gnu.org
Hi Arun,

Arun Isaac <arunisaac@systemreboot.net> skribis:

Toggle quote (2 lines)
> * gnu/packages/benchmark.scm (interbench): New variable.

LGTM, thanks!

Ludo’.
A
A
Arun Isaac wrote on 15 May 2021 09:57
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 48285-done@debbugs.gnu.org)
87r1i8e8fa.fsf@systemreboot.net
Toggle quote (4 lines)
>> * gnu/packages/benchmark.scm (interbench): New variable.
>
> LGTM, thanks!

Pushed, thanks for the review! :-)
-----BEGIN PGP SIGNATURE-----

iQFPBAEBCAA5FiEEf3MDQ/Lwnzx3v3nTLiXui2GAK7MFAmCfftkbHGFydW5pc2Fh
Y0BzeXN0ZW1yZWJvb3QubmV0AAoJEC4l7othgCuzESgH/0K9ZXanOITdXuyZZzk2
perz5TwFJv/0MsUB5In8Eyqu9h++QNtKlUM+IYBjVRB2AObCvsnCr20MC9xWpllA
jV6hKbbkZF4xYCn1UuWHTmgfPJBtJsMTDpudrqATcpU9Ii3xNrXjjTSndhVGq43M
u2P0njR6iYewyzAKNy/ly7ikFLEBhvPMf1fMRQjbGj6e8HncmuV7wtxSpusPi3OV
TElyrTWrJsjdAWHNyE2zQXvCdXRi7+i2ZQ5pDmGkSIkqI9udcuogJsh2AfjnCh88
M+bztabjflCmhgwJcZJ1f+qV+wgDEbqOftRSVgTeyQRtUtNkw/29WPezBXCQUYNN
ODQ=
=WDxr
-----END PGP SIGNATURE-----

Closed
?