[PATCH] gnu: xboard: Set default engine to gnuchess.

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Michael Rohleder
Owner
unassigned
Submitted by
Michael Rohleder
Severity
normal
M
M
Michael Rohleder wrote on 4 May 2021 01:07
(address . guix-patches@gnu.org)(name . Michael Rohleder)(address . mike@rohleder.de)
20210503230728.16491-1-mike@rohleder.de

* gnu/packages/games.scm (xboard): Set default engine to gnuchess.
[arguments]: Add phase 'patch-default-engine.
[inputs]: Add chess.
---
gnu/packages/games.scm | 12 ++++++++++--
1 file changed, 10 insertions(+), 2 deletions(-)

Toggle diff (27 lines)
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 073e41eec6..b394e0e5e9 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -3332,10 +3332,18 @@ exec ~a/bin/freedink -refdir ~a/share/dink\n"
(lambda* (#:key inputs #:allow-other-keys)
(substitute* "xboard.conf"
(("aplay -q")
- (string-append (assoc-ref inputs "alsa-utils") "/bin/aplay -q")))
- #t)))))
+ (string-append (assoc-ref inputs "alsa-utils") "/bin/aplay -q")))))
+ ;; Fixes https://issues.guix.gnu.org/45236.
+ (add-after 'unpack 'patch-default-engine
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "xboard.conf"
+ (("-firstChessProgram fairymax")
+ (string-append "-firstChessProgram "
+ (assoc-ref inputs "chess")
+ "/bin/gnuchessx"))))))))
(inputs
`(("alsa-utils" ,alsa-utils)
+ ("chess" ,chess)
("gtk+" ,gtk+-2)
("librsvg" ,librsvg)))
(native-inputs
--
2.31.1
L
L
Ludovic Courtès wrote on 5 May 2021 15:28
(name . Michael Rohleder)(address . mike@rohleder.de)(address . 48210-done@debbugs.gnu.org)
87r1iljomw.fsf@gnu.org
Hi,

Michael Rohleder <mike@rohleder.de> skribis:

Toggle quote (6 lines)
>
> * gnu/packages/games.scm (xboard): Set default engine to gnuchess.
> [arguments]: Add phase 'patch-default-engine.
> [inputs]: Add chess.

Applied, thanks!

One remaining issue, a minor one, is:

Toggle snippet (3 lines)
/gnu/store/sf57176zicjqrjz4whh84qspqr4n590j-xboard-4.9.1/share/games/xboard/sounds/woodthunk.wav: Dosiero a? dosierujo ne ekzistas

:-)

Ludo’.
Closed
?