[PATCH] - added 'telescope' gemini client with a terminal interface.

  • Done
  • quality assurance status badge
Details
2 participants
  • cage
  • Nicolas Goaziou
Owner
unassigned
Submitted by
cage
Severity
normal
C
(address . guix-patches@gnu.org)
YIVva04T5jA/inAI@kurosawa.casa.net
---
gnu/packages/web-browsers.scm | 23 +++++++++++++++++++++++
1 file changed, 23 insertions(+)

Toggle diff (33 lines)
diff --git a/gnu/packages/web-browsers.scm b/gnu/packages/web-browsers.scm
index 50c3e69321..8e8895ae2e 100644
--- a/gnu/packages/web-browsers.scm
+++ b/gnu/packages/web-browsers.scm
@@ -907,3 +907,26 @@ http, and https via third-party applications.")
interface.")
(home-page "https://www.autistici.org/interzona/tinmop.html")
(license license:gpl3+)))
+
+(define-public telescope
+ (package
+ (name "telescope")
+ (version "0.1.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/omar-polo/telescope/releases/download/0.1.1/telescope-"
+ version
+ ".tar.gz"))
+ (sha256 (base32 "04rzpjfldq10xkhcr6dfniwscxkjbrfkd8mbm3327xgq3n0qjbis"))))
+ (build-system gnu-build-system)
+ (inputs
+ `(("ncurses" ,ncurses)
+ ("libressl" ,libressl)
+ ("libevent" ,libevent)))
+ (arguments
+ `(#:tests? #f))
+ (synopsis "Gemini client with a terminal interface")
+ (description "Gemini client with a terminal interface")
+ (home-page "https://git.omarpolo.com/telescope/about/")
+ (license license:x11)))
--
2.31.1
N
N
Nicolas Goaziou wrote on 12 Jun 2021 23:17
(name . cage)(address . cage-dev@twistfold.it)(address . 48017-done@debbugs.gnu.org)
87tum2rddy.fsf@nicolasgoaziou.fr
Hello,

cage <cage-dev@twistfold.it> writes:

Toggle quote (5 lines)
> +(define-public telescope
> + (package
> + (name "telescope")
> + (version "0.1.1")

Thank you. I updated it to 0.2, expounded the description into a full
sentence and applied your patch.

Regards,
--
Nicolas Goaziou
Closed
C
(name . Nicolas Goaziou)(address . mail@nicolasgoaziou.fr)
YMUnmApoxxOOw56v@kurosawa.casa.net
On Sat, Jun 12, 2021 at 11:17:45PM +0200, Nicolas Goaziou wrote:

Hi!

[...]

Toggle quote (3 lines)
> Thank you. I updated it to 0.2, expounded the description into a full
> sentence and applied your patch.

Thanks a lot!!
C.
Closed
?