[PATCH] channels: Add a #:system argument to channel-instances->manifest.

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Christopher Baines
Owner
unassigned
Submitted by
Christopher Baines
Severity
normal
C
C
Christopher Baines wrote on 24 Apr 2021 10:14
(address . guix-patches@gnu.org)
20210424081402.26742-1-mail@cbaines.net
This allows computing a manifest for a specific system. Previously this was
possible, but only through changing %current-system, which caused the
derivation to be computed using that system as well (so computing a derivation
for aarch64-linux on x86_64-linux would require running aarch64-linux code).

This new argument adds the possibility of computing derivations for non-native
systems, without having to run non-native code.

I'm looking at this as it will enable the Guix Data Service to compute channel
instance derivations without relying on QEMU emulation for non-native
systems (it should be faster as well).

* guix/channels.scm (build-from-source): Add #:system argument and pass to
build.
(build-channel-instance): Add system argument and pass to build-from-source.
(channel-instance-derivations): Add #:system argument and pass to
build-channel-instance, also rename system to current-system-value.
(channel-instances->manifest): Add #:system argument and pass to
channel-instance-derivations.
---
guix/channels.scm | 22 +++++++++++++---------
1 file changed, 13 insertions(+), 9 deletions(-)

Toggle diff (87 lines)
diff --git a/guix/channels.scm b/guix/channels.scm
index c40fc0c507..70a09e74ff 100644
--- a/guix/channels.scm
+++ b/guix/channels.scm
@@ -657,7 +657,7 @@ that unconditionally resumes the continuation."
store))))
(define* (build-from-source instance
- #:key core verbose? (dependencies '()))
+ #:key core verbose? (dependencies '()) system)
"Return a derivation to build Guix from INSTANCE, using the self-build
script contained therein. When CORE is true, build package modules under
SOURCE using CORE, an instance of Guix."
@@ -700,20 +700,22 @@ SOURCE using CORE, an instance of Guix."
(with-trivial-build-handler
(build source
#:verbose? verbose? #:version commit
+ #:system system
#:channel-metadata (channel-instance->sexp instance)
#:pull-version %pull-version))))
;; Build a set of modules that extend Guix using the standard method.
(standard-module-derivation name source core dependencies)))
-(define* (build-channel-instance instance
+(define* (build-channel-instance instance system
#:optional core (dependencies '()))
"Return, as a monadic value, the derivation for INSTANCE, a channel
instance. DEPENDENCIES is a list of extensions providing Guile modules that
INSTANCE depends on."
(build-from-source instance
#:core core
- #:dependencies dependencies))
+ #:dependencies dependencies
+ #:system system))
(define (resolve-dependencies instances)
"Return a procedure that, given one of the elements of INSTANCES, returns
@@ -743,7 +745,7 @@ list of instances it depends on."
(lambda (instance)
(vhash-foldq* cons '() instance edges)))
-(define (channel-instance-derivations instances)
+(define* (channel-instance-derivations instances #:key system)
"Return the list of derivations to build INSTANCES, in the same order as
INSTANCES."
(define core-instance
@@ -757,14 +759,15 @@ INSTANCES."
(resolve-dependencies instances))
(define (instance->derivation instance)
- (mlet %store-monad ((system (current-system)))
+ (mlet %store-monad ((current-system-value (current-system)))
(mcached (if (eq? instance core-instance)
- (build-channel-instance instance)
+ (build-channel-instance instance system)
(mlet %store-monad ((core (instance->derivation core-instance))
(deps (mapm %store-monad instance->derivation
(edges instance))))
- (build-channel-instance instance core deps)))
+ (build-channel-instance instance system core deps)))
instance
+ current-system-value
system)))
(unless core-instance
@@ -865,7 +868,7 @@ derivation."
intro))))))
'()))))
-(define (channel-instances->manifest instances)
+(define* (channel-instances->manifest instances #:key system)
"Return a profile manifest with entries for all of INSTANCES, a list of
channel instances."
(define (instance->entry instance drv)
@@ -883,7 +886,8 @@ channel instances."
(properties
`((source ,(channel-instance->sexp instance)))))))
- (mlet* %store-monad ((derivations (channel-instance-derivations instances))
+ (mlet* %store-monad ((derivations (channel-instance-derivations instances
+ #:system system))
(entries -> (map instance->entry instances derivations)))
(return (manifest entries))))
--
2.30.1
L
L
Ludovic Courtès wrote on 3 May 2021 22:56
(name . Christopher Baines)(address . mail@cbaines.net)(address . 47989@debbugs.gnu.org)
877dkfv8n4.fsf@gnu.org
Hi,

Christopher Baines <mail@cbaines.net> skribis:

Toggle quote (5 lines)
> This allows computing a manifest for a specific system. Previously this was
> possible, but only through changing %current-system, which caused the
> derivation to be computed using that system as well (so computing a derivation
> for aarch64-linux on x86_64-linux would require running aarch64-linux code).

I remember discussing it, but I wonder if I was confused.

I think you can always do the equivalent of (say):

guix time-machine -- build -s armhf-linux hello -d

… where Guix itself is built natively but it then computes a derivation
for a different architecture.

The equivalent code would be roughly:

(let ((inferior (inferior-for-channels …)))
(inferior-package-derivation store
(car (lookup-inferior-packages inferior "hello"))
"armhf-linux"))

Does that make sense?

(You may also want to turn off grafts in the inferior.)

Ludo’.
C
C
Christopher Baines wrote on 3 May 2021 23:35
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 47989@debbugs.gnu.org)
87im3zcxfu.fsf@cbaines.net
Ludovic Courtès <ludo@gnu.org> writes:

Toggle quote (25 lines)
> Christopher Baines <mail@cbaines.net> skribis:
>
>> This allows computing a manifest for a specific system. Previously this was
>> possible, but only through changing %current-system, which caused the
>> derivation to be computed using that system as well (so computing a derivation
>> for aarch64-linux on x86_64-linux would require running aarch64-linux code).
>
> I remember discussing it, but I wonder if I was confused.
>
> I think you can always do the equivalent of (say):
>
> guix time-machine -- build -s armhf-linux hello -d
>
> … where Guix itself is built natively but it then computes a derivation
> for a different architecture.
>
> The equivalent code would be roughly:
>
> (let ((inferior (inferior-for-channels …)))
> (inferior-package-derivation store
> (car (lookup-inferior-packages inferior "hello"))
> "armhf-linux"))
>
> Does that make sense?

Not really, this is just about manifests for channel instances, so
nothing to do with package derivations as far as I'm aware.
-----BEGIN PGP SIGNATURE-----

iQKlBAEBCgCPFiEEPonu50WOcg2XVOCyXiijOwuE9XcFAmCQbLVfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcRHG1haWxAY2Jh
aW5lcy5uZXQACgkQXiijOwuE9Xe2lw/9HG040zlINb539khwRpLC1JJgbBz+S4gq
ELdKaIsIwSnV9KvGh6Oynvo8wXgjjhMuhWs13tZ5T6C147cDYa5BMH6O0UT2XU0o
oRTNvvA/KHpDAYquYQiSVn8oifok4POe75jLCMlRlOqJmNc7SF1E3bCdXqjpauAh
ZR19qbwicK53M+V/UuoXqamhKp1/4duqkQ6MLvuwQK+9PU26V4WzF+DpIv4CHeFA
BDRW1xjVamHmYBVU/Cs8ItGVZGd045uDtjLjQTxnEx0UYi28XGXhJxsYFjwqwBcs
5G4dHgqqUgJnuWfdhZn6FKNFga6ccKLv928Yu/CHiBCc8zUOU4TAkDs0kVq8HKiJ
ziS/kTYgIJzSM4y2rKpZ6uX72Xp2KT1w1uP+qOSoReIDWCyBtTqqcvPuw1gVtIFg
MWPE0dX+sykHOOxFga585sYNlxbZn8PkkNl7bYIDEKEUELmQTrZAdHbP5S2Itz/v
AiSegI/v3gP2uOp0mpsCDcRGAx+2yaXGKTannVqU1tk0KP7vqRDIAv3Izp3zaDW4
WSYLlwlH4Fi3Epeierh16lX+QzCFKdun3Y2YB91MM/YDapn1XjhJJS1DR7jwC7w0
0GVYnOXLUBM0iJTGF9xlxsHrsuiB3u3frcQO2fXbIbOIFbat4zv5scy63ilKpa/U
AbbhWSrwXKM=
=P1Oz
-----END PGP SIGNATURE-----

L
L
Ludovic Courtès wrote on 4 May 2021 15:48
(name . Christopher Baines)(address . mail@cbaines.net)(address . 47989@debbugs.gnu.org)
87eeemr4nu.fsf@gnu.org
Hi Christopher,

Christopher Baines <mail@cbaines.net> skribis:

Toggle quote (29 lines)
> Ludovic Courtès <ludo@gnu.org> writes:
>
>> Christopher Baines <mail@cbaines.net> skribis:
>>
>>> This allows computing a manifest for a specific system. Previously this was
>>> possible, but only through changing %current-system, which caused the
>>> derivation to be computed using that system as well (so computing a derivation
>>> for aarch64-linux on x86_64-linux would require running aarch64-linux code).
>>
>> I remember discussing it, but I wonder if I was confused.
>>
>> I think you can always do the equivalent of (say):
>>
>> guix time-machine -- build -s armhf-linux hello -d
>>
>> … where Guix itself is built natively but it then computes a derivation
>> for a different architecture.
>>
>> The equivalent code would be roughly:
>>
>> (let ((inferior (inferior-for-channels …)))
>> (inferior-package-derivation store
>> (car (lookup-inferior-packages inferior "hello"))
>> "armhf-linux"))
>>
>> Does that make sense?
>
> Not really,

:-)

Toggle quote (3 lines)
> this is just about manifests for channel instances, so nothing to do
> with package derivations as far as I'm aware.

I re-read your message and must have misunderstood. It’s the derivation
of channel instances that you want for a given system, right? (What’s
the use case though?) In that case something along the lines of the
patch makes perfect sense.

Thanks,
Ludo’.
L
L
Ludovic Courtès wrote on 4 May 2021 15:52
(name . Christopher Baines)(address . mail@cbaines.net)(address . 47989@debbugs.gnu.org)
878s4ur4gq.fsf@gnu.org
Christopher Baines <mail@cbaines.net> skribis:

Toggle quote (20 lines)
> This allows computing a manifest for a specific system. Previously this was
> possible, but only through changing %current-system, which caused the
> derivation to be computed using that system as well (so computing a derivation
> for aarch64-linux on x86_64-linux would require running aarch64-linux code).
>
> This new argument adds the possibility of computing derivations for non-native
> systems, without having to run non-native code.
>
> I'm looking at this as it will enable the Guix Data Service to compute channel
> instance derivations without relying on QEMU emulation for non-native
> systems (it should be faster as well).
>
> * guix/channels.scm (build-from-source): Add #:system argument and pass to
> build.
> (build-channel-instance): Add system argument and pass to build-from-source.
> (channel-instance-derivations): Add #:system argument and pass to
> build-channel-instance, also rename system to current-system-value.
> (channel-instances->manifest): Add #:system argument and pass to
> channel-instance-derivations.

[...]

Toggle quote (7 lines)
> (define* (build-from-source instance
> - #:key core verbose? (dependencies '()))
> + #:key core verbose? (dependencies '()) system)
> "Return a derivation to build Guix from INSTANCE, using the self-build
> script contained therein. When CORE is true, build package modules under
> SOURCE using CORE, an instance of Guix."

Please mention SYSTEM in the docstring.

Toggle quote (22 lines)
> +(define* (channel-instance-derivations instances #:key system)
> "Return the list of derivations to build INSTANCES, in the same order as
> INSTANCES."
> (define core-instance
> @@ -757,14 +759,15 @@ INSTANCES."
> (resolve-dependencies instances))
>
> (define (instance->derivation instance)
> - (mlet %store-monad ((system (current-system)))
> + (mlet %store-monad ((current-system-value (current-system)))
> (mcached (if (eq? instance core-instance)
> - (build-channel-instance instance)
> + (build-channel-instance instance system)
> (mlet %store-monad ((core (instance->derivation core-instance))
> (deps (mapm %store-monad instance->derivation
> (edges instance))))
> - (build-channel-instance instance core deps)))
> + (build-channel-instance instance system core deps)))
> instance
> + current-system-value
> system)))

Here, there should not be any additional key to ‘mcached’ since there’s
only one system being targeted.

Instead, it should look something like this:

(define (instance->derivation core-instance)
(mlet %store-monad ((system (if system (return system) (current-system))))
(mcached … ;pass ‘system’ to callees
instance
system))) ;unchanged

HTH,
Ludo’.
C
C
Christopher Baines wrote on 5 May 2021 11:28
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 47989@debbugs.gnu.org)
8735v1cyww.fsf@cbaines.net
Ludovic Courtès <ludo@gnu.org> writes:

Toggle quote (41 lines)
> Christopher Baines <mail@cbaines.net> skribis:
>
>> Ludovic Courtès <ludo@gnu.org> writes:
>>
>>> Christopher Baines <mail@cbaines.net> skribis:
>>>
>>>> This allows computing a manifest for a specific system. Previously this was
>>>> possible, but only through changing %current-system, which caused the
>>>> derivation to be computed using that system as well (so computing a derivation
>>>> for aarch64-linux on x86_64-linux would require running aarch64-linux code).
>>>
>>> I remember discussing it, but I wonder if I was confused.
>>>
>>> I think you can always do the equivalent of (say):
>>>
>>> guix time-machine -- build -s armhf-linux hello -d
>>>
>>> … where Guix itself is built natively but it then computes a derivation
>>> for a different architecture.
>>>
>>> The equivalent code would be roughly:
>>>
>>> (let ((inferior (inferior-for-channels …)))
>>> (inferior-package-derivation store
>>> (car (lookup-inferior-packages inferior "hello"))
>>> "armhf-linux"))
>>>
>>> Does that make sense?
>>
>> Not really,
>
> :-)
>
>> this is just about manifests for channel instances, so nothing to do
>> with package derivations as far as I'm aware.
>
> I re-read your message and must have misunderstood. It’s the derivation
> of channel instances that you want for a given system, right? (What’s
> the use case though?) In that case something along the lines of the
> patch makes perfect sense.

Yep, the Guix Data Service currently uses channel-instances->manifest to
compute the channel instance derivations (which show up here for example
[1]. Currently it computes the derivations for different systems by
setting %current-system, but this has the side effect of also running
the Guile code for computing the derivation with Guile for that system.


That effectively only works if QEMU binfmt support is available for
those other systems. It would be faster just to use the native Guile,
and this would also avoid substitute availability problems (I had to
disable armhf-linux emulation on the data.guix.gnu.org machine when the
substitute availability from ci.guix.gnu.org got worse recently as too
much time was being spent just building armhf-linux things).
-----BEGIN PGP SIGNATURE-----

iQKlBAEBCgCPFiEEPonu50WOcg2XVOCyXiijOwuE9XcFAmCSZT9fFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcRHG1haWxAY2Jh
aW5lcy5uZXQACgkQXiijOwuE9XfjBRAAt9SoMJ9Y5/ekWOLaoqDwX7Um0aNimwwr
YLmNOgzw2OMEp3x53dQ6qWyA023ULGv+OfBpm88B9LxRSdIOm2jq47+AY5XHKv5v
2LOIt46LsC2+UEQ1K1MeCf3f6NydyQ8akerXwppM74oPJHGvtfEK9jXwfSpn7lm4
6rQFbyCmwNMj2XGNfaKLR9iFzLv35JVSpcBHZV6KIerNcGFFnktyuVRRHwgjrIAM
EkWyzfk2k0gj/9+ftqkwg1kUANwjX2wIm+V+9dZoABejihqXg5qrWo0mNItONdqh
KfcAH+tMqstN1MId/8o8nbT9ND3vDllte9s1w5ZKCXgnFTezM2noG3AdixSoVOe6
uQ1qPnCULAp7s20qMVD6A5gJNIjalsdp1wdQEU54gxNn5I4rs71/hD+mBWjvPWQi
DizzY7pjrEmc6uLybzTdaH13P0Sefr0WHCSLsRurtxdizvgNMJlXFJDJz/qyNiAi
eTsP2ZhaeGnId8LKMpKuK49GvqVlfGymUWMuqZrXR5A+hx1XDq+PCHYwgpR+TwSv
W54jMs25WPwm92KuZ2Qg8KvKH8+a4qQwdek+di5PyznYFARt/V+dmPw507QrZIu8
iI81N6J59wH7Je8lWnzj5FvmKZEd/FtNwRue7SeG3BDIjQ3kgNnV+CC+AlF7He2R
l9boIsYbhE0=
=Wmiz
-----END PGP SIGNATURE-----

C
C
Christopher Baines wrote on 5 May 2021 13:24
[PATCH v2] channels: Add a #:system argument to channel-instances->manifest.
(address . 47989@debbugs.gnu.org)
20210505112419.14893-1-mail@cbaines.net
This allows computing a manifest for a specific system. Previously this was
possible, but only through changing %current-system, which caused the
derivation to be computed using that system as well (so computing a derivation
for aarch64-linux on x86_64-linux would require running aarch64-linux code).

This new argument adds the possibility of computing derivations for non-native
systems, without having to run non-native code.

I'm looking at this as it will enable the Guix Data Service to compute channel
instance derivations without relying on QEMU emulation for non-native
systems (it should be faster as well).

* guix/channels.scm (build-from-source): Add #:system argument and pass to
build.
(build-channel-instance): Add system argument and pass to build-from-source.
(channel-instance-derivations): Add #:system argument and pass to
build-channel-instance, also rename system to current-system-value.
(channel-instances->manifest): Add #:system argument and pass to
channel-instance-derivations.
---
guix/channels.scm | 33 +++++++++++++++++++--------------
1 file changed, 19 insertions(+), 14 deletions(-)

Toggle diff (99 lines)
diff --git a/guix/channels.scm b/guix/channels.scm
index c40fc0c507..476d62e1f4 100644
--- a/guix/channels.scm
+++ b/guix/channels.scm
@@ -657,10 +657,11 @@ that unconditionally resumes the continuation."
store))))
(define* (build-from-source instance
- #:key core verbose? (dependencies '()))
+ #:key core verbose? (dependencies '()) system)
"Return a derivation to build Guix from INSTANCE, using the self-build
script contained therein. When CORE is true, build package modules under
-SOURCE using CORE, an instance of Guix."
+SOURCE using CORE, an instance of Guix. By default, build for the current
+system, or SYSTEM if specified."
(define name
(symbol->string
(channel-name (channel-instance-channel instance))))
@@ -700,20 +701,22 @@ SOURCE using CORE, an instance of Guix."
(with-trivial-build-handler
(build source
#:verbose? verbose? #:version commit
+ #:system system
#:channel-metadata (channel-instance->sexp instance)
#:pull-version %pull-version))))
;; Build a set of modules that extend Guix using the standard method.
(standard-module-derivation name source core dependencies)))
-(define* (build-channel-instance instance
+(define* (build-channel-instance instance system
#:optional core (dependencies '()))
"Return, as a monadic value, the derivation for INSTANCE, a channel
-instance. DEPENDENCIES is a list of extensions providing Guile modules that
-INSTANCE depends on."
+instance, for SYSTEM. DEPENDENCIES is a list of extensions providing Guile
+modules that INSTANCE depends on."
(build-from-source instance
#:core core
- #:dependencies dependencies))
+ #:dependencies dependencies
+ #:system system))
(define (resolve-dependencies instances)
"Return a procedure that, given one of the elements of INSTANCES, returns
@@ -743,9 +746,9 @@ list of instances it depends on."
(lambda (instance)
(vhash-foldq* cons '() instance edges)))
-(define (channel-instance-derivations instances)
+(define* (channel-instance-derivations instances #:key system)
"Return the list of derivations to build INSTANCES, in the same order as
-INSTANCES."
+INSTANCES. Build for the current system by default, or SYSTEM if specified."
(define core-instance
;; The 'guix' channel is treated specially: it's an implicit dependency of
;; all the other channels.
@@ -757,13 +760,13 @@ INSTANCES."
(resolve-dependencies instances))
(define (instance->derivation instance)
- (mlet %store-monad ((system (current-system)))
+ (mlet %store-monad ((system (if system (return system) (current-system))))
(mcached (if (eq? instance core-instance)
- (build-channel-instance instance)
+ (build-channel-instance instance system)
(mlet %store-monad ((core (instance->derivation core-instance))
(deps (mapm %store-monad instance->derivation
(edges instance))))
- (build-channel-instance instance core deps)))
+ (build-channel-instance instance system core deps)))
instance
system)))
@@ -865,9 +868,10 @@ derivation."
intro))))))
'()))))
-(define (channel-instances->manifest instances)
+(define* (channel-instances->manifest instances #:key system)
"Return a profile manifest with entries for all of INSTANCES, a list of
-channel instances."
+channel instances. By default, build for the current system, or SYSTEM if
+specified."
(define (instance->entry instance drv)
(let ((commit (channel-instance-commit instance))
(channel (channel-instance-channel instance)))
@@ -883,7 +887,8 @@ channel instances."
(properties
`((source ,(channel-instance->sexp instance)))))))
- (mlet* %store-monad ((derivations (channel-instance-derivations instances))
+ (mlet* %store-monad ((derivations (channel-instance-derivations instances
+ #:system system))
(entries -> (map instance->entry instances derivations)))
(return (manifest entries))))
--
2.30.1
C
C
Christopher Baines wrote on 5 May 2021 13:25
Re: bug#47989: [PATCH] channels: Add a #:system argument to channel-instances->manifest.
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 47989@debbugs.gnu.org)
87wnsdbey0.fsf@cbaines.net
Ludovic Courtès <ludo@gnu.org> writes:

Toggle quote (66 lines)
> Christopher Baines <mail@cbaines.net> skribis:
>
>> This allows computing a manifest for a specific system. Previously this was
>> possible, but only through changing %current-system, which caused the
>> derivation to be computed using that system as well (so computing a derivation
>> for aarch64-linux on x86_64-linux would require running aarch64-linux code).
>>
>> This new argument adds the possibility of computing derivations for non-native
>> systems, without having to run non-native code.
>>
>> I'm looking at this as it will enable the Guix Data Service to compute channel
>> instance derivations without relying on QEMU emulation for non-native
>> systems (it should be faster as well).
>>
>> * guix/channels.scm (build-from-source): Add #:system argument and pass to
>> build.
>> (build-channel-instance): Add system argument and pass to build-from-source.
>> (channel-instance-derivations): Add #:system argument and pass to
>> build-channel-instance, also rename system to current-system-value.
>> (channel-instances->manifest): Add #:system argument and pass to
>> channel-instance-derivations.
>
> [...]
>
>> (define* (build-from-source instance
>> - #:key core verbose? (dependencies '()))
>> + #:key core verbose? (dependencies '()) system)
>> "Return a derivation to build Guix from INSTANCE, using the self-build
>> script contained therein. When CORE is true, build package modules under
>> SOURCE using CORE, an instance of Guix."
>
> Please mention SYSTEM in the docstring.
>
>> +(define* (channel-instance-derivations instances #:key system)
>> "Return the list of derivations to build INSTANCES, in the same order as
>> INSTANCES."
>> (define core-instance
>> @@ -757,14 +759,15 @@ INSTANCES."
>> (resolve-dependencies instances))
>>
>> (define (instance->derivation instance)
>> - (mlet %store-monad ((system (current-system)))
>> + (mlet %store-monad ((current-system-value (current-system)))
>> (mcached (if (eq? instance core-instance)
>> - (build-channel-instance instance)
>> + (build-channel-instance instance system)
>> (mlet %store-monad ((core (instance->derivation core-instance))
>> (deps (mapm %store-monad instance->derivation
>> (edges instance))))
>> - (build-channel-instance instance core deps)))
>> + (build-channel-instance instance system core deps)))
>> instance
>> + current-system-value
>> system)))
>
> Here, there should not be any additional key to ‘mcached’ since there’s
> only one system being targeted.
>
> Instead, it should look something like this:
>
> (define (instance->derivation core-instance)
> (mlet %store-monad ((system (if system (return system) (current-system))))
> (mcached … ;pass ‘system’ to callees
> instance
> system))) ;unchanged

Sure, I've sent an updated patch that updates docstrings and makes the
above changes.
-----BEGIN PGP SIGNATURE-----

iQKlBAEBCgCPFiEEPonu50WOcg2XVOCyXiijOwuE9XcFAmCSgJdfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcRHG1haWxAY2Jh
aW5lcy5uZXQACgkQXiijOwuE9XeSDBAAoXNdAZAcBj4ofKRsHG+s+s8Lcgdbkmcl
OUNo0fsmpjPbs3N4SQ0SoMpMVsm5IgSC8QkiUPWJGpoOWxOsMADqepxCvRm7Zv68
UEmf4u926NHKKi5WfKLnTP90Qxi7mD+uQMyWJ/KkiOORdsUcfPoZr1EPnfD062v8
ypnXQBmIJ9bN9231uP7IeY4qA2+4mYdi8aQDk4ckVfXLBeTPg21rN0lIbi4sT0Aj
iUKWGZNIw3mavxdjkYBKxW9v5FRT4QwI6p4dkzGg7YfJyBXb166gIWOXMIKYEMk+
Lm9vse9BrZvlX7BUKcSHUeCUGRAvKE5NFZx+8t3Wb1tp9qxoIbhcZp6npMSMEUN9
c6gwpKZreTnjUyr/ml5/wZsYRj+8RCJvNLy2x9IzJaBEBWXWPcMHnRlhO2dPzTn9
EYjU+TzyYltYjbY2iYbviFEZyFkwnLpGqTwTCCcnuzMNN93CLpBMqgY5JBFCp5XH
SZbF7dALz6iDYALRVfbQwKi9xk+DCmRLMjxa+UG1GoiZd4UoKBgsdQ6bGYWu+a+k
HBMah7WOrDVwc0F/28ewdK5RkN8rtHiFe9LDuvCRtn6Eel0TPwVSJJcVRyVsD9KA
SML1//MvczJusYOlvqUOBTXT1yTwdueD+qWZxsejT5p0Br5wEZD9oG62GJNUM82D
PUJW9zTtDkw=
=fSCv
-----END PGP SIGNATURE-----

L
L
Ludovic Courtès wrote on 11 May 2021 10:48
(name . Christopher Baines)(address . mail@cbaines.net)(address . 47989@debbugs.gnu.org)
874kf94pwc.fsf@gnu.org
Hi,

Christopher Baines <mail@cbaines.net> skribis:

Toggle quote (8 lines)
> Yep, the Guix Data Service currently uses channel-instances->manifest to
> compute the channel instance derivations (which show up here for example
> [1]. Currently it computes the derivations for different systems by
> setting %current-system, but this has the side effect of also running
> the Guile code for computing the derivation with Guile for that system.
>
> 1: https://data.guix.gnu.org/revision/afec2784174058fdd85d9698e1fa748c45bfa8ee/channel-instances

I see, that’s because you explicitly want to channel derivations for
several systems in this case. Got it!

Ludo’.
L
L
Ludovic Courtès wrote on 11 May 2021 10:52
(name . Christopher Baines)(address . mail@cbaines.net)(address . 47989@debbugs.gnu.org)
87zgx13b65.fsf_-_@gnu.org
Christopher Baines <mail@cbaines.net> skribis:

Toggle quote (20 lines)
> This allows computing a manifest for a specific system. Previously this was
> possible, but only through changing %current-system, which caused the
> derivation to be computed using that system as well (so computing a derivation
> for aarch64-linux on x86_64-linux would require running aarch64-linux code).
>
> This new argument adds the possibility of computing derivations for non-native
> systems, without having to run non-native code.
>
> I'm looking at this as it will enable the Guix Data Service to compute channel
> instance derivations without relying on QEMU emulation for non-native
> systems (it should be faster as well).
>
> * guix/channels.scm (build-from-source): Add #:system argument and pass to
> build.
> (build-channel-instance): Add system argument and pass to build-from-source.
> (channel-instance-derivations): Add #:system argument and pass to
> build-channel-instance, also rename system to current-system-value.
> (channel-instances->manifest): Add #:system argument and pass to
> channel-instance-derivations.

LGTM!

(Please double-check that ‘make as-derivation’ or ‘guix pull --url=$PWD …’
work, in case we overlooked something.)

Thank you,
Ludo’.
C
C
Christopher Baines wrote on 12 May 2021 10:52
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 47989-done@debbugs.gnu.org)
87k0o41ggl.fsf@cbaines.net
Ludovic Courtès <ludo@gnu.org> writes:

Toggle quote (27 lines)
> Christopher Baines <mail@cbaines.net> skribis:
>
>> This allows computing a manifest for a specific system. Previously this was
>> possible, but only through changing %current-system, which caused the
>> derivation to be computed using that system as well (so computing a derivation
>> for aarch64-linux on x86_64-linux would require running aarch64-linux code).
>>
>> This new argument adds the possibility of computing derivations for non-native
>> systems, without having to run non-native code.
>>
>> I'm looking at this as it will enable the Guix Data Service to compute channel
>> instance derivations without relying on QEMU emulation for non-native
>> systems (it should be faster as well).
>>
>> * guix/channels.scm (build-from-source): Add #:system argument and pass to
>> build.
>> (build-channel-instance): Add system argument and pass to build-from-source.
>> (channel-instance-derivations): Add #:system argument and pass to
>> build-channel-instance, also rename system to current-system-value.
>> (channel-instances->manifest): Add #:system argument and pass to
>> channel-instance-derivations.
>
> LGTM!
>
> (Please double-check that ‘make as-derivation’ or ‘guix pull --url=$PWD …’
> work, in case we overlooked something.)

Great, I've pushed this as 34985fb6ae7deffd40443766f5408649a0cbbff2 now.
-----BEGIN PGP SIGNATURE-----

iQKlBAEBCgCPFiEEPonu50WOcg2XVOCyXiijOwuE9XcFAmCbl2pfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcRHG1haWxAY2Jh
aW5lcy5uZXQACgkQXiijOwuE9Xf2Kg/8CYyTzmHgP4149c4x4HyhzWVjh2+Yr6l8
tPlAl2c0052cT7CuS0mn4HBdUaVmqprGkBVirGaUdHqVMXb+f0zBS3e5rV5KfdHj
z+xnRV9hEovw26936JKGuAaHpDJPZvnLF7eLnI4hH9n+DIE8NR4QJiiPpkccI4wl
X2diftGBy0NY1F3JFoCrxLkK+WODSEzIt9uXCX+PECxwkXSJZFF+VG4DS13zmHto
aei+T9JQwMqQfgnUv4FxKBdL05sbvlUCK/hler7rvHQPNs8Lf+jfoo3ZgmGKChj5
ebBedj531G5S4iYJx+7vjMrBKSMKJtSwpeeQyHBUWfIpQYyXEWQCxHGce3FV44Vy
sLhh1sfd7jrtj+hpPaHBOuBttM0kxAgr0pKUHVVK3DpxyunzOI7gqvvzzFsZi57n
HKRPh5+TswZTuubqYf08r6bzfT2kVEhS9k6QMUjuiZRAY0L2SZ6MstftV4WpSjpZ
T5+nc3pMUmhLp7IuOskJv4NNgwE12yKJ1a927f5IQDcEkH7wfZRmrVOcRbbjx/RM
24ShOBf2pwHWQgVUHeWTuJ+Q0Bqi6QzidqEOLfzNQALmb7+JC5Pj4L8Z2vZrhgQ8
c+nhcWmjmaIMSeQBEoDjkIaNEsMyioe6HJsyvm7A/64eNnP9d3ARrMyijSSJaXTa
5wnVKkJi8pU=
=ET3e
-----END PGP SIGNATURE-----

Closed
?