[PATCH] gnu: Add eovim.

  • Done
  • quality assurance status badge
Details
2 participants
  • Efraim Flashner
  • Jack Hill
Owner
unassigned
Submitted by
Jack Hill
Severity
normal
J
J
Jack Hill wrote on 23 Apr 2021 04:40
(address . guix-patches@gnu.org)
20210423024046.24776-1-jackhill@jackhill.us
* gnu/packages/vim (eovim): New variable.
---
gnu/packages/vim.scm | 34 +++++++++++++++++++++++++++++++++-
1 file changed, 33 insertions(+), 1 deletion(-)

Toggle diff (61 lines)
diff --git a/gnu/packages/vim.scm b/gnu/packages/vim.scm
index 231fae9298..61ac6dee5f 100644
--- a/gnu/packages/vim.scm
+++ b/gnu/packages/vim.scm
@@ -8,7 +8,7 @@
;;; Copyright © 2019 HiPhish <hiphish@posteo.de>
;;; Copyright © 2019 Julien Lepiller <julien@lepiller.eu>
;;; Copyright © 2019, 2020 Jakub K?dzio?ka <kuba@kadziolka.net>
-;;; Copyright © 2020 Jack Hill <jackhill@jackhill.us>
+;;; Copyright © 2020, 2021 Jack Hill <jackhill@jackhill.us>
;;; Copyright © 2021 Simon Tournier <zimon.toutoune@gmail.com>
;;;
;;; This file is part of GNU Guix.
@@ -42,6 +42,7 @@
#:use-module (gnu packages attr)
#:use-module (gnu packages autotools)
#:use-module (gnu packages base)
+ #:use-module (gnu packages enlightenment)
#:use-module (gnu packages fontutils)
#:use-module (gnu packages gawk)
#:use-module (gnu packages gettext)
@@ -708,6 +709,37 @@ refactor Vim in order to:
;; except for parts that were contributed under the Vim license.
(license (list license:asl2.0 license:vim))))
+(define-public eovim
+ (package
+ (name "eovim")
+ (version "0.2.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/jeanguyomarch/eovim/")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "06b7crmz3wvvq15ncl0jk20s8j1pmna2jin0k5y5n5qxpafbgp3k"))))
+ (build-system cmake-build-system)
+ (arguments
+ '(#:tests? #false ; no tests
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'build 'set-home
+ (lambda _ (setenv "HOME" "/tmp"))))))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (inputs
+ `(("efl" ,efl)
+ ("msgpack" ,msgpack)))
+ (home-page "https://github.com/jeanguyomarch/eovim/")
+ (synopsis "EFL GUI for Neovim")
+ (description "GUI for Neovim based on the @acronym{EFL, Elightenment
+Foundation Libraries} toolkit.")
+ (license license:expat)))
+
(define-public vifm
(package
(name "vifm")
--
2.31.1
J
J
Jack Hill wrote on 23 Apr 2021 05:01
[PATCH v2] gnu: Add eovim.
(address . 47963@debbugs.gnu.org)
20210423030134.28261-1-jackhill@jackhill.us
* gnu/packages/vim (eovim): New variable.
---

Version 2: now with a corrected and hopefully improved description

gnu/packages/vim.scm | 35 ++++++++++++++++++++++++++++++++++-
1 file changed, 34 insertions(+), 1 deletion(-)

Toggle diff (62 lines)
diff --git a/gnu/packages/vim.scm b/gnu/packages/vim.scm
index 231fae9298..cd41eb3fe4 100644
--- a/gnu/packages/vim.scm
+++ b/gnu/packages/vim.scm
@@ -8,7 +8,7 @@
;;; Copyright © 2019 HiPhish <hiphish@posteo.de>
;;; Copyright © 2019 Julien Lepiller <julien@lepiller.eu>
;;; Copyright © 2019, 2020 Jakub K?dzio?ka <kuba@kadziolka.net>
-;;; Copyright © 2020 Jack Hill <jackhill@jackhill.us>
+;;; Copyright © 2020, 2021 Jack Hill <jackhill@jackhill.us>
;;; Copyright © 2021 Simon Tournier <zimon.toutoune@gmail.com>
;;;
;;; This file is part of GNU Guix.
@@ -42,6 +42,7 @@
#:use-module (gnu packages attr)
#:use-module (gnu packages autotools)
#:use-module (gnu packages base)
+ #:use-module (gnu packages enlightenment)
#:use-module (gnu packages fontutils)
#:use-module (gnu packages gawk)
#:use-module (gnu packages gettext)
@@ -708,6 +709,38 @@ refactor Vim in order to:
;; except for parts that were contributed under the Vim license.
(license (list license:asl2.0 license:vim))))
+(define-public eovim
+ (package
+ (name "eovim")
+ (version "0.2.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/jeanguyomarch/eovim/")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "06b7crmz3wvvq15ncl0jk20s8j1pmna2jin0k5y5n5qxpafbgp3k"))))
+ (build-system cmake-build-system)
+ (arguments
+ '(#:tests? #false ; no tests
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'build 'set-home
+ (lambda _ (setenv "HOME" "/tmp"))))))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (inputs
+ `(("efl" ,efl)
+ ("msgpack" ,msgpack)))
+ (home-page "https://github.com/jeanguyomarch/eovim/")
+ (synopsis "EFL GUI for Neovim")
+ (description "GUI for Neovim based on the @acronym{EFL, Enlightenment
+Foundation Libraries} toolkit. Its features include customizable appearance
+and support for fonts with ligatures.")
+ (license license:expat)))
+
(define-public vifm
(package
(name "vifm")
--
2.31.1
J
J
Jack Hill wrote on 23 Apr 2021 16:43
(address . 47963@debbugs.gnu.org)
alpine.DEB.2.21.2104231041550.8414@marsh.hcoop.net
I don't think this patch is ready to be merged yet. eovim currently finds
neovim on the PATH, but I believe we can do better and encode a reference.
I'll investigate and propose a v3.

Best,
Jack
J
J
Jack Hill wrote on 23 Apr 2021 21:58
[PATCH v3] gnu: Add eovim.
(address . 47963@debbugs.gnu.org)
20210423195818.4709-1-jackhill@jackhill.us
* gnu/packages/vim (eovim): New variable.
---

Version 3: Adds an absolute store reference to the nvim
dependency. Users will still be able to use the --nvim option to
select a different version.

I believe this patch is now ready for review and merging if appropriate.

gnu/packages/vim.scm | 45 +++++++++++++++++++++++++++++++++++++++++++-
1 file changed, 44 insertions(+), 1 deletion(-)

Toggle diff (72 lines)
diff --git a/gnu/packages/vim.scm b/gnu/packages/vim.scm
index 231fae9298..009544f40e 100644
--- a/gnu/packages/vim.scm
+++ b/gnu/packages/vim.scm
@@ -8,7 +8,7 @@
;;; Copyright © 2019 HiPhish <hiphish@posteo.de>
;;; Copyright © 2019 Julien Lepiller <julien@lepiller.eu>
;;; Copyright © 2019, 2020 Jakub K?dzio?ka <kuba@kadziolka.net>
-;;; Copyright © 2020 Jack Hill <jackhill@jackhill.us>
+;;; Copyright © 2020, 2021 Jack Hill <jackhill@jackhill.us>
;;; Copyright © 2021 Simon Tournier <zimon.toutoune@gmail.com>
;;;
;;; This file is part of GNU Guix.
@@ -42,6 +42,7 @@
#:use-module (gnu packages attr)
#:use-module (gnu packages autotools)
#:use-module (gnu packages base)
+ #:use-module (gnu packages enlightenment)
#:use-module (gnu packages fontutils)
#:use-module (gnu packages gawk)
#:use-module (gnu packages gettext)
@@ -708,6 +709,48 @@ refactor Vim in order to:
;; except for parts that were contributed under the Vim license.
(license (list license:asl2.0 license:vim))))
+(define-public eovim
+ (package
+ (name "eovim")
+ (version "0.2.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/jeanguyomarch/eovim/")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "06b7crmz3wvvq15ncl0jk20s8j1pmna2jin0k5y5n5qxpafbgp3k"))))
+ (build-system cmake-build-system)
+ (arguments
+ '(#:tests? #false ;no tests
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'configure 'reference-nvim
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((nvim (string-append (assoc-ref inputs "neovim")
+ "/bin/nvim")))
+ ;; This substitution should change one line, and replaces the default
+ ;; value in the struct of options with an absolute store reference.
+ (substitute* "../source/src/main.c"
+ (("(^[[:blank:]]+\\.nvim = \")nvim" _ start)
+ (string-append start nvim))))))
+ (add-before 'build 'set-home
+ (lambda _ (setenv "HOME" "/tmp"))))))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (inputs
+ `(("efl" ,efl)
+ ("msgpack" ,msgpack)
+ ("neovim" ,neovim)))
+ (home-page "https://github.com/jeanguyomarch/eovim/")
+ (synopsis "EFL GUI for Neovim")
+ (description "GUI for Neovim based on the @acronym{EFL, Enlightenment
+Foundation Libraries} toolkit. Its features include customizable appearance
+and support for fonts with ligatures.")
+ (license license:expat)))
+
(define-public vifm
(package
(name "vifm")
--
2.31.1
J
J
Jack Hill wrote on 23 Apr 2021 22:05
[PATCH v4] gnu: Add eovim.
(address . 47963@debbugs.gnu.org)
20210423200506.5953-1-jackhill@jackhill.us
* gnu/packages/vim (eovim): New variable.
---

Version 4: Tweaked the description a little bit more. Now it says "GUI"
in the synopsis, but "Graphical" in the description.

gnu/packages/vim.scm | 45 +++++++++++++++++++++++++++++++++++++++++++-
1 file changed, 44 insertions(+), 1 deletion(-)

Toggle diff (72 lines)
diff --git a/gnu/packages/vim.scm b/gnu/packages/vim.scm
index 231fae9298..3b796fa341 100644
--- a/gnu/packages/vim.scm
+++ b/gnu/packages/vim.scm
@@ -8,7 +8,7 @@
;;; Copyright © 2019 HiPhish <hiphish@posteo.de>
;;; Copyright © 2019 Julien Lepiller <julien@lepiller.eu>
;;; Copyright © 2019, 2020 Jakub K?dzio?ka <kuba@kadziolka.net>
-;;; Copyright © 2020 Jack Hill <jackhill@jackhill.us>
+;;; Copyright © 2020, 2021 Jack Hill <jackhill@jackhill.us>
;;; Copyright © 2021 Simon Tournier <zimon.toutoune@gmail.com>
;;;
;;; This file is part of GNU Guix.
@@ -42,6 +42,7 @@
#:use-module (gnu packages attr)
#:use-module (gnu packages autotools)
#:use-module (gnu packages base)
+ #:use-module (gnu packages enlightenment)
#:use-module (gnu packages fontutils)
#:use-module (gnu packages gawk)
#:use-module (gnu packages gettext)
@@ -708,6 +709,48 @@ refactor Vim in order to:
;; except for parts that were contributed under the Vim license.
(license (list license:asl2.0 license:vim))))
+(define-public eovim
+ (package
+ (name "eovim")
+ (version "0.2.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/jeanguyomarch/eovim/")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "06b7crmz3wvvq15ncl0jk20s8j1pmna2jin0k5y5n5qxpafbgp3k"))))
+ (build-system cmake-build-system)
+ (arguments
+ '(#:tests? #false ;no tests
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'configure 'reference-nvim
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((nvim (string-append (assoc-ref inputs "neovim")
+ "/bin/nvim")))
+ ;; This substitution should change one line, and replaces the default
+ ;; value in the struct of options with an absolute store reference.
+ (substitute* "../source/src/main.c"
+ (("(^[[:blank:]]+\\.nvim = \")nvim" _ start)
+ (string-append start nvim))))))
+ (add-before 'build 'set-home
+ (lambda _ (setenv "HOME" "/tmp"))))))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (inputs
+ `(("efl" ,efl)
+ ("msgpack" ,msgpack)
+ ("neovim" ,neovim)))
+ (home-page "https://github.com/jeanguyomarch/eovim/")
+ (synopsis "EFL GUI for Neovim")
+ (description "Graphical Neovim interface based on the @acronym{EFL, Enlightenment
+Foundation Libraries} toolkit. Its features include customizable appearance
+and support for fonts with ligatures.")
+ (license license:expat)))
+
(define-public vifm
(package
(name "vifm")
--
2.31.1
E
E
Efraim Flashner wrote on 21 Jun 2021 16:27
(name . Jack Hill)(address . jackhill@jackhill.us)(address . 47963-done@debbugs.gnu.org)
YNChzST6ecZJISlV@3900XT
Looks like this patch fell through the cracks. Patch pushed!

--
Efraim Flashner <efraim@flashner.co.il> ????? ?????
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAmDQoc0ACgkQQarn3Mo9
g1EkEg/6A/OsyqWQta45clZCcf1bP86Pea0b6HQ6Mu3vOCE+rMwR6st3/tQN8eAi
1n0RqVV9L5/LdUPuN8DRAaWfHx0BA1sFTdkY3qpIEtG8ikTAde+VqnQ8uCLNW9R0
BBH+TqFT0ld4kTZx2gZ4qF998BC7qPsgK6Rm+ceu4izeAK4KlfSaSSygeJ/hSFoj
tfXrrxDxXpbcq1mZfXpn/+cS+fno2mhH8DKReVw735HkbIfzW5U4ao2+RvoBcc0z
qhgUSyQZ5wsd69ShJL8c7vq1ARn5H2R2mWO6TWx3mciP7oIHBuD02L/36SP61qM+
9Iorvbl6kiZWdvPtd/mfZYpqSnFKULrk5w9HkUYBEfPjodu1T4/FMHBdQlZ8XMe5
ZQcE5O8nRAUc842feHZOVdzbAPsPkZkJ79YmR9IX2zxR1Tn39JVb6l8+Sc+DJZlS
A7DVyXtKcQy8QXH0pzOGCmVLdOtNy60Wx/oOhx28So7R6iYI6tnIkWvQ2Je8ofHp
CEkSxXSSDu8BHSfuU5sHc2nQxo5c2a+SULvKJ6h9rNIKCwbDSbeXjieOXIp+YQuE
UV9eLKQSFRmeLJ1B4uE3bL5TxYdYbFHY75hT7626phCAX6V9I4v1Sgrbs7zxiVnT
Zi9lERVGGUwBbIHhGBr/ULVEhWXM9AOFH4pX5AVZiYFse3DYDQg=
=Xtmc
-----END PGP SIGNATURE-----


Closed
?