[PATCH 0/5] Add alsa-ucm-conf and alsa-topology-conf.

  • Done
  • quality assurance status badge
Details
One participant
  • Mathieu Othacehe
Owner
unassigned
Submitted by
Mathieu Othacehe
Severity
normal
M
M
Mathieu Othacehe wrote on 22 Apr 2021 11:52
(address . guix-patches@gnu.org)(name . Mathieu Othacehe)(address . othacehe@gnu.org)
20210422095225.10248-1-othacehe@gnu.org
Hello,

This patchset adds alsa-ucm-conf and alsa-topology-conf conf packages. It also
modifies the alsa-lib package to include references to those packages.

They are required on recent hardware such as Lenovo X1 to have a functional
audio setup.

Those changes are targeting the core-updates branch.

Thanks,

Mathieu

Mathieu Othacehe (5):
gnu: Add alsa-ucm-conf.
gnu: Add alsa-topology-conf.
gnu: alsa-lib: Use alsa-ucm-conf and alsa-topology-conf.
gnu: alsa-lib: Update the home-page.
gnu: alsa-lib: Fix the indentation.

gnu/packages/linux.scm | 93 +++++++++++++++++++++++++++++++++++++-----
1 file changed, 83 insertions(+), 10 deletions(-)

--
2.31.1
M
M
Mathieu Othacehe wrote on 22 Apr 2021 11:54
[PATCH 2/5] gnu: Add alsa-topology-conf.
(address . 47947@debbugs.gnu.org)(name . Mathieu Othacehe)(address . othacehe@gnu.org)
20210422095421.10358-2-othacehe@gnu.org
* gnu/packages/linux.scm (alsa-topology-conf): New variable.
---
gnu/packages/linux.scm | 23 +++++++++++++++++++++++
1 file changed, 23 insertions(+)

Toggle diff (36 lines)
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 576636414e..b60e6ad392 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -2159,6 +2159,29 @@ configuration of audio input/output names and routing for specific audio
hardware.")
(license license:bsd-3)))
+(define-public alsa-topology-conf
+ (package
+ (name "alsa-topology-conf")
+ (version "1.2.4")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "ftp://ftp.alsa-project.org/pub/lib/" name "-"
+ version ".tar.bz2"))
+ (sha256
+ (base32
+ "01zdg6q4s6d01k39z96wi4vbhrfw1i2g4yi5dijwfk6a5vjfdq2m"))))
+ (build-system copy-build-system)
+ (arguments
+ '(#:install-plan
+ '(("topology" "share/alsa/topology"))))
+ (home-page "https://www.alsa-project.org/wiki/Main_Page")
+ (synopsis "The Advanced Linux Sound Architecture libraries")
+ (description
+ "This package contains Advanced Linux Sound Architecture topology
+configuration files that can be used for specific audio hardware.")
+ (license license:bsd-3)))
+
(define-public alsa-lib
(package
(name "alsa-lib")
--
2.31.1
M
M
Mathieu Othacehe wrote on 22 Apr 2021 11:54
[PATCH 3/5] gnu: alsa-lib: Use alsa-ucm-conf and alsa-topology-conf.
(address . 47947@debbugs.gnu.org)(name . Mathieu Othacehe)(address . othacehe@gnu.org)
20210422095421.10358-3-othacehe@gnu.org
* gnu/packages/linux.scm (alsa)[arguments]: Add a pre-install phase that
creates symlinks to alsa-ucm-conf and alsa-topology-conf files.
---
gnu/packages/linux.scm | 26 +++++++++++++++++++++++++-
1 file changed, 25 insertions(+), 1 deletion(-)

Toggle diff (39 lines)
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index b60e6ad392..e5fe79b4b6 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -2198,7 +2198,31 @@ configuration files that can be used for specific audio hardware.")
(arguments
'(#:configure-flags (list (string-append "LDFLAGS=-Wl,-rpath="
(assoc-ref %outputs "out")
- "/lib"))))
+ "/lib"))
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'install 'pre-install
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let* ((ucm
+ (string-append (assoc-ref inputs "alsa-ucm-conf")))
+ (topology
+ (string-append (assoc-ref inputs "alsa-topology-conf")))
+ (alsa
+ (string-append (assoc-ref outputs "out") "/share/alsa"))
+ (ucm-share
+ (string-append ucm "/share/alsa/ucm"))
+ (ucm2-share
+ (string-append ucm "/share/alsa/ucm2"))
+ (topology-share
+ (string-append topology "/share/alsa/topology")))
+ (mkdir-p alsa)
+ (symlink ucm-share (string-append alsa "/ucm"))
+ (symlink ucm2-share (string-append alsa "/ucm2"))
+ (symlink topology-share (string-append alsa "/topology")))
+ #t)))))
+ (inputs
+ `(("alsa-ucm-conf" ,alsa-ucm-conf)
+ ("alsa-topology-conf" ,alsa-topology-conf)))
(home-page "https://www.alsa-project.org/")
(synopsis "The Advanced Linux Sound Architecture libraries")
(description
--
2.31.1
M
M
Mathieu Othacehe wrote on 22 Apr 2021 11:54
[PATCH 1/5] gnu: Add alsa-ucm-conf.
(address . 47947@debbugs.gnu.org)(name . Mathieu Othacehe)(address . othacehe@gnu.org)
20210422095421.10358-1-othacehe@gnu.org
* gnu/packages/linux.scm (alsa-ucm-conf): New variable.
---
gnu/packages/linux.scm | 28 +++++++++++++++++++++++++++-
1 file changed, 27 insertions(+), 1 deletion(-)

Toggle diff (55 lines)
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 1ea9d80834..576636414e 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -22,7 +22,7 @@
;;; Copyright © 2017, 2018, 2020 Leo Famulari <leo@famulari.name>
;;; Copyright © 2017 José Miguel Sánchez García <jmi2k@openmailbox.com>
;;; Copyright © 2017 Gábor Boskovits <boskovits@gmail.com>
-;;; Copyright © 2017, 2019 Mathieu Othacehe <m.othacehe@gmail.com>
+;;; Copyright © 2017, 2019, 2021 Mathieu Othacehe <othacehe@gnu.org>
;;; Copyright © 2017 Clément Lassieur <clement@lassieur.org>
;;; Copyright © 2017, 2018, 2019 Rutger Helling <rhelling@mykolab.com>
;;; Copyright © 2017 nee <nee-git@hidamari.blue>
@@ -145,6 +145,7 @@
#:use-module (gnu packages selinux)
#:use-module (gnu packages swig)
#:use-module (guix build-system cmake)
+ #:use-module (guix build-system copy)
#:use-module (guix build-system gnu)
#:use-module (guix build-system go)
#:use-module (guix build-system meson)
@@ -2133,6 +2134,31 @@ an executed process and the signals received by that process. It can also
intercept and print the system calls executed by the program.")
(license license:gpl2+)))
+(define-public alsa-ucm-conf
+ (package
+ (name "alsa-ucm-conf")
+ (version "1.2.4")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "ftp://ftp.alsa-project.org/pub/lib/" name "-"
+ version ".tar.bz2"))
+ (sha256
+ (base32
+ "0h6kzi1cfdqyxp4pwpqh5wb89c8s9wrgix315bvamffwfxf56frc"))))
+ (build-system copy-build-system)
+ (arguments
+ '(#:install-plan
+ '(("ucm" "share/alsa/ucm")
+ ("ucm2" "share/alsa/ucm2"))))
+ (home-page "https://www.alsa-project.org/wiki/Main_Page")
+ (synopsis "The Advanced Linux Sound Architecture Use Case Manager")
+ (description
+ "This package contains Advanced Linux Sound Architecture Use Case Manager
+configuration of audio input/output names and routing for specific audio
+hardware.")
+ (license license:bsd-3)))
+
(define-public alsa-lib
(package
(name "alsa-lib")
--
2.31.1
M
M
Mathieu Othacehe wrote on 22 Apr 2021 11:54
[PATCH 4/5] gnu: alsa-lib: Update the home-page.
(address . 47947@debbugs.gnu.org)(name . Mathieu Othacehe)(address . othacehe@gnu.org)
20210422095421.10358-4-othacehe@gnu.org
* gnu/packages/linux.scm (alsa-lib)[home-page]: Update it.
---
gnu/packages/linux.scm | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

Toggle diff (15 lines)
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index e5fe79b4b6..9c5bca49c3 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -2223,7 +2223,7 @@ configuration files that can be used for specific audio hardware.")
(inputs
`(("alsa-ucm-conf" ,alsa-ucm-conf)
("alsa-topology-conf" ,alsa-topology-conf)))
- (home-page "https://www.alsa-project.org/")
+ (home-page "https://www.alsa-project.org/wiki/Main_Page")
(synopsis "The Advanced Linux Sound Architecture libraries")
(description
"The Advanced Linux Sound Architecture (ALSA) provides audio and
--
2.31.1
M
M
Mathieu Othacehe wrote on 22 Apr 2021 11:54
[PATCH 5/5] gnu: alsa-lib: Fix the indentation.
(address . 47947@debbugs.gnu.org)(name . Mathieu Othacehe)(address . othacehe@gnu.org)
20210422095421.10358-5-othacehe@gnu.org
* gnu/packages/linux.scm (alsa-lib): Fix the indentation.
---
gnu/packages/linux.scm | 14 +++++++-------
1 file changed, 7 insertions(+), 7 deletions(-)

Toggle diff (27 lines)
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 9c5bca49c3..35db28ca5a 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -2187,13 +2187,13 @@ configuration files that can be used for specific audio hardware.")
(name "alsa-lib")
(version "1.2.4")
(source (origin
- (method url-fetch)
- (uri (string-append
- "ftp://ftp.alsa-project.org/pub/lib/alsa-lib-"
- version ".tar.bz2"))
- (sha256
- (base32
- "1xq8d48wfy59qw4x7383j32n8j5njndw5hcgnmlg9pvclphlnmgp"))))
+ (method url-fetch)
+ (uri (string-append
+ "ftp://ftp.alsa-project.org/pub/lib/alsa-lib-"
+ version ".tar.bz2"))
+ (sha256
+ (base32
+ "1xq8d48wfy59qw4x7383j32n8j5njndw5hcgnmlg9pvclphlnmgp"))))
(build-system gnu-build-system)
(arguments
'(#:configure-flags (list (string-append "LDFLAGS=-Wl,-rpath="
--
2.31.1
M
M
Mathieu Othacehe wrote on 13 May 2021 17:32
Re: bug#47947: [PATCH 0/5] Add alsa-ucm-conf and alsa-topology-conf.
(address . 47947-done@debbugs.gnu.org)
87pmxulkem.fsf@gnu.org
Toggle quote (2 lines)
> Those changes are targeting the core-updates branch.

Pushed to core-updates,

Thanks,

Mathieu
Closed
?