[PATCH] gnu: Add python-crcmod.

  • Done
  • quality assurance status badge
Details
3 participants
  • Jelle Licht
  • Roel Janssen
  • zimoun
Owner
unassigned
Submitted by
Roel Janssen
Severity
normal
R
R
Roel Janssen wrote on 21 Apr 2021 15:38
(address . guix-patches@gnu.org)
9b937c12-c3cc-34af-aba3-694fa17770c6@gnu.org
Hi Guix,

Here's a patch for python-crcmod.

Kind regards,
Roel Janssen
From 61fbb10be87a4d52a8a2a1328102e8f9c41b8726 Mon Sep 17 00:00:00 2001
From: Roel Janssen <roel@gnu.org>
Date: Wed, 21 Apr 2021 15:36:55 +0200
Subject: [PATCH] gnu: Add python-crcmod.

* gnu/packages/python-xyz.scm (python-crcmod): New variable.
---
gnu/packages/python-xyz.scm | 19 +++++++++++++++++++
1 file changed, 19 insertions(+)

Toggle diff (32 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 5cf0b61c68..823d82cea7 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -355,6 +355,25 @@ implementation for the Telegram Bot API.")
with Python's logging module that outputs records using terminal colors.")
(license license:expat)))
+(define-public python-crcmod
+ (package
+ (name "python-crcmod")
+ (version "1.7")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "crcmod" version))
+ (sha256
+ (base32
+ "07k0hgr42vw2j92cln3klxka81f33knd7459cn3d8aszvfh52w6w"))))
+ (build-system python-build-system)
+ (home-page "http://crcmod.sourceforge.net/")
+ (synopsis "CRC generator for Python")
+ (description "The software in this package provides a Python module for
+generating objects that compute the Cyclic Redundancy Check (CRC). It includes
+a (optional) C extension for fast calculation, as well as a pure Python
+implementation.")
+ (license license:expat)))
+
(define-public python-pyprind
(package
(name "python-pyprind")
--
2.31.1
Z
Z
zimoun wrote on 3 Nov 2021 11:09
(name . Roel Janssen)(address . roel@gnu.org)(address . 47933@debbugs.gnu.org)
877ddptusk.fsf@gmail.com
Hi Roel,

On Wed, 21 Apr 2021 at 15:38, Roel Janssen <roel@gnu.org> wrote:

Toggle quote (10 lines)
>>From 61fbb10be87a4d52a8a2a1328102e8f9c41b8726 Mon Sep 17 00:00:00 2001
> From: Roel Janssen <roel@gnu.org>
> Date: Wed, 21 Apr 2021 15:36:55 +0200
> Subject: [PATCH] gnu: Add python-crcmod.
>
> * gnu/packages/python-xyz.scm (python-crcmod): New variable.
> ---
> gnu/packages/python-xyz.scm | 19 +++++++++++++++++++
> 1 file changed, 19 insertions(+)

I have not applied this patch myself but it LGTM. If it builds and
“guix lint” does not report nothing blocking, feel free to push. :-)

Cheers,
simon
J
J
Jelle Licht wrote on 29 May 2023 13:06
(address . 47933-done@debbugs.gnu.org)
87pm6jo0r6.fsf@fsfe.org
zimoun <zimon.toutoune@gmail.com> writes:

Toggle quote (20 lines)
> Hi Roel,
>
> On Wed, 21 Apr 2021 at 15:38, Roel Janssen <roel@gnu.org> wrote:
>
>>>>From 61fbb10be87a4d52a8a2a1328102e8f9c41b8726 Mon Sep 17 00:00:00 2001
>> From: Roel Janssen <roel@gnu.org>
>> Date: Wed, 21 Apr 2021 15:36:55 +0200
>> Subject: [PATCH] gnu: Add python-crcmod.
>>
>> * gnu/packages/python-xyz.scm (python-crcmod): New variable.
>> ---
>> gnu/packages/python-xyz.scm | 19 +++++++++++++++++++
>> 1 file changed, 19 insertions(+)
>
> I have not applied this patch myself but it LGTM. If it builds and
> “guix lint” does not report nothing blocking, feel free to push. :-)
>
> Cheers,
> simon

Superseded by commit 36ea29115cd, which was merged into master recently.
Closing.
Closed
?