[PATCH] add netdiscover

  • Done
  • quality assurance status badge
Details
3 participants
  • Arun Isaac
  • Maxime Devos
  • terramorpha
Owner
unassigned
Submitted by
terramorpha
Severity
normal
T
T
terramorpha wrote on 20 Apr 2021 19:47
(address . guix-patches@gnu.org)
4ecb12dc6ad26ca9874b46784fad0119@cock.li
---
gnu/packages/networking.scm | 26 ++++++++++++++++++++++++++
1 file changed, 26 insertions(+)

Toggle diff (44 lines)
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index f7557fc331..342621299b 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -4075,3 +4075,29 @@ IPv6 Internet connectivity - it also works over
IPv4.")
;; version. This exception does not (and cannot) modify any
license terms
;; which apply to the Application, with which you must still
comply
license:lgpl3)))
+
+(define-public netdiscover
+ (package
+ (name "netdiscover")
+ (version "0.7")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url
"https://github.com/netdiscover-scanner/netdiscover")
+ (commit version)))
+ (sha256 (base32
"0g8w8rlg16dsibxi4dnyn7v7r8wwi5ypd51c4w59j0ps2id0w8yj"))
+ (file-name (string-append "netdiscover-" version))))
+ (arguments `(#:tests? #f)) ;; no tests
+ (build-system gnu-build-system)
+ (inputs `(("libpcap" ,libpcap)
+ ("libnet" ,libnet)))
+ (native-inputs `(("automake" ,automake)
+ ("autoconf" ,autoconf)))
+ (synopsis "Network address discovery tool")
+ (description
+ "Netdiscover is a network address discovering tool, developed
mainly for
+those wireless networks without dhcp server, it also works on
hub/switched
+networks. Its based on arp packets, it will send arp requests and
sniff for
+replies.")
+ (home-page "https://github.com/netdiscover-scanner/netdiscover")
+ (license license:gpl3)))
--
2.31.1
M
M
Maxime Devos wrote on 20 Apr 2021 20:29
7fea94996f15157e9e37fcae6c4f525c919a3019.camel@telenet.be
terramorpha@cock.li schreef op di 20-04-2021 om 13:47 [-0400]:
Toggle quote (3 lines)
> [...]
> + (home-page "https://github.com/netdiscover-scanner/netdiscover")
> + (license license:gpl3)))
Fr-
om netdiscover/src/data_ai.h:

* This program is free software; you can redistribute it and/or modify
* it under the terms of the GNU General Public License as published by
* the Free Software Foundation; either version 3 of the License, or
* (at your option) any later version.

So this should perhaps be license:gpl3+?
Greetings,
Maxime.
-----BEGIN PGP SIGNATURE-----

iI0EABYKADUWIQTB8z7iDFKP233XAR9J4+4iGRcl7gUCYH8dhRccbWF4aW1lZGV2
b3NAdGVsZW5ldC5iZQAKCRBJ4+4iGRcl7se2AP97taiWWY+St1CrYF1AGvZuFcQN
ZfavybrOlTPf5hYQggEAj3XtETG7o/TrZUhfs5WAgieDgEhAb2dqm1U27VPA+QQ=
=sm5s
-----END PGP SIGNATURE-----


J
J
Justin Veilleux wrote on 20 Apr 2021 22:26
B7140A7C-9A48-4091-B5A9-FD4AEBB9F67F@cock.li
That makes sense. Should I send another patch with this field fixed ?

On April 20, 2021 2:29:24 p.m. EDT, Maxime Devos <maximedevos@telenet.be> wrote:
Toggle quote (17 lines)
>terramorpha@cock.li schreef op di 20-04-2021 om 13:47 [-0400]:
>> [...]
>> + (home-page "https://github.com/netdiscover-scanner/netdiscover")
>> + (license license:gpl3)))
>Fr-
>om netdiscover/src/data_ai.h:
>
> * This program is free software; you can redistribute it and/or modify
> * it under the terms of the GNU General Public License as published by
> * the Free Software Foundation; either version 3 of the License, or
> * (at your option) any later version.
>
>So this should perhaps be license:gpl3+?
>
>Greetings,
>Maxime.

--
Sent from my Android device with K-9 Mail. Please excuse my brevity.
Attachment: file
T
T
terramorpha wrote on 20 Apr 2021 22:43
[PATCH v2] add netdiscover
(address . 47913@debbugs.gnu.org)
b8b6d5e7c34d9e843e941bfe2c36828d@cock.li
Here you go.


---
gnu/packages/networking.scm | 26 ++++++++++++++++++++++++++
1 file changed, 26 insertions(+)

Toggle diff (44 lines)
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index f7557fc331..e973a1b26a 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -4075,3 +4075,29 @@ IPv6 Internet connectivity - it also works over
IPv4.")
;; version. This exception does not (and cannot) modify any
license terms
;; which apply to the Application, with which you must still
comply
license:lgpl3)))
+
+(define-public netdiscover
+ (package
+ (name "netdiscover")
+ (version "0.7")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url
"https://github.com/netdiscover-scanner/netdiscover")
+ (commit version)))
+ (sha256 (base32
"0g8w8rlg16dsibxi4dnyn7v7r8wwi5ypd51c4w59j0ps2id0w8yj"))
+ (file-name (string-append "netdiscover-" version))))
+ (arguments `(#:tests? #f)) ;; no tests
+ (build-system gnu-build-system)
+ (inputs `(("libpcap" ,libpcap)
+ ("libnet" ,libnet)))
+ (native-inputs `(("automake" ,automake)
+ ("autoconf" ,autoconf)))
+ (synopsis "Network address discovery tool")
+ (description
+ "Netdiscover is a network address discovering tool, developed
mainly for
+those wireless networks without dhcp server, it also works on
hub/switched
+networks. Its based on arp packets, it will send arp requests and
sniff for
+replies.")
+ (home-page "https://github.com/netdiscover-scanner/netdiscover")
+ (license license:gpl3+)))
--
2.31.1
T
T
terramorpha wrote on 27 Apr 2021 17:52
(address . 47913@debbugs.gnu.org)(address . maximedevos@telenet.be)
97dec77cdb4a73a06c5176e4a7c108f0@cock.li
Are there still issues preventing the patch from being merged?
M
M
Maxime Devos wrote on 27 Apr 2021 20:19
0de231e2cb9f9a90a94a80da569397e09d50c00d.camel@telenet.be
terramorpha@cock.li schreef op di 27-04-2021 om 11:52 [-0400]:
Toggle quote (2 lines)
> Are there still issues preventing the patch from being merged?

None that I know of. You'll have to wait for a committer (which I am not)
to confirm and merge the patch.

Note: I reviewed the patch, but didn't test the package.

Greetings,
Maxime.
-----BEGIN PGP SIGNATURE-----

iI0EABYKADUWIQTB8z7iDFKP233XAR9J4+4iGRcl7gUCYIhVthccbWF4aW1lZGV2
b3NAdGVsZW5ldC5iZQAKCRBJ4+4iGRcl7mPwAQCeN/JrIy56moFYzQhE9AgEKh2p
UGDjrWUKsaqhcPBf8wEA9/7s1XhvGaAELPorXcCeE/H7s9AMKm0FWx8XjGIvbAw=
=x2tY
-----END PGP SIGNATURE-----


T
T
terramorpha wrote on 9 Jul 2021 23:07
is there anybody out there?
(address . 47913@debbugs.gnu.org)
b678b2eb6f2de7e77f4ded3aede28448@cock.li
Could someone with commit access take a look at my patch ?
A
A
Arun Isaac wrote on 10 Jul 2021 11:51
871r86339n.fsf@systemreboot.net
Hi Justin,

Thank you for contributing to Guix! I applied your patch with a few
corrections:

- changed commit message to conform to Guix conventions
- added a copyright header for you
- made some stylistic changes to the package description
- modified the description slightly

Thanks,
Arun
-----BEGIN PGP SIGNATURE-----

iQFPBAEBCAA5FiEEf3MDQ/Lwnzx3v3nTLiXui2GAK7MFAmDpbbQbHGFydW5pc2Fh
Y0BzeXN0ZW1yZWJvb3QubmV0AAoJEC4l7othgCuzTbMIAIZq+WxCprG4Zm5DqsIL
9Gprwcb15bxxl8fysdeIWJ3WhhwpdjSqQph/Y3tYLYDTSFqexQaiXVwD4Hcz5vRu
sWlqet5TeSHlJKZ91b7PcGkacUc+kNF8wVezs9VyPP9p683ymZqfvaUse0In63Di
e3ewwSFUT9amjZAqXMXeV5kaCZiP+tMMtbSLevPk38PQPE3N7RBuz3ci1YIv7pvh
DGhOcR6/9Zl+VEsXs5f8PlsISLhJ8Y4rWAgEXaX/iei+8ZgOlOf5RrOpIJ8lMaQ9
vq8/AQse19CgEbA9kvo89eSqw4zclICxzRy1oelf7IJdlNe1UV6I008HH9F4AlF4
7xU=
=5KCq
-----END PGP SIGNATURE-----

Closed
?