[PATCH] gnu: Add emacs-ibuffer-vc.

  • Done
  • quality assurance status badge
Details
2 participants
  • Alexandr Vityazev
  • Nicolas Goaziou
Owner
unassigned
Submitted by
Alexandr Vityazev
Severity
normal
A
A
Alexandr Vityazev wrote on 18 Apr 2021 17:52
(address . guix-patches@gnu.org)
8735vnzj1w.fsf@posteo.net
---
gnu/packages/emacs-xyz.scm | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)

Toggle diff (40 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 1c449eb606..9074faf83b 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -27668,3 +27668,27 @@ quasi-prefix map, with many useful bindings. These bindings are
shorter than usual, using mostly unprefixed keys.")
(license license:gpl3+)))
+(define-public emacs-ibuffer-vc
+ (package
+ (name "emacs-ibuffer-vc")
+ (version "0.11")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/purcell/ibuffer-vc")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1mgn7b786j4hwq1ks012hxxgvrfn5rz90adi2j190gmjz60rc5g5"))))
+ (build-system emacs-build-system)
+ (home-page
+ "https://github.com/purcell/ibuffer-vc")
+ (synopsis
+ "Group ibuffer's list by VC project, or show VC status")
+ (description
+ "Adds functionality to ibuffer for grouping buffers by their parent
+vc root directory, and for displaying and/or sorting by the vc
+status of listed files.")
+ (license license:gpl3+)))
--
2.31.1



--

Alexandr Vityazev
N
N
Nicolas Goaziou wrote on 23 Apr 2021 11:10
(name . Alexandr Vityazev)(address . avityazev@posteo.org)(address . 47873-done@debbugs.gnu.org)
87o8e52wo7.fsf@nicolasgoaziou.fr
Hello,

Alexandr Vityazev <avityazev@posteo.org> writes:

Toggle quote (4 lines)
> ---
> gnu/packages/emacs-xyz.scm | 24 ++++++++++++++++++++++++
> 1 file changed, 24 insertions(+)

Thank you.

I moved the package definition elsewhere than the end of the file (to
prevent merge conflicts), added a proper commit message, made the
changes below and applied your patch.

Toggle quote (3 lines)
> + (synopsis
> + "Group ibuffer's list by VC project, or show VC status")

I detailed what meant "VC".

Toggle quote (5 lines)
> + (description
> + "Adds functionality to ibuffer for grouping buffers by their parent
> +vc root directory, and for displaying and/or sorting by the vc
> +status of listed files.")

Description ought to be a complete sentence, and therefore, cannot start
with "Adds". I reworded it accordingly.

Regards,
--
Nicolas Goaziou
Closed
?