[PATCH] gnu: Add r-naturalsort.

  • Done
  • quality assurance status badge
Details
3 participants
  • Efraim Flashner
  • Leo Famulari
  • Roel Janssen
Owner
unassigned
Submitted by
Roel Janssen
Severity
normal
R
R
Roel Janssen wrote on 16 Apr 2021 12:57
(address . guix-patches@gnu.org)
3d1ca65d2e40892c8effa6e4ed7e6a3948698b1a.camel@gnu.org
Hi Guix,

Here's a patch for r-naturalsort.

Also: is it OK to push patches like this ("another" fairly trivial R
package) directly?

Kind regards,
Roel Janssen
From 452a5561d9ab7623d52d0a6625f0199e8ff0e488 Mon Sep 17 00:00:00 2001
From: Roel Janssen <roel@gnu.org>
Date: Fri, 16 Apr 2021 12:53:06 +0200
Subject: [PATCH] gnu: Add r-naturalsort.

* gnu/packages/cran.scm (r-naturalsort): New variable.
---
gnu/packages/cran.scm | 19 +++++++++++++++++++
1 file changed, 19 insertions(+)

Toggle diff (32 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 6f931f06c2..012a734c30 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -25194,6 +25194,25 @@ addition, objects which include the k-d tree search structure can be returned
to speed up repeated queries of the same set of target points.")
(license license:bsd-3)))
+(define-public r-naturalsort
+ (package
+ (name "r-naturalsort")
+ (version "0.1.3")
+ (source (origin
+ (method url-fetch)
+ (uri (cran-uri "naturalsort" version))
+ (sha256
+ (base32
+ "0mz801y9mzld9ypp3xmsjw2d8l9q97sdnv09wrci9xi3yg2sjf6d"))))
+ (build-system r-build-system)
+ (home-page "https://cran.r-project.org/web/packages/naturalsort/")
+ (synopsis "Natural ordering")
+ (description "This package provides functions related to human natural
+ordering. It handles adjacent digits in a character sequence as a number
+so that natural sort function arranges a character vector by their numbers,
+not digit characters.")
+ (license license:bsd-3)))
+
(define-public r-muhaz
(package
(name "r-muhaz")
--
2.30.2
E
E
Efraim Flashner wrote on 4 May 2021 17:52
(name . Roel Janssen)(address . roel@gnu.org)(address . 47822@debbugs.gnu.org)
YJFt29q9peVYQNf1@3900XT
On Fri, Apr 16, 2021 at 12:57:51PM +0200, Roel Janssen wrote:
Toggle quote (11 lines)
> Hi Guix,
>
> Here's a patch for r-naturalsort.
>
> Also: is it OK to push patches like this ("another" fairly trivial R
> package) directly?
>
> Kind regards,
> Roel Janssen
>

Probably. Plus it's been 2 weeks.


--
Efraim Flashner <efraim@flashner.co.il> ????? ?????
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAmCRbdsACgkQQarn3Mo9
g1EgrA/+PQadIrJY3ocYLnHWwx0caWz+5x1e1kF3WhqcEO60h4RrIdbl64GtErjO
+Kc/uom/9CznqHv/1EBQ38zg9EHz5shLzd7guAXwucmteS48k91itXeJyLfgosyE
ZR5PSoGQ4Gwc3XFX5zu/nVz7o/lcfBvWQ6iFHRI2q5Z33RNVpJrACudtdzM7uKPA
Z8vBmRPHdJHKkTllhmbs4AkgWnBPQgJ8GB+6GOUgdXE9SiFhndo3JpukO3u/fE7M
j+l6ul0X1irdZncgZJDByk0otZGm70AHUAMwGUiitV94HVZGGgPY19lST0YbfR5C
qiz4zhHIC5NnOD7uagvxGABSwpgbKQgDHhlSnhFcYSrQM7wFFEfv71wQay+nFhEU
tKwyARumEZffGSUEfEUj9MfQoxBfa82t//YL3NyrNpqwzxn+QJNyLDM1YU4tbFDL
wHB/HnAt0XnKAyWr309vm9W4xco4+fVXcX1YSyXJSZCZpVpnwn2n6VU9HOW0MKmC
cxQxe716vnvj/xir0BnPU31vHYnbouzkexLeWHoql/acsqBMtgx4QxAuQ1sKLprI
Jf+xTBSKmpXJDvB4Ys42dKBe2uaWQJNl2eWp7k4GO4OJQZM2zUy//lEs1yuqVRtn
I9a5tITqi2FJh9TVqLOxNw+0dSGHc7wRpAtkjyD2YYiSUaB0cyk=
=Yi5m
-----END PGP SIGNATURE-----


L
L
Leo Famulari wrote on 4 May 2021 18:31
(name . Roel Janssen)(address . roel@gnu.org)(address . 47822@debbugs.gnu.org)
YJF29GvSab5i4ViV@jasmine.lan
On Fri, Apr 16, 2021 at 12:57:51PM +0200, Roel Janssen wrote:
Toggle quote (5 lines)
> Here's a patch for r-naturalsort.
>
> Also: is it OK to push patches like this ("another" fairly trivial R
> package) directly?

Yes. Quoting the manual section Commit Access:

------
For patches that just add a new package, and a simple one, it’s OK to
commit, if you’re confident (which means you successfully built it in a
chroot setup, and have done a reasonable copyright and license
auditing). Likewise for package upgrades, except upgrades that trigger a
lot of rebuilds (for example, upgrading GnuTLS or GLib).
------

If you aren't feeling confident, just let us know what you'd like
someone else to check for you. Otherwise, feel free to push.
R
R
Roel Janssen wrote on 4 May 2021 21:36
(address . 47822-done@debbugs.gnu.org)
cb9cb30a9fb0c14da29218f7acf0688f863187da.camel@gnu.org
On Tue, 2021-05-04 at 12:31 -0400, Leo Famulari wrote:
Toggle quote (23 lines)
> On Fri, Apr 16, 2021 at 12:57:51PM +0200, Roel Janssen wrote:
> > Here's a patch for r-naturalsort.
> >
> > Also: is it OK to push patches like this ("another" fairly trivial
> > R
> > package) directly?
>
> Yes. Quoting the manual section Commit Access:
>
> ------
> For patches that just add a new package, and a simple one, it’s OK to
> commit, if you’re confident (which means you successfully built it in
> a
> chroot setup, and have done a reasonable copyright and license
> auditing). Likewise for package upgrades, except upgrades that
> trigger a
> lot of rebuilds (for example, upgrading GnuTLS or GLib).
> ------
>
> If you aren't feeling confident, just let us know what you'd like
> someone else to check for you. Otherwise, feel free to push.
>

Thanks Efraim and Leo. I pushed this patch in
aa7eeabe9a782afc2535581298990050d16b1895.

I will push trivial patches like these directly from now on. Please do
let me know if I pushed something that would've benefitted from review.

Kind regards,
Roel Janssen
Closed
?