[PATCH]: Update FreeCAD to 0.19.1

  • Done
  • quality assurance status badge
Details
3 participants
  • Ekaitz Zarraga
  • Leo Famulari
  • Maxime Devos
Owner
unassigned
Submitted by
Ekaitz Zarraga
Severity
normal
E
E
Ekaitz Zarraga wrote on 14 Apr 2021 17:59
(name . guix-patches@gnu.org)(address . guix-patches@gnu.org)
m_h_ks9CqvOZi3cTATp3NMe7nn7GQ4D_lNmHTyjumMdbRLLo0kDr2azjpMuPl_WvNRmRlYxCSteMDK_BypDhvlyVVHyzDRcVGIiHblvb_c0=@elenq.tech
Hi,

This set of patches update freecad from unstable to the 0.19.1 release.

More information in this help-guix thread:


Thanks!
From 48fc072af9b595c7e71f0f06d9963685e7d3a796 Mon Sep 17 00:00:00 2001
From: Ekaitz Zarraga <ekaitz@elenq.tech>
Date: Wed, 14 Apr 2021 15:48:06 +0200
Subject: [PATCH 1/2] gnu: Add vtk-8.

gnu/packages/image-processing (vtk-8): New variable.
---
gnu/packages/image-processing.scm | 17 +++++++++++++++++
1 file changed, 17 insertions(+)

Toggle diff (37 lines)
diff --git a/gnu/packages/image-processing.scm b/gnu/packages/image-processing.scm
index ce2242a658..16c9887741 100644
--- a/gnu/packages/image-processing.scm
+++ b/gnu/packages/image-processing.scm
@@ -15,6 +15,7 @@
;;; Copyright © 2021 Oleh Malyi <astroclubzp@gmail.com>
;;; Copyright © 2021 Felix Gruber <felgru@posteo.net>
;;; Copyright © 2021 Andy Tai <atai@atai.org>
+;;; Copyright © 2020 Ekaitz Zarraga <ekaitz@elenq.tech>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -349,6 +350,22 @@ a suite of 3D interaction widgets, supports parallel processing, and
integrates with various databases on GUI toolkits such as Qt and Tk.")
(license license:bsd-3)))
+;; freecad needs an old version of VTK, because VTK's API changed from 8 to 9
+(define-public vtk-8
+ (package (inherit vtk)
+ (version "8.2.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://vtk.org/files/release/"
+ (version-major+minor version)
+ "/VTK-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1fspgp8k0myr6p2a6wkc21ldcswb4bvmb484m12mxgk1a9vxrhrl"))))
+ (inputs
+ `(("jsoncpp" ,jsoncpp-for-tensorflow)
+ ,@(alist-delete "jsoncpp" (package-inputs vtk))))))
+
;; itksnap needs an older variant of VTK.
(define-public vtk-6
(package (inherit vtk)
--
2.31.0
M
M
Maxime Devos wrote on 14 Apr 2021 23:39
4a8ff1b83b4d4580294833e421e34a52aa88a86e.camel@telenet.be
On Wed, 2021-04-14 at 15:59 +0000, Ekaitz Zarraga wrote:
Toggle quote (10 lines)
> Hi,
>
> This set of patches update freecad from unstable to the 0.19.1 release.
>
> More information in this help-guix thread:
>
> https://lists.gnu.org/archive/html/help-guix/2021-04/msg00118.html
>
> Thanks!

+ `(#:tests? #f
Why's that? ‘We’ prefer to have tests enabled when possible.
Please document why tests are disabled here (with a comment
#:tests? #f ; no tests / tests require dependency X, which is not packaged ...).

+ (add-before 'configure 'restore-pythonpath
+ (lambda _
+ (substitute* "src/Main/MainGui.cpp"
+ (("_?putenv\\(\"PYTHONPATH=\"\\);") ""))
+ #t))

The #t can be removed. The warning that results when #t is absent
has been removed on the core-updates branch; we might as well stop
introducing these silly #t now such that we don't have to remove them
later.

Greetings,
Maxme.
-----BEGIN PGP SIGNATURE-----

iI0EABYKADUWIQTB8z7iDFKP233XAR9J4+4iGRcl7gUCYHdhAhccbWF4aW1lZGV2
b3NAdGVsZW5ldC5iZQAKCRBJ4+4iGRcl7tg/AP0Y1+O5FNY4OTxeqw65/NBxIeCT
I4AEvGwSkC6MxXcvIgEA/e7gWkPocQ+j9NhiMW8BtLyJtvTMkt5MO1/qcd0q5wY=
=A9oO
-----END PGP SIGNATURE-----


E
E
Ekaitz Zarraga wrote on 14 Apr 2021 23:44
(name . Maxime Devos)(address . maximedevos@telenet.be)(name . 47778@debbugs.gnu.org)(address . 47778@debbugs.gnu.org)
Y6-3eSREOSuxV-uvkz1UmhQnArxXmS0aD29IH7kVgWtQZMt-50aGR-R7-QIiB49NUowBSi3VF3xt-fGGrLT_zVReOoxh_5HTtA8cpYhBlb8=@elenq.tech
Hi,

Toggle quote (7 lines)
>
> - `(#:tests? #f
>
> Why's that? ‘We’ prefer to have tests enabled when possible.
> Please document why tests are disabled here (with a comment
> #:tests? #f ; no tests / tests require dependency X, which is not packaged ...).

I'll try to test the package with the tests, but they were
disabled before too, so I didn't change that.

Toggle quote (25 lines)
>
> - (add-before 'configure 'restore-pythonpath
>
>
> - (lambda _
>
>
> - (substitute* "src/Main/MainGui.cpp"
>
>
> - (("_?putenv\\\\(\\"PYTHONPATH=\\"\\\\);") ""))
>
>
> - #t))
>
>
>
> The #t can be removed. The warning that results when #t is absent
> has been removed on the core-updates branch; we might as well stop
> introducing these silly #t now such that we don't have to remove them
> later.
>
> Greetings,
> Maxme.

Ok, I'll remove that and update the patch.

Thanks!
E
E
Ekaitz Zarraga wrote on 15 Apr 2021 00:58
(name . Maxime Devos)(address . maximedevos@telenet.be)(name . 47778@debbugs.gnu.org)(address . 47778@debbugs.gnu.org)
pceIjJ6DHzEsFgtRq_uUnpXNffT4E8LF7nCoBd_FV_kymAqk_ouMklhhW5e0_Qk1MkA012Isa7Jyv_NR2T7qnUkkORIX1IYFrih5gDXTJWU=@elenq.tech
Hi,

As they are not functional changes, I updated inside
the same diff.

Hope it's ok.
Cheers,

Ekaitz
L
L
Leo Famulari wrote on 16 Apr 2021 04:26
(name . Ekaitz Zarraga)(address . ekaitz@elenq.tech)
YHj1u3t/Nn0JrpJx@jasmine.lan
On Wed, Apr 14, 2021 at 10:58:57PM +0000, Ekaitz Zarraga wrote:
Toggle quote (18 lines)
> Hi,
>
> As they are not functional changes, I updated inside
> the same diff.
>
> Hope it's ok.
> Cheers,
>
> Ekaitz

> From 5308c3eeda66262cf5427cf040589bdaa0b85cab Mon Sep 17 00:00:00 2001
> From: Ekaitz Zarraga <ekaitz@elenq.tech>
> Date: Wed, 14 Apr 2021 15:49:53 +0200
> Subject: [PATCH 2/2] gnu: freecad: Update to 0.19.1
>
> * gnu/packages/engineering.scm (freecad): Update to 0.19.1
> [inputs]: Add new dependencies

Thanks! I filled out the commit message and pushed the patches as
ce2fe8bf34199e2b9788a7f77c0ad0bbdfa713bd.

Thanks for reviewing Maxime! I wanted to make sure this made it into the
upcoming release :)
Closed
?