[PATCH] gnu: Add seatd.

  • Done
  • quality assurance status badge
Details
3 participants
  • guixuser6392
  • Ludovic Courtès
  • Tobias Geerinckx-Rice
Owner
unassigned
Submitted by
guixuser6392
Severity
normal
Merged with
G
G
guixuser6392 wrote on 13 Apr 2021 15:45
(name . guix-patches@gnu.org)(address . guix-patches@gnu.org)
kg70plrfIYk953CSJvLS-mK18mf3Fct93nx9fLjUB2CZvhfRfWfnYOa2MtLBPpmvNDBePVSxZtPTAZfg8E-W_w2fMZnzMU5jAf_ANmDub_0=@protonmail.com
Hello, Guix!

This patch adds a single package definition for a minimal seat management daemon (seatd), and a universal seat management library (libseat), under the name of `seatd'.

Regards,
pineapples
From 6dce6e93197bd911e136e345a7d6acfe711ecef3 Mon Sep 17 00:00:00 2001
From: pineapples <guixuser6392@protonmail.com>
Date: Tue, 13 Apr 2021 15:12:53 +0200
Subject: [PATCH] gnu: Add seatd.

* gnu/packages/freedesktop.scm (seatd): New variable.
---
gnu/packages/freedesktop.scm | 31 +++++++++++++++++++++++++++++++
1 file changed, 31 insertions(+)

Toggle diff (51 lines)
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index 40d41350ac..36002fcf04 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -23,6 +23,7 @@
;;; Copyright © 2020 Anders Thuné <asse.97@gmail.com>
;;; Copyright © 2020 Raghav Gururajan <raghavgururajan@disroot.org>
;;; Copyright © 2021 Brendan Tildesley <mail@brendan.scot>
+;;; Copyright © 2021 pineapples <guixuser6392@protonmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -825,6 +826,36 @@ GNOME Shell. The @command{localectl} command-line tool allows you to interact
with localed. This package is extracted from the broader systemd package.")
(license license:lgpl2.1+)))
+(define-public seatd
+ (package
+ (name "seatd")
+ (version "0.5.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.sr.ht/~kennylevinsen/seatd")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1kglq8v4rnr3415mfaghyv2s2f8mxsy5s881gmm2908ig4n4j297"))))
+ (build-system meson-build-system)
+ (arguments
+ `(#:configure-flags '("-Dlogind=enabled")))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ("scdoc" ,scdoc)))
+ (inputs
+ `(("elogind" ,elogind)))
+ (home-page "https://sr.ht/~kennylevinsen/seatd")
+ (synopsis "Seat management daemon and library")
+ (description
+ "This package provides a minimal seat management daemon whose task is to
+mediate access to shared devices, such as graphics and input, for applications
+that require it. It also provides a universal seat management library that
+allows applications to use whatever seat management is available.")
+ (license license:expat)))
+
(define-public packagekit
(package
(name "packagekit")
--
2.31.1
T
T
Tobias Geerinckx-Rice wrote on 13 Apr 2021 16:45
(no subject)
(address . control@debbugs.gnu.org)
87y2dmdyzo.fsf@nckx
merge 47750 47751
L
L
Ludovic Courtès wrote on 14 May 2021 12:44
Re: bug#47750: [PATCH] gnu: Add seatd.
(name . guixuser6392)(address . guixuser6392@protonmail.com)(address . 47750-done@debbugs.gnu.org)
87y2chmw74.fsf@gnu.org
Hi,

guixuser6392 <guixuser6392@protonmail.com> skribis:

Toggle quote (7 lines)
> From 6dce6e93197bd911e136e345a7d6acfe711ecef3 Mon Sep 17 00:00:00 2001
> From: pineapples <guixuser6392@protonmail.com>
> Date: Tue, 13 Apr 2021 15:12:53 +0200
> Subject: [PATCH] gnu: Add seatd.
>
> * gnu/packages/freedesktop.scm (seatd): New variable.

Finally applied, thanks!

Ludo’.
Closed
?