[PATCH v2] gnu: Add node-once.

  • Done
  • quality assurance status badge
Details
2 participants
  • Tobias Geerinckx-Rice
  • Ron Nazarov
Owner
unassigned
Submitted by
Ron Nazarov
Severity
normal
Merged with
R
R
Ron Nazarov wrote on 10 Apr 2021 00:10
(address . guix-patches@gnu.org)(name . Ron Nazarov)(address . noisytoot@disroot.org)
20210409221018.44513-1-noisytoot@disroot.org
* gnu/packages/node-xyz.scm (node-once): New variable.
---
gnu/packages/node-xyz.scm | 30 ++++++++++++++++++++++++++++++
1 file changed, 30 insertions(+)

Toggle diff (40 lines)
diff --git a/gnu/packages/node-xyz.scm b/gnu/packages/node-xyz.scm
index f401380310..ee0b5e62d9 100644
--- a/gnu/packages/node-xyz.scm
+++ b/gnu/packages/node-xyz.scm
@@ -298,3 +298,33 @@ function with browser support.")
(synopsis "Callback wrapping utility")
(description "@code{wrappy} is a utility for Node.js to wrap callbacks.")
(license license:isc)))
+
+(define-public node-once
+ (package
+ (name "node-once")
+ (version "1.4.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/isaacs/once")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1z8dcbf28dqdcp4wb0c53wrs90a07nkrax2c9kk26dsk1dhrnxav"))))
+ (build-system node-build-system)
+ (arguments
+ '(#:tests? #f ; FIXME: Tests depend on node-tap
+ #:phases
+ (modify-phases %standard-phases
+ ;; If configure existed it would fail due to tap being missing,
+ ;; as we do not have tap packaged yet, tap is used for tests.
+ ;; This package still works as a dependency of glob and inflight,
+ ;; which are being packaged.
+ (delete 'configure))))
+ (inputs
+ `(("node-wrappy" ,node-wrappy)))
+ (home-page "https://github.com/isaacs/once")
+ (synopsis "Node.js module to only run a function once")
+ (description "@code{once} is a Node.js module to only run a function once.")
+ (license license:isc)))
--
2.30.2
R
R
Ron Nazarov wrote on 10 Apr 2021 00:15
merge 47680 47682
(address . control@debbugs.gnu.org)
44035df75ef3ea2b390bb3623e223dab2502c642.camel@disroot.org
merge 47680 47682
T
T
Tobias Geerinckx-Rice wrote on 4 May 2021 23:14
Re: [PATCH v2] gnu: Add node-once.
(address . 47682-done@debbugs.gnu.org)
87sg32mcbd.fsf@nckx
Noisy,

Toggle quote (2 lines)
> This package still works as a dependency of glob and inflight

If you say so!

Toggle quote (2 lines)
> which are being packaged.

I dropped this part as it I hope it to be outdated soon.

Pushed as 2959adef94ba8684127bb995ce26b3234b4d457d.

Thanks,

T G-R
-----BEGIN PGP SIGNATURE-----

iIMEARYKACsWIQT12iAyS4c9C3o4dnINsP+IT1VteQUCYJG5Jg0cbWVAdG9iaWFz
LmdyAAoJEA2w/4hPVW15k7IA/RTjR5H+iLdQbEDNXdcQLIbF+OxwFNkyE9F+TRjX
N/wjAQDOLCL5ct/AH6Z3ZcM5ZBOFJ3fos46zga54Z/KbVSNsDw==
=5SZs
-----END PGP SIGNATURE-----

Closed
?