[PATCH] gnu: Add node-once.

  • Done
  • quality assurance status badge
Details
One participant
  • Ron Nazarov
Owner
unassigned
Submitted by
Ron Nazarov
Severity
normal
Merged with
R
R
Ron Nazarov wrote on 9 Apr 2021 23:34
(address . guix-patches@gnu.org)(name . Ron Nazarov)(address . noisytoot@disroot.org)
20210409213443.40317-1-noisytoot@disroot.org
* gnu/packages/node-xyz.scm (node-once): New variable.
---
gnu/packages/node-xyz.scm | 27 +++++++++++++++++++++++++++
1 file changed, 27 insertions(+)

Toggle diff (37 lines)
diff --git a/gnu/packages/node-xyz.scm b/gnu/packages/node-xyz.scm
index f401380310..a56190da9e 100644
--- a/gnu/packages/node-xyz.scm
+++ b/gnu/packages/node-xyz.scm
@@ -298,3 +298,30 @@ function with browser support.")
(synopsis "Callback wrapping utility")
(description "@code{wrappy} is a utility for Node.js to wrap callbacks.")
(license license:isc)))
+
+(define-public node-once
+ (package
+ (name "node-once")
+ (version "1.4.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/isaacs/once")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1z8dcbf28dqdcp4wb0c53wrs90a07nkrax2c9kk26dsk1dhrnxav"))))
+ (build-system node-build-system)
+ (arguments
+ '(#:tests? #f ; FIXME: Tests depend on node-tap
+ #:phases
+ (modify-phases %standard-phases
+ ;; Fails due to tap being missing
+ (delete 'configure))))
+ (inputs
+ `(("node-wrappy" ,node-wrappy)))
+ (home-page "https://github.com/isaacs/once")
+ (synopsis "Node.js module to only run a function once")
+ (description "@code{once} is a Node.js module to only run a function once.")
+ (license license:isc)))
--
2.30.2
R
R
Ron Nazarov wrote on 10 Apr 2021 00:15
merge 47680 47682
(address . control@debbugs.gnu.org)
44035df75ef3ea2b390bb3623e223dab2502c642.camel@disroot.org
merge 47680 47682
?