[PATCH] gnu: Add node-wrappy.

  • Done
  • quality assurance status badge
Details
2 participants
  • Leo Famulari
  • Ron Nazarov
Owner
unassigned
Submitted by
Ron Nazarov
Severity
normal
R
R
Ron Nazarov wrote on 3 Apr 2021 23:19
(address . guix-patches@gnu.org)(name . Ron Nazarov)(address . noisytoot@disroot.org)
20210403211908.106880-1-noisytoot@disroot.org
* gnu/packages/node-xyz.scm (node-wrappy): New variable.
---
gnu/packages/node-xyz.scm | 26 ++++++++++++++++++++++++++
1 file changed, 26 insertions(+)

Toggle diff (43 lines)
diff --git a/gnu/packages/node-xyz.scm b/gnu/packages/node-xyz.scm
index 60cc005ea4..f401380310 100644
--- a/gnu/packages/node-xyz.scm
+++ b/gnu/packages/node-xyz.scm
@@ -1,6 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2020 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2020 Giacomo Leidi <goodoldpaul@autistici.org>
+;;; Copyright © 2021 Noisytoot <noisytoot@disroot.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -272,3 +273,28 @@ function with browser support.")
"@code{node-semver} is a JavaScript implementation of the
@uref{https://semver.org/, SemVer.org} specification.")
(license license:isc)))
+
+(define-public node-wrappy
+ (package
+ (name "node-wrappy")
+ (version "1.0.2")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/npm/wrappy")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1ymlc61cja6v5438vwb04gq8wg2b784lj39zf0g4i36fvgcw9783"))))
+ (build-system node-build-system)
+ (arguments
+ '(#:tests? #f ; FIXME: Tests depend on node-tap
+ #:phases
+ (modify-phases %standard-phases
+ ;; The only dependency to check for is tap, which we don't have.
+ (delete 'configure))))
+ (home-page "https://github.com/npm/wrappy")
+ (synopsis "Callback wrapping utility")
+ (description "@code{wrappy} is a utility for Node.js to wrap callbacks.")
+ (license license:isc)))
--
2.30.2
L
L
Leo Famulari wrote on 5 Apr 2021 23:23
(name . Ron Nazarov via Guix-patches via)(address . guix-patches@gnu.org)
YGt/totiFoGG+igR@jasmine.lan
On Sat, Apr 03, 2021 at 10:19:08PM +0100, Ron Nazarov via Guix-patches via wrote:
Toggle quote (2 lines)
> * gnu/packages/node-xyz.scm (node-wrappy): New variable.

Thanks! Pushed as ab0ed26eb70931e04c921ceef313ca67e3c6d61c
?