[PATCH] gnu: Add go-github-com-rivo-uniseg.

  • Done
  • quality assurance status badge
Details
2 participants
  • Adam Kandur
  • Sergey Trofimov
Owner
unassigned
Submitted by
Adam Kandur
Severity
normal
A
A
Adam Kandur wrote on 22 Mar 2021 12:17
(name . Guix Patches)(address . guix-patches@gnu.org)
MWOdxJr--3-2@tuta.io
From 12c52ae9e6dcd0bdc5f095cefb7b1b4f0e938795 Mon Sep 17 00:00:00 2001
From: Adam Kandur <rndd@tuta.io>
Date: Mon, 22 Mar 2021 14:16:38 +0300
Subject: [PATCH] gnu: Add go-github-com-rivo-uniseg.

* gnu/packages/golang.scm (go-github-com-rivo-uniseg): New variable.
---
 gnu/packages/golang.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)

Toggle diff (36 lines)
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index d9988cd..7e455d7 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -2151,6 +2151,29 @@ a file on the file system.  The log levels are dynamic at instantiation of the
 hook, so it is capable of logging at some or all levels.")
     (license license:expat)))
 
+(define-public go-github-com-rivo-uniseg
+  (package
+    (name "go-github-com-rivo-uniseg")
+    (version "v0.2.0")
+    (home-page "https://github.com/rivo/uniseg")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+         (url "https://github.com/rivo/uniseg")
+         (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0j7h22vfmjj562vr8gpsyrkrwp1pq9ayh5fylv24skxb467g9f0q"))))
+    (build-system go-build-system)
+    (arguments
+     '(#:import-path "github.com/rivo/uniseg"))
+    (synopsis "Unicode Text Segmentation for Go (or: How to Count Characters in a String)")
+    (description
+     "This Go package implements Unicode Text Segmentation according to Unicode Standard Annex #29 (Unicode version 12.0.0).
+At this point, only the determination of grapheme cluster boundaries is implemented.")
+    (license license:expat)))
+
 (define-public go-github-com-kardianos-osext
   (let ((commit "ae77be60afb1dcacde03767a8c37337fad28ac14")
         (revision "1"))
--
2.30.1
S
S
Sergey Trofimov wrote on 9 Nov 2023 21:56
control message for bug #47317
(address . control@debbugs.gnu.org)
b1271ec55fd0b865c9f9966207976675@sarg.org.ru
close 47317
quit
?