[PATCH 00/25] some Python 2 removals.

  • Done
  • quality assurance status badge
Details
2 participants
  • Maxim Cournoyer
  • zimoun
Owner
unassigned
Submitted by
zimoun
Severity
normal
Z
Z
zimoun wrote on 15 Mar 2021 16:53
(address . guix-patches@gnu.org)(name . zimoun)(address . zimon.toutoune@gmail.com)
20210315155325.51019-1-zimon.toutoune@gmail.com
Hi,

Because Python 2 is EOL and these packages fail to build, there are removed.
Well, "guix refresh -l" is checked so nothing should break.

At the end of the series, "make as-derivation" successes, so everything seems
fine.

Cheers,
simon

zimoun (25):
gnu: python2-arrow: Remove package.
gnu: python2-cairocffi: Remove.
gnu: python2-dulwich: Remove package.
gnu: python2-yubikey-manager: Remove package.
gnu: python2-fido2: Remove package.
gnu: python2-flask-wtf: Remove package.
gnu: python2-fask-babel: Remove package.
gnu: python2-flask-htmlmin: Remove package.
gnu: python2-flask-login: Remove package.
gnu: python2-flask-multistatic: Remove package.
gnu: python2-httpbin: Remove package.
gnu: python2-flask: Remove package.
gnu: python2-furl: Remove package.
gnu: python2-graphql-core: Remove package.
gnu: python2-ipywidgets: Remove package.
gnu: python2-mpd2: Remove package.
gnu: python2-mutagen: Remove package.
gnu: python2-nbxmpp: Remove package.
gnu: python2-rq: Remove package.
gnu: python2-sh: Remove package.
gnu: python2-stem: Remove package.
gnu: python2-tables: Remove package.
gnu: python2-utils: Remove package.
gnu: python2-widgetsnbextension: Remove package.
gnu: python2-wsgiproxy2: Remove package.

gnu/packages/databases.scm | 3 ---
gnu/packages/messaging.scm | 3 ---
gnu/packages/mpd.scm | 3 ---
gnu/packages/music.scm | 3 ---
gnu/packages/python-web.scm | 24 ------------------------
gnu/packages/python-xyz.scm | 27 ---------------------------
gnu/packages/security-token.scm | 6 ------
gnu/packages/time.scm | 3 ---
gnu/packages/web.scm | 3 ---
9 files changed, 75 deletions(-)


base-commit: 266d55dc3080475544bf45e72359c9b9bbcecd53
--
2.30.1
Z
Z
zimoun wrote on 15 Mar 2021 16:55
[PATCH 01/25] gnu: python2-arrow: Remove package.
(address . 47165@debbugs.gnu.org)(name . zimoun)(address . zimon.toutoune@gmail.com)
20210315155509.51077-1-zimon.toutoune@gmail.com
* gnu/packages/time.scm (python2-arrow): Delete.
---
gnu/packages/time.scm | 3 ---
1 file changed, 3 deletions(-)

Toggle diff (16 lines)
diff --git a/gnu/packages/time.scm b/gnu/packages/time.scm
index 73e7f04834..7de85819e0 100644
--- a/gnu/packages/time.scm
+++ b/gnu/packages/time.scm
@@ -443,9 +443,6 @@ converting dates, times, and timestamps. It implements and updates the
datetime type.")
(license asl2.0)))
-(define-public python2-arrow
- (package-with-python2 python-arrow))
-
(define-public python-aniso8601
(package
(name "python-aniso8601")
--
2.30.1
Z
Z
zimoun wrote on 15 Mar 2021 16:55
[PATCH 02/25] gnu: python2-cairocffi: Remove.
(address . 47165@debbugs.gnu.org)(name . zimoun)(address . zimon.toutoune@gmail.com)
20210315155509.51077-2-zimon.toutoune@gmail.com
* gnu/packages/python-xyz.scm (python2-cairocffi): Delete.
---
gnu/packages/python-xyz.scm | 3 ---
1 file changed, 3 deletions(-)

Toggle diff (16 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 2114503ff3..7847352290 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -6424,9 +6424,6 @@ graphics library with support for multiple backends including image buffers,
PNG, PostScript, PDF, and SVG file output.")
(license license:bsd-3)))
-(define-public python2-cairocffi
- (package-with-python2 python-cairocffi))
-
(define-public python-decorator
(package
(name "python-decorator")
--
2.30.1
Z
Z
zimoun wrote on 15 Mar 2021 16:55
[PATCH 03/25] gnu: python2-dulwich: Remove package.
(address . 47165@debbugs.gnu.org)(name . zimoun)(address . zimon.toutoune@gmail.com)
20210315155509.51077-3-zimon.toutoune@gmail.com
* gnu/packages/python-xyz.scm (python2-dulwich): Delete.
---
gnu/packages/python-xyz.scm | 3 ---
1 file changed, 3 deletions(-)

Toggle diff (16 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 7847352290..feed012fac 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -15257,9 +15257,6 @@ protocols written in pure Python.")
;; Can be used with either license.
(license (list license:asl2.0 license:gpl2+))))
-(define-public python2-dulwich
- (package-with-python2 python-dulwich))
-
(define-public python-pbkdf2
(package
(name "python-pbkdf2")
--
2.30.1
Z
Z
zimoun wrote on 15 Mar 2021 16:55
[PATCH 04/25] gnu: python2-yubikey-manager: Remove package.
(address . 47165@debbugs.gnu.org)(name . zimoun)(address . zimon.toutoune@gmail.com)
20210315155509.51077-4-zimon.toutoune@gmail.com
* gnu/packages/security-token.scm (python2-yubikey-manager): Delete.
---
gnu/packages/security-token.scm | 3 ---
1 file changed, 3 deletions(-)

Toggle diff (13 lines)
diff --git a/gnu/packages/security-token.scm b/gnu/packages/security-token.scm
index f47619aa55..e53d8590e6 100644
--- a/gnu/packages/security-token.scm
+++ b/gnu/packages/security-token.scm
@@ -670,6 +670,3 @@ that after installing this package, you might still need to add appropriate
udev rules to your system configuration to be able to configure the YubiKey as
an unprivileged user.")
(license license:bsd-2)))
-
-(define-public python2-yubikey-manager
- (package-with-python2 python-yubikey-manager))
--
2.30.1
Z
Z
zimoun wrote on 15 Mar 2021 16:55
[PATCH 05/25] gnu: python2-fido2: Remove package.
(address . 47165@debbugs.gnu.org)(name . zimoun)(address . zimon.toutoune@gmail.com)
20210315155509.51077-5-zimon.toutoune@gmail.com
* gnu/packages/security-token.scm (python2-fido2): Delete.
---
gnu/packages/security-token.scm | 3 ---
1 file changed, 3 deletions(-)

Toggle diff (16 lines)
diff --git a/gnu/packages/security-token.scm b/gnu/packages/security-token.scm
index e53d8590e6..accab82419 100644
--- a/gnu/packages/security-token.scm
+++ b/gnu/packages/security-token.scm
@@ -631,9 +631,6 @@ implementing a Relying Party.")
;; files for internal use, so they are not really a bundled dependency.
(license (list license:bsd-2 license:asl2.0))))
-(define-public python2-fido2
- (package-with-python2 python-fido2))
-
(define-public python-yubikey-manager
(package
(name "python-yubikey-manager")
--
2.30.1
Z
Z
zimoun wrote on 15 Mar 2021 16:55
[PATCH 06/25] gnu: python2-flask-wtf: Remove package.
(address . 47165@debbugs.gnu.org)(name . zimoun)(address . zimon.toutoune@gmail.com)
20210315155509.51077-6-zimon.toutoune@gmail.com
* gnu/packages/python-web.scm (python2-flask-wtf): Delete.
---
gnu/packages/python-web.scm | 3 ---
1 file changed, 3 deletions(-)

Toggle diff (16 lines)
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index e327b3b030..45ae69ee78 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -2961,9 +2961,6 @@ presume or force a developer to use a particular tool or library.")
upload, and reCAPTCHA.")
(license license:bsd-3)))
-(define-public python2-flask-wtf
- (package-with-python2 python-flask-wtf))
-
(define-public python-flask-multistatic
(package
(name "python-flask-multistatic")
--
2.30.1
Z
Z
zimoun wrote on 15 Mar 2021 16:55
[PATCH 07/25] gnu: python2-fask-babel: Remove package.
(address . 47165@debbugs.gnu.org)(name . zimoun)(address . zimon.toutoune@gmail.com)
20210315155509.51077-7-zimon.toutoune@gmail.com
* gnu/packages/python-web.scm (python2-fask-babel): Delete.
---
gnu/packages/python-web.scm | 3 ---
1 file changed, 3 deletions(-)

Toggle diff (16 lines)
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 45ae69ee78..1378629304 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -1018,9 +1018,6 @@ support for Flask. This is based on the Python babel module as well as pytz -
both of which are installed automatically if you install this library.")
(license license:bsd-3)))
-(define-public python2-flask-babel
- (package-with-python2 python-flask-babel))
-
(define-public python-flask-cors
(package
(name "python-flask-cors")
--
2.30.1
Z
Z
zimoun wrote on 15 Mar 2021 16:55
[PATCH 08/25] gnu: python2-flask-htmlmin: Remove package.
(address . 47165@debbugs.gnu.org)(name . zimoun)(address . zimon.toutoune@gmail.com)
20210315155509.51077-8-zimon.toutoune@gmail.com
* gnu/packages/python-web.scm (python2-flask-htmlmin): Delete.
---
gnu/packages/python-web.scm | 3 ---
1 file changed, 3 deletions(-)

Toggle diff (16 lines)
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 1378629304..d5f55e3d59 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -3596,9 +3596,6 @@ It comes with safe defaults and easily configurable options.")
"Minify @code{text/html} MIME type responses when using @code{Flask}.")
(license license:bsd-3)))
-(define-public python2-flask-htmlmin
- (package-with-python2 python-flask-htmlmin))
-
(define-public python-jsmin
(package
(name "python-jsmin")
--
2.30.1
Z
Z
zimoun wrote on 15 Mar 2021 16:55
[PATCH 09/25] gnu: python2-flask-login: Remove package.
(address . 47165@debbugs.gnu.org)(name . zimoun)(address . zimon.toutoune@gmail.com)
20210315155509.51077-9-zimon.toutoune@gmail.com
* gnu/packages/python-web.scm (python2-flask-login): Delete.
---
gnu/packages/python-web.scm | 3 ---
1 file changed, 3 deletions(-)

Toggle diff (16 lines)
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index d5f55e3d59..110324d689 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -3649,9 +3649,6 @@ handles the common tasks of logging in, logging out, and remembering your
users' sessions over extended periods of time.")
(license license:expat)))
-(define-public python2-flask-login
- (package-with-python2 python-flask-login))
-
(define-public python-oauth2client
(package
(name "python-oauth2client")
--
2.30.1
Z
Z
zimoun wrote on 15 Mar 2021 16:55
[PATCH 10/25] gnu: python2-flask-multistatic: Remove package.
(address . 47165@debbugs.gnu.org)(name . zimoun)(address . zimon.toutoune@gmail.com)
20210315155544.51139-1-zimon.toutoune@gmail.com
* gnu/packages/python-web.scm (python2-flask-multistatic): Delete.
---
gnu/packages/python-web.scm | 3 ---
1 file changed, 3 deletions(-)

Toggle diff (16 lines)
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 110324d689..8706caa42a 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -2978,9 +2978,6 @@ upload, and reCAPTCHA.")
for overriding static files.")
(license license:gpl3+)))
-(define-public python2-flask-multistatic
- (package-with-python2 python-flask-multistatic))
-
(define-public python-cookies
(package
(name "python-cookies")
--
2.30.1
Z
Z
zimoun wrote on 15 Mar 2021 16:55
[PATCH 11/25] gnu: python2-httpbin: Remove package.
(address . 47165@debbugs.gnu.org)(name . zimoun)(address . zimon.toutoune@gmail.com)
20210315155544.51139-2-zimon.toutoune@gmail.com
* gnu/packages/web.scm (python2-httpbin): Delete.
---
gnu/packages/web.scm | 3 ---
1 file changed, 3 deletions(-)

Toggle diff (16 lines)
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 4a14046d42..f28c3c647e 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -6135,9 +6135,6 @@ response. This exists to cover all kinds of HTTP scenarios. All endpoint respo
JSON-encoded.")
(license license:isc)))
-(define-public python2-httpbin
- (package-with-python2 python-httpbin))
-
(define-public python-pytest-httpbin
(package
(name "python-pytest-httpbin")
--
2.30.1
Z
Z
zimoun wrote on 15 Mar 2021 16:55
[PATCH 12/25] gnu: python2-flask: Remove package.
(address . 47165@debbugs.gnu.org)(name . zimoun)(address . zimon.toutoune@gmail.com)
20210315155544.51139-3-zimon.toutoune@gmail.com
* gnu/packages/python-web.scm (python2-flask): Delete.
---
gnu/packages/python-web.scm | 3 ---
1 file changed, 3 deletions(-)

Toggle diff (16 lines)
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 8706caa42a..1c4017a067 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -2923,9 +2923,6 @@ and Jinja2 template engine. It is called a micro framework because it does not
presume or force a developer to use a particular tool or library.")
(license license:bsd-3)))
-(define-public python2-flask
- (package-with-python2 python-flask))
-
(define-public python-flask-wtf
(package
(name "python-flask-wtf")
--
2.30.1
Z
Z
zimoun wrote on 15 Mar 2021 16:55
[PATCH 13/25] gnu: python2-furl: Remove package.
(address . 47165@debbugs.gnu.org)(name . zimoun)(address . zimon.toutoune@gmail.com)
20210315155544.51139-4-zimon.toutoune@gmail.com
* gnu/packages/python-web.scm (python2-furl): Delete.
---
gnu/packages/python-web.scm | 3 ---
1 file changed, 3 deletions(-)

Toggle diff (16 lines)
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 1c4017a067..7a3b8cc344 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -623,9 +623,6 @@ over a different origin than that of the web application.")
@code{urllib} and @code{urlparse} modules for manipulating URLs.")
(license license:unlicense)))
-(define-public python2-furl
- (package-with-python2 python-furl))
-
(define-public python-httplib2
(package
(name "python-httplib2")
--
2.30.1
Z
Z
zimoun wrote on 15 Mar 2021 16:55
[PATCH 14/25] gnu: python2-graphql-core: Remove package.
(address . 47165@debbugs.gnu.org)(name . zimoun)(address . zimon.toutoune@gmail.com)
20210315155544.51139-5-zimon.toutoune@gmail.com
* gnu/packages/python-xyz.scm (python2-graphql-core): Delete.
---
gnu/packages/python-xyz.scm | 3 ---
1 file changed, 3 deletions(-)

Toggle diff (16 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index feed012fac..31d760ec53 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -14609,9 +14609,6 @@ This library is a port of @url{https://github.com/graphql/graphql-js,graphql-js}
to Python.")
(license license:expat)))
-(define-public python2-graphql-core
- (package-with-python2 python-graphql-core))
-
(define-public python-graphql-relay
(package
(name "python-graphql-relay")
--
2.30.1
Z
Z
zimoun wrote on 15 Mar 2021 16:55
[PATCH 15/25] gnu: python2-ipywidgets: Remove package.
(address . 47165@debbugs.gnu.org)(name . zimoun)(address . zimon.toutoune@gmail.com)
20210315155544.51139-6-zimon.toutoune@gmail.com
* gnu/packages/python-xyz.scm (python2-ipywidgets): Delete.
---
gnu/packages/python-xyz.scm | 3 ---
1 file changed, 3 deletions(-)

Toggle diff (16 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 31d760ec53..d0f5fa18ec 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -10379,9 +10379,6 @@ widgets are used. Users gain control of their data and can visualize changes
in the data.")
(license license:bsd-3)))
-(define-public python2-ipywidgets
- (package-with-python2 python-ipywidgets))
-
(define-public python-jupyter-console
(package
(name "python-jupyter-console")
--
2.30.1
Z
Z
zimoun wrote on 15 Mar 2021 16:55
[PATCH 17/25] gnu: python2-mutagen: Remove package.
(address . 47165@debbugs.gnu.org)(name . zimoun)(address . zimon.toutoune@gmail.com)
20210315155544.51139-8-zimon.toutoune@gmail.com
* gnu/packages/music.scm (python2-mutagen): Delete.
---
gnu/packages/music.scm | 3 ---
1 file changed, 3 deletions(-)

Toggle diff (16 lines)
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 1e12bbe1a2..e9bf81d53b 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -3348,9 +3348,6 @@ APEv2 tags can be edited regardless of audio format. It can also manipulate Ogg
streams on an individual packet/page level.")
(license license:gpl2))) ; "later version" never mentioned
-(define-public python2-mutagen
- (package-with-python2 python-mutagen))
-
(define-public python-mediafile
(package
(name "python-mediafile")
--
2.30.1
Z
Z
zimoun wrote on 15 Mar 2021 16:55
[PATCH 18/25] gnu: python2-nbxmpp: Remove package.
(address . 47165@debbugs.gnu.org)(name . zimoun)(address . zimon.toutoune@gmail.com)
20210315155544.51139-9-zimon.toutoune@gmail.com
* gnu/packages/messaging.scm (python2-nbxmpp): Delete.
---
gnu/packages/messaging.scm | 3 ---
1 file changed, 3 deletions(-)

Toggle diff (16 lines)
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index 7ab6d028a3..1179e0f106 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -958,9 +958,6 @@ of xmpppy.")
(home-page "https://dev.gajim.org/gajim/python-nbxmpp")
(license license:gpl3+)))
-(define-public python2-nbxmpp
- (package-with-python2 python-nbxmpp))
-
(define-public gajim
(package
(name "gajim")
--
2.30.1
Z
Z
zimoun wrote on 15 Mar 2021 16:55
[PATCH 19/25] gnu: python2-rq: Remove package.
(address . 47165@debbugs.gnu.org)(name . zimoun)(address . zimon.toutoune@gmail.com)
20210315155544.51139-10-zimon.toutoune@gmail.com
* gnu/packages/databases.scm (python2-rq): Delete.
---
gnu/packages/databases.scm | 3 ---
1 file changed, 3 deletions(-)

Toggle diff (16 lines)
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index 8705cd2be4..a7e6f3ff73 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -3551,9 +3551,6 @@ processing them in the background with workers. It is backed by Redis and it
is designed to have a low barrier to entry.")
(license license:bsd-2)))
-(define-public python2-rq
- (package-with-python2 python-rq))
-
(define-public python-rq-scheduler
(package
(name "python-rq-scheduler")
--
2.30.1
Z
Z
zimoun wrote on 15 Mar 2021 16:55
[PATCH 16/25] gnu: python2-mpd2: Remove package.
(address . 47165@debbugs.gnu.org)(name . zimoun)(address . zimon.toutoune@gmail.com)
20210315155544.51139-7-zimon.toutoune@gmail.com
* gnu/packages/mpd.scm (python2-mpd2): Delete.
---
gnu/packages/mpd.scm | 3 ---
1 file changed, 3 deletions(-)

Toggle diff (16 lines)
diff --git a/gnu/packages/mpd.scm b/gnu/packages/mpd.scm
index 2f32364ad8..7df0d82805 100644
--- a/gnu/packages/mpd.scm
+++ b/gnu/packages/mpd.scm
@@ -307,9 +307,6 @@ information about tracks being played to a scrobbler, such as Libre.FM.")
interface for the Music Player Daemon.")
(license license:lgpl3+)))
-(define-public python2-mpd2
- (package-with-python2 python-mpd2))
-
(define-public sonata
(package
(name "sonata")
--
2.30.1
Z
Z
zimoun wrote on 15 Mar 2021 16:56
[PATCH 20/25] gnu: python2-sh: Remove package.
(address . 47165@debbugs.gnu.org)(name . zimoun)(address . zimon.toutoune@gmail.com)
20210315155616.51202-1-zimon.toutoune@gmail.com
* gnu/packages/python-xyz.scm (python2-sh): Delete.
---
gnu/packages/python-xyz.scm | 3 ---
1 file changed, 3 deletions(-)

Toggle diff (16 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index d0f5fa18ec..8f4cb7dee9 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -993,9 +993,6 @@ concepts.")
@code{subprocess} feature.")
(license license:expat)))
-(define-public python2-sh
- (package-with-python2 python-sh))
-
(define-public python-cftime
(package
(name "python-cftime")
--
2.30.1
Z
Z
zimoun wrote on 15 Mar 2021 16:56
[PATCH 21/25] gnu: python2-stem: Remove package.
(address . 47165@debbugs.gnu.org)(name . zimoun)(address . zimon.toutoune@gmail.com)
20210315155616.51202-2-zimon.toutoune@gmail.com
* gnu/packages/python-xyz.scm (python2-stem): Delete.
---
gnu/packages/python-xyz.scm | 3 ---
1 file changed, 3 deletions(-)

Toggle diff (16 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 8f4cb7dee9..0b42dbb284 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -14176,9 +14176,6 @@ control protocol to script against the Tor process and read descriptor data
relays publish about themselves.")
(license license:lgpl3)))
-(define-public python2-stem
- (package-with-python2 python-stem))
-
(define-public python-pyserial
(package
(name "python-pyserial")
--
2.30.1
Z
Z
zimoun wrote on 15 Mar 2021 16:56
[PATCH 22/25] gnu: python2-tables: Remove package.
(address . 47165@debbugs.gnu.org)(name . zimoun)(address . zimon.toutoune@gmail.com)
20210315155616.51202-3-zimon.toutoune@gmail.com
* gnu/packages/python-xyz.scm (python2-tables): Delete.
---
gnu/packages/python-xyz.scm | 3 ---
1 file changed, 3 deletions(-)

Toggle diff (16 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 0b42dbb284..f0a2d14a52 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -9461,9 +9461,6 @@ tasks, sockets, files, locks, and queues.")
designed to efficiently cope with extremely large amounts of data.")
(license license:bsd-3)))
-(define-public python2-tables
- (package-with-python2 python-tables))
-
(define-public python-sniffio
(package
(name "python-sniffio")
--
2.30.1
Z
Z
zimoun wrote on 15 Mar 2021 16:56
[PATCH 23/25] gnu: python2-utils: Remove package.
(address . 47165@debbugs.gnu.org)(name . zimoun)(address . zimon.toutoune@gmail.com)
20210315155616.51202-4-zimon.toutoune@gmail.com
* gnu/packages/python-xyz.scm (python2-utils): Delete.
---
gnu/packages/python-xyz.scm | 3 ---
1 file changed, 3 deletions(-)

Toggle diff (16 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index f0a2d14a52..09588d531b 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -16211,9 +16211,6 @@ exception message with a traceback that points to the culprit.")
make common patterns shorter and easier.")
(license license:bsd-2)))
-(define-public python2-utils
- (package-with-python2 python-utils))
-
(define-public python-diff-match-patch
(package
(name "python-diff-match-patch")
--
2.30.1
Z
Z
zimoun wrote on 15 Mar 2021 16:56
[PATCH 24/25] gnu: python2-widgetsnbextension: Remove package.
(address . 47165@debbugs.gnu.org)(name . zimoun)(address . zimon.toutoune@gmail.com)
20210315155616.51202-5-zimon.toutoune@gmail.com
* gnu/packages/python-xyz.scm (python2-widgetsnbextension): Delete.
---
gnu/packages/python-xyz.scm | 3 ---
1 file changed, 3 deletions(-)

Toggle diff (16 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 09588d531b..811b06d40d 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -10343,9 +10343,6 @@ interactive computing.")
notebooks.")
(license license:bsd-3)))
-(define-public python2-widgetsnbextension
- (package-with-python2 python-widgetsnbextension))
-
(define-public python-ipywidgets
(package
(name "python-ipywidgets")
--
2.30.1
Z
Z
zimoun wrote on 15 Mar 2021 16:56
[PATCH 25/25] gnu: python2-wsgiproxy2: Remove package.
(address . 47165@debbugs.gnu.org)(name . zimoun)(address . zimon.toutoune@gmail.com)
20210315155616.51202-6-zimon.toutoune@gmail.com
* gnu/packages/python-web.scm (python2-wsgiproxy2): Delete.
---
gnu/packages/python-web.scm | 3 ---
1 file changed, 3 deletions(-)

Toggle diff (16 lines)
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 7a3b8cc344..defd97ba00 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -2825,9 +2825,6 @@ It also includes code to sign requests and pass private data,
and to spawn subprocesses to handle requests.")
(license license:expat)))
-(define-public python2-wsgiproxy2
- (package-with-python2 python-wsgiproxy2))
-
(define-public python-pastedeploy
(package
(name "python-pastedeploy")
--
2.30.1
M
M
Maxim Cournoyer wrote on 24 Mar 2021 02:40
Re: bug#47165: [PATCH 00/25] some Python 2 removals.
(name . zimoun)(address . zimon.toutoune@gmail.com)(address . 47165-done@debbugs.gnu.org)
875z1huy5b.fsf@gmail.com
Hi Simon,

Sorry for taking my sweet time.

zimoun <zimon.toutoune@gmail.com> writes:

[...]

Toggle quote (7 lines)
> gnu: python2-arrow: Remove package.
> gnu: python2-cairocffi: Remove.
> gnu: python2-dulwich: Remove package.
> gnu: python2-yubikey-manager: Remove package.
> gnu: python2-fido2: Remove package.
> gnu: python2-flask-wtf: Remove package.
> gnu: python2-fask-babel: Remove package.
^flask
Toggle quote (3 lines)
> gnu: python2-flask-htmlmin: Remove package.
> gnu: python2-flask-login: Remove package.

I did:

removed=$(echo ' gnu: python2-arrow: Remove package.
gnu: python2-cairocffi: Remove.
gnu: python2-dulwich: Remove package.
gnu: python2-yubikey-manager: Remove package.
gnu: python2-fido2: Remove package.
gnu: python2-flask-wtf: Remove package.
gnu: python2-flask-babel: Remove package.
gnu: python2-flask-htmlmin: Remove package.
gnu: python2-flask-login: Remove package.
gnu: python2-flask-multistatic: Remove package.
gnu: python2-httpbin: Remove package.
gnu: python2-flask: Remove package.
gnu: python2-furl: Remove package.
gnu: python2-graphql-core: Remove package.
gnu: python2-ipywidgets: Remove package.
gnu: python2-mpd2: Remove package.
gnu: python2-mutagen: Remove package.
gnu: python2-nbxmpp: Remove package.
gnu: python2-rq: Remove package.
gnu: python2-sh: Remove package.
gnu: python2-stem: Remove package.
gnu: python2-tables: Remove package.
gnu: python2-utils: Remove package.
gnu: python2-widgetsnbextension: Remove package.
gnu: python2-wsgiproxy2: Remove package.
' | cut -d':' -f2)

$ guix refresh -l $removed

Building the following 7 packages would ensure 8 dependent packages are rebuilt: python2-yubikey-manager@2.1.0 python2-flask-multistatic@1.0 python2-flask-htmlmin@1.2 python2-flask-wtf@0.14.3 python2-flask-login@0.5.0 python2-httpbin@0.5.0 python2-ipywidgets@7.5.1
maxim@hurd ~/src/guix [env]$ guix search python2-yubikey-manager

All these packages are removed by the above, so it looks good to me,
apart from the one typo spotted earlier.

From the Debbugs summary buffer, I M-x cd ~/src/guix RET, then moved to
the 01/25 patch, did C-u 24 | git am --signoff to apply all the patches
to my tree, reviewed them there (mostly checking no special python2
property had been left behind), then pushed.

Thank you for taking care of this!

Closing.

Maxim
Closed
?