[PATCH] etc: Run pre-push make in guix environment.

  • Open
  • quality assurance status badge
Details
3 participants
  • Leo Prikler
  • Tobias Geerinckx-Rice
  • zimoun
Owner
unassigned
Submitted by
Tobias Geerinckx-Rice
Severity
normal
T
T
Tobias Geerinckx-Rice wrote on 11 Mar 2021 15:42
(address . guix-patches@gnu.org)
20210311144257.4203-1-me@tobias.gr
* etc/git/pre-push: Exec make in a guix development environment.
---

Guix,

The pre-push assumes you have make installed, which I didn't.

Now it assumes that Guix developers have a vaguely up-to-date guix
command, which seems reasonable.

Kind regards,

T G-R

etc/git/pre-push | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

Toggle diff (15 lines)
diff --git a/etc/git/pre-push b/etc/git/pre-push
index 59671b0d58..372c7dece0 100755
--- a/etc/git/pre-push
+++ b/etc/git/pre-push
@@ -32,7 +32,7 @@ do
# Only use the hook when pushing to Savannah.
case "$2" in
*.gnu.org*)
- exec make authenticate check-channel-news
+ exec guix environment guix -- make authenticate check-channel-news
exit 127
;;
*)
--
2.30.1
Z
Z
zimoun wrote on 26 Mar 2021 09:20
(name . Tobias Geerinckx-Rice)(address . me@tobias.gr)(address . 47069@debbugs.gnu.org)
86lfaaba2m.fsf@gmail.com
Hi Tobias,

On Thu, 11 Mar 2021 at 15:42, Tobias Geerinckx-Rice <me@tobias.gr> wrote:
Toggle quote (5 lines)
> * etc/git/pre-push: Exec make in a guix development environment.
> ---

> The pre-push assumes you have make installed, which I didn't.

How do you rebuild Guix before pushing?


Cheers,
simon
L
L
Leo Prikler wrote on 26 Mar 2021 11:11
(address . 47069@debbugs.gnu.org)
60a9423555bdb4202c8684d3a5b5780b13422599.camel@student.tugraz.at
Am Freitag, den 26.03.2021, 09:20 +0100 schrieb zimoun:
Toggle quote (9 lines)
> Hi Tobias,
>
> On Thu, 11 Mar 2021 at 15:42, Tobias Geerinckx-Rice <me@tobias.gr>
> wrote:
> > * etc/git/pre-push: Exec make in a guix development environment.
> > ---
> > The pre-push assumes you have make installed, which I didn't.
>
> How do you rebuild Guix before pushing?
If that's a problem for the script, you could add an explicit 'all'
target.

That said, I think, that many developers (myself included), who would
suffer from the problem mentioned by Tobias already run 'git push'
inside a guix environment. I know I do.
@Tobias: would it make sense to detect that case (via GUIX_ENVIRONMENT)
and only optionally construct the guix environment?

Regards,
Leo
?