[PATCH] gnu: add ekho

  • Done
  • quality assurance status badge
Details
2 participants
  • Nicolas Goaziou
  • qblade
Owner
unassigned
Submitted by
qblade
Severity
normal
Q
Q
qblade wrote on 24 Feb 2021 12:43
(name . guix-patches@gnu.org)(address . guix-patches@gnu.org)
lV3vhQwRCKG-2EZO42fRTPzxCrjRhYX_vBCWaPuhpznRD5ToyfpsMqYj_G1IYfHxxNBFGcsRsLR6rcORZHHkFrUKk0PWeFGURHoJL6g8LUI=@protonmail.com
Empty Message
From 28c74e38d5b1b27aa83385b0c6a9ddec62ff3416 Mon Sep 17 00:00:00 2001
From: qblade <qblade@protonmail.com>
Date: Wed, 24 Feb 2021 11:35:35 +0000
Subject: [PATCH] gnu: add ekho

* gnu/packages/speech.scm (ekho): New variable.
---
gnu/packages/speech.scm | 36 ++++++++++++++++++++++++++++++++++++
1 file changed, 36 insertions(+)

Toggle diff (53 lines)
diff --git a/gnu/packages/speech.scm b/gnu/packages/speech.scm
index 66d8fca31b..793b4fe626 100644
--- a/gnu/packages/speech.scm
+++ b/gnu/packages/speech.scm
@@ -7,6 +7,7 @@
;;; Copyright © 2019 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2020 Nicolas Goaziou <mail@nicolasgoaziou.fr>
;;; Copyright © 2020 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2021 qblade <qblade@protonmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -616,3 +617,38 @@ manipulating acoustic feature and audio files.")
large vocabulary, speaker-independent continuous speech recognition
engine.")
(license license:bsd-2)))
+
+(define-public ekho
+ (package
+ (name "ekho")
+ (version "8.4")
+ (source (origin
+ (method url-fetch)
+ (uri
+ (string-append
+ "http://sourceforge.net/projects/e-guidedog/files/Ekho/"
+ version "/ekho-" version ".tar.xz"))
+ (sha256
+ (base32
+ "1v476kpw09ljj8mavasj4hya2w11jwlx7q22rh1lsn9jkkam5i2a"))))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (inputs
+ `(("libsndfile" ,libsndfile)
+ ("espeak-ng" ,espeak-ng)
+ ("pulseaudio" ,pulseaudio)
+ ("alsa-lib" ,alsa-lib)))
+ (build-system gnu-build-system)
+ (native-search-paths
+ (list (search-path-specification
+ (variable "EKHO_DATA_PATH")
+ (files '("share/ekho-data")))))
+ (home-page "https://eguidedog.net/ekho.php")
+ (synopsis "Chinese text-to-speech software")
+ (description "it can speak Cantonese
+Mandarin, Hakka, Tibetan, Ngangien and English (through Festival),
+Korean is in trial.")
+ (license (list
+ license:gpl2+
+ ;; libmusicxml
+ license:mpl2.0))))
--
2.29.2
N
N
Nicolas Goaziou wrote on 27 Feb 2021 12:45
(name . qblade via Guix-patches via)(address . guix-patches@gnu.org)
875z2d3f9y.fsf@nicolasgoaziou.fr
Hello,

qblade via Guix-patches via <guix-patches@gnu.org> writes:

Toggle quote (2 lines)
> Subject: [PATCH] gnu: add ekho

Thank you.

I changed the source URI to use a Sourceforge mirror, re-orderer inputs
alphabetically, and reworded description a bit.

Applied!

Regards,
--
Nicolas Goaziou
?