[PATCH] gnu: add python-esptool

  • Done
  • quality assurance status badge
Details
2 participants
  • Nicolas Goaziou
  • qblade
Owner
unassigned
Submitted by
qblade
Severity
normal
Q
Q
qblade wrote on 24 Feb 2021 12:41
(name . guix-patches@gnu.org)(address . guix-patches@gnu.org)
wS5kAqiLwointpfvYZ1w6sbzUCFb20EKtQI4fdz-YGIZ4M5QiEEd95sGVRJrKb-Y9PDM-Tw8PjlTdrxeRuE8Bu8Iv4cuRnn8Vit6U5J0lZw=@protonmail.com
Empty Message
From aa87fca639c6caefa0dee22a76af8d3dbc0206a0 Mon Sep 17 00:00:00 2001
From: qblade <qblade@protonmail.com>
Date: Tue, 23 Feb 2021 01:13:09 +0000
Subject: [PATCH] gnu: add python-esptool

* gnu/packages/engineering.scm (python-esptool-3.0): New variable.
---
gnu/packages/engineering.scm | 31 +++++++++++++++++++++++++++++++
1 file changed, 31 insertions(+)

Toggle diff (55 lines)
diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index 11585f6234..36969e00e0 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -21,6 +21,7 @@
;;; Copyright © 2020 B. Wilson <elaexuotee@wilsonb.com>
;;; Copyright © 2020, 2021 Vinicius Monego <monego@posteo.net>
;;; Copyright © 2020, 2021 Morgan Smith <Morgan.J.Smith@outlook.com>
+;;; Copyright © 2021 qblade <qblade@protonmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -106,6 +107,7 @@
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages pretty-print)
#:use-module (gnu packages python)
+ #:use-module (gnu packages python-crypto)
#:use-module (gnu packages python-xyz)
#:use-module (gnu packages qt)
#:use-module (gnu packages readline)
@@ -2996,3 +2998,32 @@ and drilling of PCBs. It takes Gerber files as input and outputs G-code files
for the milling of PCBs. It also includes an autoleveller for the automatic
dynamic calibration of the milling depth.")
(license license:gpl3+)))
+
+(define-public python-esptool-3.0
+ (package
+ (name "python-esptool")
+ (version "3.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "esptool" version))
+ (sha256
+ (base32
+ "0d69rd9h8wrzjvfrc66vmz4qd5hly2fpdcwj2bdrlb7dbwikv5c7"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:tests? #f))
+ (propagated-inputs
+ `(("python-ecdsa" ,python-ecdsa)
+ ("python-pyaes" ,python-pyaes)
+ ("python-pyserial" ,python-pyserial)))
+ (home-page
+ "https://github.com/espressif/esptool")
+ (synopsis
+ "Serial utility to communicate & flash code to
+Espressif ESP8266 & ESP32 chips")
+ (description
+ "Python-based, open source, platform independent,
+utility to communicate with the ROM bootloader
+in Espressif ESP8266 & ESP32 series chips.")
+ (license license:gpl2+)))
--
2.29.2
N
N
Nicolas Goaziou wrote on 25 Feb 2021 10:46
(name . qblade via Guix-patches via)(address . guix-patches@gnu.org)
87eeh4fpip.fsf@nicolasgoaziou.fr
Hello,

Thank you. I applied the patch with minor modifications.

qblade via Guix-patches via <guix-patches@gnu.org> writes:

Toggle quote (3 lines)
> + (arguments
> + `(#:tests? #f))

I added a comment explaining why the tests were skipped. In this case,
we do not provide python-reedsolo library yet.

Toggle quote (4 lines)
> + (synopsis
> + "Serial utility to communicate & flash code to
> +Espressif ESP8266 & ESP32 chips")

I shortened the synopsis.

Toggle quote (5 lines)
> + (description
> + "Python-based, open source, platform independent,
> +utility to communicate with the ROM bootloader
> +in Espressif ESP8266 & ESP32 series chips.")

I wrote a full sentence, and remove "open source", and "platform
independant" from it.

Regards,
--
Nicolas Goaziou
?