[PATCH] gnu: Add emacs-ido-at-point.

  • Done
  • quality assurance status badge
Details
2 participants
  • Nicolas Goaziou
  • Masaya Tojo
Owner
unassigned
Submitted by
Masaya Tojo
Severity
normal
M
M
Masaya Tojo wrote on 23 Feb 2021 11:54
(address . guix-patches@gnu.org)(name . Masaya Tojo)(address . masaya@tojo.tokyo)
20210223105422.24036-1-masaya@tojo.tokyo
* gnu/packages/emacs-xyz.scm (emacs-ido-at-point): New variable.
---
gnu/packages/emacs-xyz.scm | 24 +++++++++++++++++++++++-
1 file changed, 23 insertions(+), 1 deletion(-)

Toggle diff (41 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 71564dcd0c..6d492b33eb 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -60,7 +60,7 @@
;;; Copyright © 2020 Paul Garlick <pgarlick@tourbillion-technology.com>
;;; Copyright © 2020 Robert Smith <robertsmith@posteo.net>
;;; Copyright © 2020 Evan Straw <evan.straw99@gmail.com>
-;;; Copyright © 2020 Masaya Tojo <masaya@tojo.tokyo>
+;;; Copyright © 2020, 2021 Masaya Tojo <masaya@tojo.tokyo>
;;; Copyright © 2020, 2021 Martin Becze <mjbecze@riseup.net>
;;; Copyright © 2020, 2021 Michael Rohleder <mike@rohleder.de>
;;; Copyright © 2020 Brice Waegeneire <brice@waegenei.re>
@@ -26887,3 +26887,25 @@ to pastebin-like services. It supports more than one service and will
failover if one service fails. More services can easily be added over time
and prefered services can easily be configured.")
(license license:gpl3+)))
+
+(define-public emacs-ido-at-point
+ (package
+ (name "emacs-ido-at-point")
+ (version "1.0.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/katspaugh/ido-at-point")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1bii7vj8pmmijcpvq3a1scky4ais7k6d7zympb3m9dmz355m9rpp"))))
+ (build-system emacs-build-system)
+ (synopsis "Ido-style completion-at-point")
+ (description
+ "This package is an alternative frontend for @code{completion-at-point}.
+It replaces the standard completions buffer with ido prompt. Press <M-tab>
+or <C-M-i> to complete a symbol at point.")
+ (home-page "https://github.com/katspaugh/ido-at-point")
+ (license license:gpl3+)))
--
2.30.1
N
N
Nicolas Goaziou wrote on 23 Feb 2021 13:49
(name . Masaya Tojo)(address . masaya@tojo.tokyo)(address . 46714-done@debbugs.gnu.org)
878s7flzj4.fsf@nicolasgoaziou.fr
Hello,

Masaya Tojo <masaya@tojo.tokyo> writes:

Toggle quote (2 lines)
> * gnu/packages/emacs-xyz.scm (emacs-ido-at-point): New variable.

Applied. Thank you.

Regards,
--
Nicolas Goaziou
Closed
?