[PATCH] Added HDF5 1.12.0.

  • Done
  • quality assurance status badge
Details
2 participants
  • Gerd Heber
  • Leo Famulari
Owner
unassigned
Submitted by
Gerd Heber
Severity
normal
G
G
Gerd Heber wrote on 21 Feb 2021 19:57
(address . guix-patches@gnu.org)(name . Gerd Heber)(address . gheber@hdfgroup.org)
20210221185751.10341-1-gheber@hdfgroup.org
---
gnu/packages/maths.scm | 19 +++++++++++++++++++
1 file changed, 19 insertions(+)

Toggle diff (32 lines)
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 42f3881bbc..a40e4677af 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -1219,6 +1219,25 @@ extremely large and complex data collections.")
(base32 "0pm5xxry55i0h7wmvc7svzdaa90rnk7h78rrjmnlkz2ygsn8y082"))
(patches (search-patches "hdf5-config-date.patch"))))))
+(define-public hdf5-1.12
+ (package/inherit hdf5-1.8
+ (version "1.12.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (list (string-append "https://support.hdfgroup.org/ftp/HDF5/releases/"
+ "hdf5-" (version-major+minor version)
+ "/hdf5-" version "/src/hdf5-"
+ version ".tar.bz2")
+ (string-append "https://support.hdfgroup.org/ftp/HDF5/"
+ "current"
+ (apply string-append
+ (take (string-split version #\.) 2))
+ "/src/hdf5-" version ".tar.bz2")))
+ (sha256
+ (base32 "0qazfslkqbmzg495jafpvqp0khws3jkxa0z7rph9qvhacil6544p"))
+ (patches (search-patches "hdf5-config-date.patch"))))))
+
(define-public hdf5
;; Default version of HDF5.
hdf5-1.10)
--
2.30.1
L
L
Leo Famulari wrote on 21 Feb 2021 22:04
(no subject)
(address . control@debbugs.gnu.org)
YDLK7iL4loWMx+ZM@jasmine.lan
close 46693
L
L
Leo Famulari wrote on 21 Feb 2021 22:04
Re: [bug#46693] [PATCH] Added HDF5 1.12.0.
(name . Gerd Heber)(address . gerd.heber@gmail.com)
YDLK3rVLBSBT+CA3@jasmine.lan
On Sun, Feb 21, 2021 at 12:57:51PM -0600, Gerd Heber wrote:
Toggle quote (14 lines)
> ---
> gnu/packages/maths.scm | 19 +++++++++++++++++++
> 1 file changed, 19 insertions(+)
>
> diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
> index 42f3881bbc..a40e4677af 100644
> --- a/gnu/packages/maths.scm
> +++ b/gnu/packages/maths.scm
> @@ -1219,6 +1219,25 @@ extremely large and complex data collections.")
> (base32 "0pm5xxry55i0h7wmvc7svzdaa90rnk7h78rrjmnlkz2ygsn8y082"))
> (patches (search-patches "hdf5-config-date.patch"))))))
>
> +(define-public hdf5-1.12

Thanks! I wrote the commit message, added your name to the list of
authors, and pushed as f601cdc6981888f55882c942dab413cb783caecc
?