[PATCH] gnu: add libucl

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • qblade
Owner
unassigned
Submitted by
qblade
Severity
normal
Q
Q
qblade wrote on 21 Feb 2021 08:21
(name . guix-patches@gnu.org)(address . guix-patches@gnu.org)
h7NfSSBWXKgCk4KXIid6eBO4hUAtZfaVRlalkRTyiBp6dUlwxLm3xJMj3rWtGQEPu7jyU6g3X5EL9eJNNp32LHvOX-GDBiJPik7vDgJqzXI=@protonmail.com
Empty Message
From aae95593f1cfd48c50578bec83927c870afc6bce Mon Sep 17 00:00:00 2001
From: qblade <qblade@protonmail.com>
Date: Sun, 21 Feb 2021 06:48:18 +0000
Subject: [PATCH] gnu: add libucl

* gnu/packages/config-lang.scm (libucl): New variable.
---
gnu/packages/config-lang.scm | 54 ++++++++++++++++++++++++++++++++++++
1 file changed, 54 insertions(+)
create mode 100644 gnu/packages/config-lang.scm

Toggle diff (62 lines)
diff --git a/gnu/packages/config-lang.scm b/gnu/packages/config-lang.scm
new file mode 100644
index 0000000000..8ef0b1cdb6
--- /dev/null
+++ b/gnu/packages/config-lang.scm
@@ -0,0 +1,54 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2021 qblade <qblade@protonmail.com>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages config-lang)
+ #:use-module (gnu packages)
+ #:use-module ((guix licenses) #:prefix license:)
+ #:use-module (guix packages)
+ #:use-module (gnu packages autotools)
+ #:use-module (gnu packages pkg-config)
+ #:use-module (guix build-system gnu)
+ #:use-module (guix git-download))
+
+(define-public libucl
+ (package
+ (name "libucl")
+ (version "0.8.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/vstakhov/libucl/")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1h52ldxankyhbbm1qbqz1f2q0j03c1b4mig7343bs3mc6fpm18gf"))))
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("pkg-config" ,pkg-config)
+ ("libtool" ,libtool)))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f)) ;; no tests
+ (home-page "https://github.com/vstakhov/libucl")
+ (synopsis "Universal configuration language")
+ (description "Universal configuration language.
+fully compatible with JSON format and is able to parse json files")
+ (license license:bsd-2)))
--
2.29.2
L
L
Ludovic Courtès wrote on 6 Mar 2021 11:32
(name . qblade)(address . qblade@protonmail.com)(address . 46686@debbugs.gnu.org)
87sg58incc.fsf@gnu.org
Hi,

qblade <qblade@protonmail.com> skribis:

Toggle quote (7 lines)
> From aae95593f1cfd48c50578bec83927c870afc6bce Mon Sep 17 00:00:00 2001
> From: qblade <qblade@protonmail.com>
> Date: Sun, 21 Feb 2021 06:48:18 +0000
> Subject: [PATCH] gnu: add libucl
>
> * gnu/packages/config-lang.scm (libucl): New variable.

Thanks for the patch! It looks good to me, modulo the minor issues
below.

Toggle quote (2 lines)
> gnu/packages/config-lang.scm | 54 ++++++++++++++++++++++++++++++++++++

Could you perhaps find another file to add it to, so we don’t have a
module for a single package? That said, I don’t have a good suggestion,
since ‘iniparser’ for instance is in samba.scm.

Toggle quote (4 lines)
> + (synopsis "Universal configuration language")
> + (description "Universal configuration language.
> +fully compatible with JSON format and is able to parse json files")

Could you reword the description with full sentences, along the lines of:


Make sure to capitalize acronyms like JSON.

TIA,
Ludo’.
Q
Q
qblade wrote on 7 Mar 2021 04:08
(name . Ludovic Courtès)(address . ludo@gnu.org)(name . 46686@debbugs.gnu.org)(address . 46686@debbugs.gnu.org)
6tSVk4Fiug-ZOTbsSW7r2irpw0gLdYAmYwzv20UdrLbGWBXntkODGHfA-mJa92yd9jMwVoVt2OtxiFcsVMKsUYpMzp50FGBXqZ7SYIQmIVc=@protonmail.com
Hello, I submitted a new patch, because libucl is currently only used in hikari (I will submit its package definition later) I decided to put it in gnu/packages/wm.scm

hikari's home pager: https://hikari.acmelabs.space/
From f80bb9ea8d4161e351b30b6154d25cbfca8095fd Mon Sep 17 00:00:00 2001
From: qblade <qblade@protonmail.com>
Date: Sun, 7 Mar 2021 02:31:07 +0000
Subject: [PATCH] gnu: add libucl

* gnu/packages/wm.scm (libucl): New variable.
---
gnu/packages/wm.scm | 29 +++++++++++++++++++++++++++++
1 file changed, 29 insertions(+)

Toggle diff (46 lines)
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index 5d2b36f312..90453da1c8 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -42,6 +42,7 @@
;; Copyright © 2020 Niklas Eklund <niklas.eklund@posteo.net>
;;; Copyright © 2020 Robert Smith <robertsmith@posteo.net>
;;; Copyright © 2021 Zheng Junjie <873216071@qq.com>
+;;; Copyright © 2021 qblade <qblade@protonmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -2350,3 +2351,31 @@ shows a notification for the user on the screen.")
for wayland conceptually based on the X11 window manager
@command{ratpoison}.")
(license license:expat)))
+
+(define-public libucl
+ (package
+ (name "libucl")
+ (version "0.8.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/vstakhov/libucl/")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1h52ldxankyhbbm1qbqz1f2q0j03c1b4mig7343bs3mc6fpm18gf"))))
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("pkg-config" ,pkg-config)
+ ("libtool" ,libtool)))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f)) ;; no tests
+ (home-page "https://github.com/vstakhov/libucl")
+ (synopsis "Universal configuration language parser")
+ (description "libucl is a configuration language
+that is easy to read, write and compatible with JSON.")
+ (license license:bsd-2)))
--
2.29.2
L
L
Ludovic Courtès wrote on 17 Mar 2021 22:24
Re: bug#46686: [PATCH] gnu: add libucl
(name . qblade)(address . qblade@protonmail.com)(name . 46686@debbugs.gnu.org)(address . 46686-done@debbugs.gnu.org)
87r1kdxyl7.fsf_-_@gnu.org
Hi,

qblade <qblade@protonmail.com> skribis:

Toggle quote (7 lines)
> From f80bb9ea8d4161e351b30b6154d25cbfca8095fd Mon Sep 17 00:00:00 2001
> From: qblade <qblade@protonmail.com>
> Date: Sun, 7 Mar 2021 02:31:07 +0000
> Subject: [PATCH] gnu: add libucl
>
> * gnu/packages/wm.scm (libucl): New variable.

Applied with minor tweaks to the description.

Thanks,
Ludo’.
Closed
?