[PATCH 1/2] gnu: Add python-pdfminer.six.

  • Done
  • quality assurance status badge
Details
2 participants
  • Nicolas Goaziou
  • Vinicius Monego
Owner
unassigned
Submitted by
Vinicius Monego
Severity
normal
V
V
Vinicius Monego wrote on 20 Feb 2021 08:05
(address . guix-patches@gnu.org)(name . Vinicius Monego)(address . monego@posteo.net)
20210220070503.36250-1-monego@posteo.net
* gnu/packages/python-xyz.scm (python-pdfminer.six): New variable.
---
gnu/packages/python-xyz.scm | 49 +++++++++++++++++++++++++++++++++++++
1 file changed, 49 insertions(+)

Toggle diff (62 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index a504bb521b..fe55d9b74e 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -12251,6 +12251,55 @@ encoding algorithms to do fuzzy string matching.")
module, adding support for Unicode strings.")
(license license:bsd-2)))
+(define-public python-pdfminer.six
+ (package
+ (name "python-pdfminer.six")
+ (version "20201018")
+ ;; There are no tests in the PyPI tarball.
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/pdfminer/pdfminer.six")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1a2fxxnnjqbx344znpvx7cnv1881dk6585ibw01inhfq3w6yj2lr"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ ;; Tests write to the source tree.
+ (add-after 'unpack 'make-git-checkout-writable
+ (lambda _
+ (for-each make-file-writable (find-files "."))
+ #t))
+ (replace 'check
+ (lambda _
+ (invoke "make" "test")))
+ (add-before 'reset-gzip-timestamps 'make-files-writable
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ (for-each make-file-writable
+ (find-files out "\\.gz$"))
+ #t))))))
+ (propagated-inputs
+ `(("python-chardet" ,python-chardet)
+ ("python-cryptography" ,python-cryptography)
+ ("python-sortedcontainers"
+ ,python-sortedcontainers)))
+ (native-inputs
+ `(("python-nose" ,python-nose)
+ ("python-tox" ,python-tox)))
+ (home-page "https://github.com/pdfminer/pdfminer.six")
+ (synopsis "PDF parser and analyzer")
+ (description "@code{pdfminer.six} is a community maintained fork of
+the original PDFMiner. It is a tool for extracting information from PDF
+documents. It focuses on getting and analyzing text data. Pdfminer.six
+extracts the text from a page directly from the sourcecode of the PDF. It
+can also be used to get the exact location, font or color of the text.")
+ (license license:expat)))
+
(define-public python-rarfile
(package
(name "python-rarfile")
--
2.30.1
V
V
Vinicius Monego wrote on 20 Feb 2021 08:06
[PATCH 2/2] gnu: setzer: Update to 0.4.1.
(address . 46654@debbugs.gnu.org)(name . Vinicius Monego)(address . monego@posteo.net)
20210220070637.36397-1-monego@posteo.net
* gnu/packages/gnome.scm (setzer): Update to 0.4.1.
[inputs]: Add python-pdfminer.six.
---
gnu/packages/gnome.scm | 5 +++--
1 file changed, 3 insertions(+), 2 deletions(-)

Toggle diff (32 lines)
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index ebb21c08ce..37db6fbdc6 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -11468,7 +11468,7 @@ and toolbars.")
(define-public setzer
(package
(name "setzer")
- (version "0.3.9")
+ (version "0.4.1")
(source
(origin
(method git-fetch)
@@ -11477,7 +11477,7 @@ and toolbars.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "1qmy2bxl8x6pijjaaj91v6rqdipha6iyy0b6b9y1lk3r2p3azd42"))))
+ (base32 "1rcx2c07jg1ij81pnvg3px49hfbjmkagn68d3gp79z3gcajbp2av"))))
(build-system meson-build-system)
(arguments
`(#:glib-or-gtk? #t
@@ -11509,6 +11509,7 @@ and toolbars.")
("gtksourceview" ,gtksourceview)
("pango" ,pango)
("poppler" ,poppler)
+ ("python-pdfminer" ,python-pdfminer.six)
("python-pycairo" ,python-pycairo)
("python-pygobject" ,python-pygobject)
("python-pyxdg" ,python-pyxdg)
--
2.30.1
N
N
Nicolas Goaziou wrote on 21 Feb 2021 01:23
(name . Vinicius Monego)(address . monego@posteo.net)(address . 46654-done@debbugs.gnu.org)
874ki6z2u1.fsf@nicolasgoaziou.fr
Hello,

Vinicius Monego <monego@posteo.net> writes:

Toggle quote (3 lines)
> * gnu/packages/gnome.scm (setzer): Update to 0.4.1.
> [inputs]: Add python-pdfminer.six.

I used python-pdfminer-six name instead of python-pdfminer.six, and
applied both patches.

Thank you.

Regards,
--
Nicolas Goaziou
Closed
?