[PATCH 1/2] gnu: Add python-pillow-simd.

  • Done
  • quality assurance status badge
Details
2 participants
  • Nicolas Goaziou
  • Vinicius Monego
Owner
unassigned
Submitted by
Vinicius Monego
Severity
normal
V
V
Vinicius Monego wrote on 20 Feb 2021 03:51
(address . guix-patches@gnu.org)(name . Vinicius Monego)(address . monego@posteo.net)
20210220025149.31960-1-monego@posteo.net
* gnu/packages/python-xyz.scm (python-pillow-simd): New variable.
---
gnu/packages/python-xyz.scm | 35 ++++++++++++++++++++++++++++++++++-
1 file changed, 34 insertions(+), 1 deletion(-)

Toggle diff (55 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index a504bb521b..ac8fce8cf7 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -82,7 +82,7 @@
;;; Copyright © 2020 Josh Holland <josh@inv.alid.pw>
;;; Copyright © 2020 Yuval Kogman <nothingmuch@woobling.org>
;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
-;;; Copyright © 2020 Vinicius Monego <monego@posteo.net>
+;;; Copyright © 2020, 2021 Vinicius Monego <monego@posteo.net>
;;; Copyright © 2020 Guy Fleury Iteriteka <gfleury@disroot.org>
;;; Copyright © 2020 Hendursaga <hendursaga@yahoo.com>
;;; Copyright © 2020 Malte Frank Gerdes <malte.f.gerdes@gmail.com>
@@ -5894,6 +5894,39 @@ a general image processing tool.")
((#:tests? _ #f) #f)))
(properties '((hidden? #t)))))
+(define-public python-pillow-simd
+ (package
+ (inherit python-pillow)
+ (name "python-pillow-simd")
+ (version "7.1.2")
+ ;; The PyPI tarball does not include test files.
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/uploadcare/pillow-simd")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0w11np4cybamry3jsg70x747c79zwjzfq0xiprfp6c186rd6nzp9"))))
+ (arguments
+ (substitute-keyword-arguments
+ (package-arguments python-pillow)
+ ((#:phases phases)
+ `(modify-phases ,phases
+ (add-after 'unpack 'make-tests-writable
+ (lambda _
+ (for-each make-file-writable (find-files "Tests"))
+ #t))))))
+ (inputs
+ `(("libraqm" ,libraqm)
+ ("libimagequant" ,libimagequant)
+ ,@(package-inputs python-pillow)))
+ (home-page "https://github.com/uploadcare/pillow-simd")
+ (synopsis "Fork of the Python Imaging Library (Pillow)")
+ (description "This package is a fork of Pillow which adds support for SIMD
+parallelism.")))
+
(define-public python-roifile
(package
(name "python-roifile")
--
2.30.1
V
V
Vinicius Monego wrote on 20 Feb 2021 03:53
[PATCH 2/2] gnu: Add imgp.
(address . 46652@debbugs.gnu.org)(name . Vinicius Monego)(address . monego@posteo.net)
20210220025354.32085-1-monego@posteo.net
* gnu/packages/image.scm (imgp): New variable.
---
gnu/packages/image.scm | 35 ++++++++++++++++++++++++++++++++++-
1 file changed, 34 insertions(+), 1 deletion(-)

Toggle diff (55 lines)
diff --git a/gnu/packages/image.scm b/gnu/packages/image.scm
index 28169b0295..68221afff1 100644
--- a/gnu/packages/image.scm
+++ b/gnu/packages/image.scm
@@ -27,7 +27,7 @@
;;; Copyright © 2020 R Veera Kumar <vkor@vkten.in>
;;; Copyright © 2020 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2020 Zhu Zihao <all_but_last@163.com>
-;;; Copyright © 2020 Vinicius Monego <monego@posteo.net>
+;;; Copyright © 2020, 2021 Vinicius Monego <monego@posteo.net>
;;; Copyright © 2021 Sharlatan Hellseher <sharlatanus@gmail.com>
;;;
;;; This file is part of GNU Guix.
@@ -1581,6 +1581,39 @@ PNG, and performs PNG integrity checks and corrections.")
(home-page "http://optipng.sourceforge.net/")
(license license:zlib)))
+(define-public imgp
+ (package
+ (name "imgp")
+ (version "2.8")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "imgp" version))
+ (sha256
+ (base32 "0q99h9wv9rynig0s0flnr9mxi541zzl0gw8vh4y6m5x132diilri"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:tests? #f ;there are no tests
+ #:phases
+ (modify-phases %standard-phases
+ ;; setup.py expects the file to be named 'imgp'.
+ (add-after 'unpack 'rename-imgp
+ (lambda _
+ (rename-file "imgp.py" "imgp")
+ #t)))))
+ (inputs
+ `(("python-pillow" ,python-pillow)))
+ (home-page "https://github.com/jarun/imgp")
+ (synopsis "High-performance CLI batch image resizer & rotator")
+ (description
+ "@code{imgp} is a command line image resizer and rotator for JPEG and PNG
+images. It can resize (or thumbnail) and rotate thousands of images in a go
+while saving significantly on storage.
+
+This package may optionally be built with @code{python-pillow-simd} in place
+of @{python-pillow} for SIMD parallelism.")
+ (license license:gpl3+)))
+
(define-public pngsuite
(package
(name "pngsuite")
--
2.30.1
N
N
Nicolas Goaziou wrote on 21 Feb 2021 01:16
(name . Vinicius Monego)(address . monego@posteo.net)(address . 46652-done@debbugs.gnu.org)
878s7iz34e.fsf@nicolasgoaziou.fr
Hello,

Vinicius Monego <monego@posteo.net> writes:

Toggle quote (2 lines)
> * gnu/packages/image.scm (imgp): New variable.

Applied both patches. Thank you.

Regards,
--
Nicolas Goaziou
Closed
?