[PATCH] gnu: Add pwsafe-cli.

  • Done
  • quality assurance status badge
Details
3 participants
  • Léo Le Bouter
  • Nicolas Goaziou
  • Stefan Reichör
Owner
unassigned
Submitted by
Stefan Reichör
Severity
normal
S
S
Stefan Reichör wrote on 19 Feb 2021 22:16
(address . guix-patches@gnu.org)(name . Stefan Reichör)(address . stefan@xsteve.at)
20210219211616.166900-1-stefan@xsteve.at
* gnu/packages/password-utils.scm (pwsafe-cli): New variable.
---
gnu/packages/password-utils.scm | 44 +++++++++++++++++++++++++++++++++
1 file changed, 44 insertions(+)

Toggle diff (71 lines)
diff --git a/gnu/packages/password-utils.scm b/gnu/packages/password-utils.scm
index ef4bf535a4..6d6834cfd5 100644
--- a/gnu/packages/password-utils.scm
+++ b/gnu/packages/password-utils.scm
@@ -29,6 +29,7 @@
;;; Copyright © 2020 Jean-Baptiste Note <jean-baptiste.note@m4x.org>
;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
;;; Copyright © 2020 Vinicius Monego <monego@posteo.net>
+;;; Copyright © 2021 Stefan Reichör <stefan@xsteve.at>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -58,6 +59,7 @@
#:use-module (gnu packages admin)
#:use-module (gnu packages aidc)
#:use-module (gnu packages authentication)
+ #:use-module (gnu packages autotools)
#:use-module (gnu packages base)
#:use-module (gnu packages check)
#:use-module (gnu packages compression)
@@ -255,6 +257,48 @@ There are other programs that support the file format on different
platforms.")
(license license:artistic2.0)))
+(define-public pwsafe-cli
+ (let ((commit "c49a0541b66647ad04d19ddb351d264054c67759")
+ (revision "0"))
+ (package
+ (name "pwsafe-cli")
+ (version (git-version "0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/nsd20463/pwsafe")
+ (commit commit)))
+ (sha256
+ (base32
+ "0ak09r1l7k57m6pdx468hhzvz0szmaq42vyr575fvsjc8rbrp8qq"))
+ (file-name (git-file-name name version))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ; skip failing test suite (requires write access to /tmp)
+ #:phases
+ (modify-phases %standard-phases
+ (replace 'bootstrap
+ (lambda _
+ (invoke "aclocal")
+ (invoke "autoheader")
+ (invoke "automake" "--add-missing")
+ (invoke "autoconf")
+ #t)))))
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)))
+ (inputs
+ `(("openssl" ,openssl)
+ ("libx11" ,libx11)
+ ("libxt" ,libxt)
+ ("libxmu" ,libxmu)))
+ (home-page "https://github.com/nsd20463/pwsafe")
+ (synopsis "CLI password manager")
+ (description "Command line tool compatible with Counterpane's
+Passwordsafe.")
+ (license license:gpl2))))
+
(define-public shroud
(package
(name "shroud")
--
2.25.1
L
L
Léo Le Bouter wrote on 23 Feb 2021 18:34
(address . 46646-done@debbugs.gnu.org)
f829d2a22a14604475b9df6abd044c1793ecf4bd.camel@zaclys.net
Pushed as 33a212bf88904295ddc20fcb05a4c237205812f8

I tried to enable the tests by substituting /tmp in all files in the
"test" directory but somehow the files created by the tests in a
writable directory are not writable themselves, still quite obscure to
me.

Please suggest another patch if you fix the tests one day.

Thank you!
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEFIvLi9gL+xax3g6RRaix6GvNEKYFAmA1PLUACgkQRaix6GvN
EKa2Cg//UvC2nA1QceLGjnk0ZF6x/xx5zwBTac7rScCZ1T5iMAVaXzJ/2z+Qy4LZ
K2ywUXeN39+NNB2iD2MeEBZxaUr9S7KB84weOxtGThMNGhXP2Pw8GIqYoqEEfHCl
MbRW9pEUPt38xCoPTjUNIOeadZuPRiYkAeON3zDlnh7TLUGpmlPe5slGwDesa/IB
IgVYaXBpNh3PCjM640ZdBImLmgVrpOmkrCaz3lbyfKmGlJ0HRHvSK8/ezNXu38KR
bNyGdAFmljas0JIarxmLCICXmoHaUXkIb6lvpOrrtMFG2vYRBHppsOnoZqPFYBvY
G5/W5qEYBWp/w5VeCVEMIyWh/Kcrp1yPDOObplG97oCluh7bk0KWPeNsqNLajzhD
5pe72z7OcnZ3SlkHum5mPzey7vCYhJfL7pi65cxhs92aQMvK4z5mveDIIGeHa32U
1RjAx/Jqpjv/ygro8su6zfi0MOAK7V+gW9abMnpfBKMcltI0X/UertD3wUJHf/Ad
frDp7fs5dNiXa6el6LeaNlhdBOE36tdWZnIF5jAy6b8TodECbKsWHKkmyM4Htq9a
Tjij9dppo8sfk/n7ByCqanUdI5XaqT4sM06W3Ad//ye4kWGRea6L6DSjkQaepum/
ztS6WEjBSvaU2F3dlWpPGnI54rL49WQfbQyoCaRT89AulRFetSk=
=ymN5
-----END PGP SIGNATURE-----


Closed
N
N
Nicolas Goaziou wrote on 23 Feb 2021 18:54
(name . Stefan Reichör)(address . stefan@xsteve.at)(address . 46646@debbugs.gnu.org)
87eeh6y8jf.fsf@nicolasgoaziou.fr
Hello,

Stefan Reichör <stefan@xsteve.at> writes:

Toggle quote (2 lines)
> * gnu/packages/password-utils.scm (pwsafe-cli): New variable.

Thanks!

The project seems to be named "pwsafe", and all other distributions use
"pwsafe" for it. I understand it is a CLI, but is there a particular
reason to name it "pwsafe-cli"?

Regards,
--
Nicolas Goaziou
S
S
Stefan Reichör wrote on 23 Feb 2021 19:04
(name . Nicolas Goaziou)(address . mail@nicolasgoaziou.fr)(address . 46646@debbugs.gnu.org)
87v9aivex2.fsf@xsteve.at
Hi Nicolas!

Toggle quote (14 lines)
> Hello,
>
> Stefan Reichör <stefan@xsteve.at> writes:
>
>> * gnu/packages/password-utils.scm (pwsafe-cli): New variable.
>
> Thanks!
>
> The project seems to be named "pwsafe", and all other distributions use
> "pwsafe" for it. I understand it is a CLI, but is there a particular
> reason to name it "pwsafe-cli"?
>
> Regards,

I would also prefer pwsafe as name, however guix already has a package named pwsafe.
This is why I picked a different name.

I would have no problem in renaming pwsafe to something else and name pwsafe-cli pwsafe... ;-)

Stefan.
N
N
Nicolas Goaziou wrote on 23 Feb 2021 19:20
(name . Stefan Reichör)(address . stefan@xsteve.at)(address . 46646@debbugs.gnu.org)
87a6ruy7bl.fsf@nicolasgoaziou.fr
Stefan Reichör <stefan@xsteve.at> writes:

Toggle quote (3 lines)
> I would also prefer pwsafe as name, however guix already has a package named pwsafe.
> This is why I picked a different name.

Ah true! I hadn't realized this.

Toggle quote (3 lines)
> I would have no problem in renaming pwsafe to something else and name
> pwsafe-cli pwsafe... ;-)

And we also have passwordsafe…

According to other distributions, we should do the following renaming

passwordsafe -> gnome-passwordsafe
pwsafe -> passwordsafe
pwsafe-cli -> pwsafe

I guess that ship has sailed…

Thank you for your answer!

Regards,
?