[PATCH 0/4] Update postgresql packages.

  • Done
  • quality assurance status badge
Details
2 participants
  • Leo Famulari
  • Léo Le Bouter
Owner
unassigned
Submitted by
Léo Le Bouter
Severity
normal
L
L
Léo Le Bouter wrote on 13 Feb 2021 08:53
(address . guix-patches@gnu.org)(name . Léo Le Bouter)(address . lle-bout@zaclys.net)
20210213075314.12511-1-lle-bout@zaclys.net

They all build successfully.

Léo Le Bouter (4):
gnu: postgresql-13: Update to 13.2.
gnu: postgresql-11: Update to 11.11.
gnu: postgresql-10: Update to 10.16.
gnu: postgresql-9.6: Update to 9.6.21.

gnu/packages/databases.scm | 16 ++++++++--------
1 file changed, 8 insertions(+), 8 deletions(-)

--
2.30.1
L
L
Léo Le Bouter wrote on 13 Feb 2021 08:56
[PATCH 3/4] gnu: postgresql-10: Update to 10.16.
(address . 46484@debbugs.gnu.org)(name . Léo Le Bouter)(address . lle-bout@zaclys.net)
20210213075607.12767-3-lle-bout@zaclys.net
* gnu/packages/databases.scm (postgresql-10): Update to 10.16.
---
gnu/packages/databases.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (23 lines)
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index 0234d9879c..d2ddf3dfea 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -1258,14 +1258,14 @@ pictures, sounds, or video.")
(define-public postgresql-10
(package
(inherit postgresql-11)
- (version "10.13")
+ (version "10.16")
(source (origin
(inherit (package-source postgresql-11))
(uri (string-append "https://ftp.postgresql.org/pub/source/v"
version "/postgresql-" version ".tar.bz2"))
(sha256
(base32
- "1qal0yp7a90yzya7hl56gsmw5fvacplrdhpn7h9gnbyr1i2iyw2d"))))))
+ "1cvv8qw0gkkczqhiwx6ns7w88dwkvdz4cvb2d4ff14363f5p2p53"))))))
(define-public postgresql-9.6
(package
--
2.30.1
L
L
Léo Le Bouter wrote on 13 Feb 2021 08:56
[PATCH 1/4] gnu: postgresql-13: Update to 13.2.
(address . 46484@debbugs.gnu.org)(name . Léo Le Bouter)(address . lle-bout@zaclys.net)
20210213075607.12767-1-lle-bout@zaclys.net
* gnu/packages/databases.scm (postgresql-13): Update to 13.2.
---
gnu/packages/databases.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (23 lines)
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index e0577f1567..2f4de2c902 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -1194,14 +1194,14 @@ developed in C/C++ to MariaDB and MySQL databases.")
(define-public postgresql-13
(package
(name "postgresql")
- (version "13.1")
+ (version "13.2")
(source (origin
(method url-fetch)
(uri (string-append "https://ftp.postgresql.org/pub/source/v"
version "/postgresql-" version ".tar.bz2"))
(sha256
(base32
- "07z6zwr58dckaa97yl9ml240z83d1lhgaxw9aq49i8lsp21mqd0j"))
+ "1z5d847jnajcfr3wa6jn52a8xjhamvwzmz18xlm5nvxqip8grmsz"))
(patches (search-patches "postgresql-disable-resolve_symlinks.patch"))))
(build-system gnu-build-system)
(arguments
--
2.30.1
L
L
Léo Le Bouter wrote on 13 Feb 2021 08:56
[PATCH 4/4] gnu: postgresql-9.6: Update to 9.6.21.
(address . 46484@debbugs.gnu.org)(name . Léo Le Bouter)(address . lle-bout@zaclys.net)
20210213075607.12767-4-lle-bout@zaclys.net
* gnu/packages/databases.scm (postgresql-9.6): Update to 9.6.21.
---
gnu/packages/databases.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (23 lines)
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index d2ddf3dfea..1b4d532ad1 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -1270,14 +1270,14 @@ pictures, sounds, or video.")
(define-public postgresql-9.6
(package
(inherit postgresql-10)
- (version "9.6.16")
+ (version "9.6.21")
(source (origin
(inherit (package-source postgresql-10))
(uri (string-append "https://ftp.postgresql.org/pub/source/v"
version "/postgresql-" version ".tar.bz2"))
(sha256
(base32
- "1rr2dgv4ams8r2lp13w85c77rkmzpb88fjlc28mvlw6zq2fblv2w"))))))
+ "0d0ngpadf1i7c0i2psaxcbmiwx8334ibcsn283n9fp4853pyl3wk"))))))
(define-public postgresql postgresql-13)
--
2.30.1
L
L
Léo Le Bouter wrote on 13 Feb 2021 08:56
[PATCH 2/4] gnu: postgresql-11: Update to 11.11.
(address . 46484@debbugs.gnu.org)(name . Léo Le Bouter)(address . lle-bout@zaclys.net)
20210213075607.12767-2-lle-bout@zaclys.net
* gnu/packages/databases.scm (postgresql-11): Update to 11.11.
---
gnu/packages/databases.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (23 lines)
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index 2f4de2c902..0234d9879c 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -1246,14 +1246,14 @@ pictures, sounds, or video.")
(package
(inherit postgresql-13)
(name "postgresql")
- (version "11.6")
+ (version "11.11")
(source (origin
(inherit (package-source postgresql-13))
(uri (string-append "https://ftp.postgresql.org/pub/source/v"
version "/postgresql-" version ".tar.bz2"))
(sha256
(base32
- "0w1iq488kpzfgfnlw4k32lz5by695mpnkq461jrgsr99z5zlz4j9"))))))
+ "0v0qk298nxmpzpgsxcsxma328hdkyzd7fwjs0zsn6zavl5zpnq20"))))))
(define-public postgresql-10
(package
--
2.30.1
L
L
Leo Famulari wrote on 13 Feb 2021 19:27
Re: [bug#46484] [PATCH 0/4] Update postgresql packages.
(name . Léo Le Bouter via Guix-patches via)(address . guix-patches@gnu.org)
YCgZ/oHHlwxSNit5@jasmine.lan
On Sat, Feb 13, 2021 at 08:53:10AM +0100, L�o Le Bouter via Guix-patches via wrote:
Toggle quote (4 lines)
>
> They all build successfully.

Thanks!

There are some system tests that exercise postgres, both postgresql-10
and postgresql. Can you make sure they (or some of them) still pass?

Maybe something like this:

`make check-system TESTS="postgresql zabbix guix-data-service cuirass"

If you aren't sure which tests to try, grep in 'gnu/tests' for
"postgres" and poke around.

And let us know if you don't have the computing resources to run them.
I can test the patches on the build farm in that case.
L
L
Léo Le Bouter wrote on 14 Feb 2021 15:10
(address . 46484@debbugs.gnu.org)
b785e784f0429f73d7d6413f972791f8cf57b502.camel@zaclys.net
Toggle quote (2 lines)
> Can you make sure they (or some of them) still pass?

I ran this:

$ TESTS="postgresql zabbix guix-data-service" ./pre-inst-env guix build
-m etc/system-tests.scm

And it did complete successfully!

/gnu/store/fz735r2c6rxdfjc214zvjayqin4i9aa4-postgresql-test
/gnu/store/h1pjyfp0bcfsswqcr4dvgsfzmj02p378-guix-data-service-test
/gnu/store/5xpdc8gmj5cbglm6dblasrl61m4w1xvz-zabbix-test

However, cuirass test did not work with an unrelated error:

$ TESTS="cuirass" ./pre-inst-env guix build -m etc/system-tests.scm
guix build: warning: failed to load '(gnu tests cuirass)':
In procedure abi-check: #<record-type <cuirass-remote-worker-
configuration>>: record ABI mismatch; recompilation needed
Selected 0 system tests...

Does that sound good to you for the package upgrades?
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEFIvLi9gL+xax3g6RRaix6GvNEKYFAmApL0MACgkQRaix6GvN
EKalgw/7BN7uqe/R9HV4PYvRlxQ86G0xfAsuZXnVm2YnV5GsdQCGi5zmSBDw7vCb
NNuipADzH0TJOfED+o47b+YX+I174qDkf1AB2eNvvlFQpoP9q+Li/4c4vd7vAaVW
wP9Hdj/pE2sw4gBadCM0yvWjH3ZjY1Nz96mlRZx5njpktuADDvsb7hTY9ujqNh7R
Z8LZsXUE7t1nf+tfKx4YEOf+Xb5TVZ0tK6hBcot18kIwv6Y6A5LLOODr5NdzbxCR
LCNpoiZCdTLL/y7XRTe9Bi/BXfZuhcuktM0JUqte5Zy73faMvtiyuiW3Ke7Zer2L
AD/FbpkiyKo7qL+OFhZcOnyFLx0Tqn6iJVvJklYHiXVccJs1z99Z9bur3pAf6lO8
YMwEx9SeTmO99wBnw3FU24q6M5kApdY8HKJl+r0+U9Eoux1Ap3QuoqQGrnK7HH7e
9ONJLqBVydykkS6wGxijoTbeWCOCT0yBrwTokOAIEP54Wy7XbsTEIkXWSmHJyZhU
R/uNvqpvf0/1OwZM0gnqn7gcHmEfqDO3C6UC/X2+alortgjOj2Pm3M6DVCqfcSfh
/aZaymCfh27sWJUP93tmwsjTDbjljMEy1rEgdfs8zU5sUeUgSMbeBo6rVy2bBU30
a7i3m6YmTEhDMj2Uft6CnkjfFCQOW/h0SqIbQfNBut+TX86ejFc=
=+o0B
-----END PGP SIGNATURE-----


L
L
Leo Famulari wrote on 14 Feb 2021 19:59
(name . Léo Le Bouter)(address . lle-bout@zaclys.net)
YCly92H8WwxHWpKm@jasmine.lan
On Sun, Feb 14, 2021 at 03:10:11PM +0100, Léo Le Bouter wrote:
Toggle quote (21 lines)
> > Can you make sure they (or some of them) still pass?
>
> I ran this:
>
> $ TESTS="postgresql zabbix guix-data-service" ./pre-inst-env guix build
> -m etc/system-tests.scm
>
> And it did complete successfully!
>
> /gnu/store/fz735r2c6rxdfjc214zvjayqin4i9aa4-postgresql-test
> /gnu/store/h1pjyfp0bcfsswqcr4dvgsfzmj02p378-guix-data-service-test
> /gnu/store/5xpdc8gmj5cbglm6dblasrl61m4w1xvz-zabbix-test
>
> However, cuirass test did not work with an unrelated error:
>
> $ TESTS="cuirass" ./pre-inst-env guix build -m etc/system-tests.scm
> guix build: warning: failed to load '(gnu tests cuirass)':
> In procedure abi-check: #<record-type <cuirass-remote-worker-
> configuration>>: record ABI mismatch; recompilation needed
> Selected 0 system tests...

Usually this means you should do `make clean-go && make`, to delete the
compiled Guile objects and rebuild everything with the new ABI.

I'll try it on a powerful server and report back shortly.
L
L
Leo Famulari wrote on 14 Feb 2021 21:00
(name . Léo Le Bouter)(address . lle-bout@zaclys.net)
YCmBWgeZntKIpxEm@jasmine.lan
On Sun, Feb 14, 2021 at 01:59:03PM -0500, Leo Famulari wrote:
Toggle quote (2 lines)
> I'll try it on a powerful server and report back shortly.

Success!

I pushed the update of postgresql-13 to staging and the rest to the
master branch as 6941dbf958a2294e0a058af3498df9c46a6a1e50

The guidelines about which branch to push changes to are in the
Submitting Patches section of the manual:


Postgresql 13 qualifies for the staging branch:

$ guix refresh -l postgresql@13
Building the following 625 packages would ensure 1160 dependent packages are rebuilt: [...]
L
L
Léo Le Bouter wrote on 14 Feb 2021 22:09
[PATCH] gnu: postgresql-13: Update to 13.2 [security fixes].
(address . 46484@debbugs.gnu.org)
20210214210913.18688-1-lle-bout@zaclys.net
Fixes CVE-2021-3393 and CVE-2021-20229.

* gnu/packages/databases.scm (postgresql-13.2): New variable.
(postgresql-13)[replacement]: New field.

Signed-off-by: Leo Famulari <leo@famulari.name>
---
gnu/packages/databases.scm | 15 +++++++++++++++
1 file changed, 15 insertions(+)

Toggle diff (35 lines)
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index 9e7e11b380..604b6ad7d6 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -1203,6 +1203,7 @@ developed in C/C++ to MariaDB and MySQL databases.")
(base32
"07z6zwr58dckaa97yl9ml240z83d1lhgaxw9aq49i8lsp21mqd0j"))
(patches (search-patches "postgresql-disable-resolve_symlinks.patch"))))
+ (replacement postgresql-13.2)
(build-system gnu-build-system)
(arguments
`(#:configure-flags '("--with-uuid=e2fs" "--with-openssl"
@@ -1242,6 +1243,20 @@ TIMESTAMP. It also supports storage of binary large objects, including
pictures, sounds, or video.")
(license (license:x11-style "file://COPYRIGHT"))))
+(define-public postgresql-13.2
+ (package
+ (inherit postgresql-13)
+ (name "postgresql")
+ (version "13.2")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://ftp.postgresql.org/pub/source/v"
+ version "/postgresql-" version ".tar.bz2"))
+ (sha256
+ (base32
+ "1z5d847jnajcfr3wa6jn52a8xjhamvwzmz18xlm5nvxqip8grmsz"))
+ (patches (search-patches "postgresql-disable-resolve_symlinks.patch"))))))
+
(define-public postgresql-11
(package
(inherit postgresql-13)
--
2.30.1
L
L
Leo Famulari wrote on 14 Feb 2021 22:16
(name . Léo Le Bouter)(address . lle-bout@zaclys.net)(address . 46484-done@debbugs.gnu.org)
YCmTH5MurWoCTv9f@jasmine.lan
On Sun, Feb 14, 2021 at 10:09:13PM +0100, L�o Le Bouter wrote:
Toggle quote (7 lines)
> Fixes CVE-2021-3393 and CVE-2021-20229.
>
> * gnu/packages/databases.scm (postgresql-13.2): New variable.
> (postgresql-13)[replacement]: New field.
>
> Signed-off-by: Leo Famulari <leo@famulari.name>

Thanks! Pushed as 392e230d5e63fe0f5d7aa9b5085516250630d879
Closed
?