[PATCH] gnu: Add python-mistletoe.

  • Done
  • quality assurance status badge
Details
2 participants
  • Tobias Geerinckx-Rice
  • Ron Nazarov
Owner
unassigned
Submitted by
Ron Nazarov
Severity
normal
R
R
Ron Nazarov wrote on 11 Feb 2021 22:36
(address . guix-patches@gnu.org)(name . Ron Nazarov)(address . noisytoot@disroot.org)
20210211213654.117065-1-noisytoot@disroot.org
* gnu/packages/python-xyz.scm (python-mistletoe): New variable.
---
gnu/packages/python-xyz.scm | 39 ++++++++++++++++++++++++++++++-------
1 file changed, 32 insertions(+), 7 deletions(-)

Toggle diff (64 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 783812eb03..69a2f29fcb 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -96,6 +96,7 @@
;;; Copyright © 2020, 2021 Zheng Junjie <873216071@qq.com>
;;; Copyright © 2021 Morgan Smith <Morgan.J.Smith@outlook.com>
;;; Copyright © 2020 EuAndreh <eu@euandre.org>
+;;; Copyright © 2021 Noisytoot <noisytoot@disroot.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -23745,18 +23746,42 @@ Application Programming Interface based on the Open Inventor 2.1 API.")
(name "python-crayons")
(version "0.4.0")
(source
- (origin
- (method url-fetch)
- (uri (pypi-uri "crayons" version))
- (sha256
- (base32
- "0gw106k4b6y8mw7pp52awxyplj2bwvwk315k4sywzwh0g1abfcxx"))))
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "crayons" version))
+ (sha256
+ (base32
+ "0gw106k4b6y8mw7pp52awxyplj2bwvwk315k4sywzwh0g1abfcxx"))))
(build-system python-build-system)
(propagated-inputs
- `(("python-colorama" ,python-colorama)))
+ `(("python-colorama" ,python-colorama)))
(home-page "https://github.com/MasterOdin/crayons")
(synopsis "TextUI colors for Python")
(description "This package gives you colored strings for the terminal.
Crayons automatically wraps a given string in the foreground color and
restores the original state after the string is printed.")
(license license:expat)))
+
+(define-public python-mistletoe
+ (package
+ (name "python-mistletoe")
+ (version "0.7.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "mistletoe" version))
+ (sha256
+ (base32
+ "18z6hqfnfjqnrcgfgl5pkj9ggf9yx0yyy94azcn1qf7hqn6g3l14"))))
+ (build-system python-build-system)
+ (home-page
+ "https://github.com/miyuchina/mistletoe")
+ (synopsis
+ "Fast, extensible Markdown parser in pure Python")
+ (description
+ "A CommonMark-compliant Markdown parser
+that supports easy definitions of custom tokens.
+Parsing Markdown into an abstract syntax tree also allows mistletoe
+to swap out renderers for different output formats,
+without touching any of the core components.")
+ (license license:expat)))
--
2.30.0
R
R
Ron Nazarov wrote on 5 Mar 2021 20:00
(address . 46449@debbugs.gnu.org)(name . Ron Nazarov)(address . noisytoot@disroot.org)
20210305190012.139489-1-noisytoot@disroot.org
* gnu/packages/python-xyz.scm (python-mistletoe): New variable.
---
gnu/packages/python-xyz.scm | 22 ++++++++++++++++++++++
1 file changed, 22 insertions(+)

Toggle diff (39 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 783812eb03..91d4e343f7 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -96,6 +96,7 @@
;;; Copyright © 2020, 2021 Zheng Junjie <873216071@qq.com>
;;; Copyright © 2021 Morgan Smith <Morgan.J.Smith@outlook.com>
;;; Copyright © 2020 EuAndreh <eu@euandre.org>
+;;; Copyright © 2021 Noisytoot <noisytoot@disroot.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -23760,3 +23761,24 @@ Application Programming Interface based on the Open Inventor 2.1 API.")
Crayons automatically wraps a given string in the foreground color and
restores the original state after the string is printed.")
(license license:expat)))
+
+(define-public python-mistletoe
+ (package
+ (name "python-mistletoe")
+ (version "0.7.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "mistletoe" version))
+ (sha256
+ (base32 "18z6hqfnfjqnrcgfgl5pkj9ggf9yx0yyy94azcn1qf7hqn6g3l14"))))
+ (build-system python-build-system)
+ (home-page "https://github.com/miyuchina/mistletoe")
+ (synopsis "Fast, extensible Markdown parser in pure Python")
+ (description
+ "The @code{mistletoe} Markdown parser is a CommonMark-compliant Markdown parser
+that supports definitions of custom tokens.
+Parsing Markdown into an abstract syntax tree also allows @code{mistletoe}
+to swap out renderers for different output formats,
+without touching any of the core components.")
+ (license license:expat)))
--
2.30.1
R
R
Ron Nazarov wrote on 7 Mar 2021 22:21
(address . 46449@debbugs.gnu.org)(name . Ron Nazarov)(address . noisytoot@disroot.org)
20210307212125.241574-1-noisytoot@disroot.org
* gnu/packages/markup.scm (python-mistletoe): New variable.
---
gnu/packages/markup.scm | 23 +++++++++++++++++++++++
1 file changed, 23 insertions(+)

Toggle diff (47 lines)
diff --git a/gnu/packages/markup.scm b/gnu/packages/markup.scm
index 95a3eb269e..4e0fcdce1c 100644
--- a/gnu/packages/markup.scm
+++ b/gnu/packages/markup.scm
@@ -6,6 +6,7 @@
;;; Copyright © 2017, 2018, 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2020 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2020 EuAndreh <eu@euandre.org>
+;;; Copyright © 2021 Noisytoot <noisytoot@disroot.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -31,6 +32,7 @@
#:use-module (guix build-system trivial)
#:use-module (guix build-system cmake)
#:use-module (guix build-system perl)
+ #:use-module (guix build-system python)
#:use-module (guix utils)
#:use-module (gnu packages compression)
#:use-module (gnu packages)
@@ -300,3 +302,24 @@ and smu is that smu doesn't support reference style links.")
SAX-like interface. It is compliant to the CommonMark specification,
with a few extensions.")
(license expat)))
+
+(define-public python-mistletoe
+ (package
+ (name "python-mistletoe")
+ (version "0.7.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "mistletoe" version))
+ (sha256
+ (base32 "18z6hqfnfjqnrcgfgl5pkj9ggf9yx0yyy94azcn1qf7hqn6g3l14"))))
+ (build-system python-build-system)
+ (home-page "https://github.com/miyuchina/mistletoe")
+ (synopsis "Fast, extensible Markdown parser in pure Python")
+ (description
+ "The @code{mistletoe} Markdown parser is a CommonMark-compliant Markdown parser
+that supports definitions of custom tokens.
+Parsing Markdown into an abstract syntax tree also allows @code{mistletoe}
+to swap out renderers for different output formats,
+without touching any of the core components.")
+ (license expat)))
--
2.30.1
T
T
Tobias Geerinckx-Rice wrote on 8 Mar 2021 20:01
(name . Ron Nazarov)(address . noisytoot@disroot.org)
87blbto4f2.fsf@nckx
Toot,

Ron Nazarov via Guix-patches via ???
Toggle quote (2 lines)
> * gnu/packages/markup.scm (python-mistletoe): New variable.

Thanks! Pushed as 80599a739d04fb1830ee0169256021764784e850, with
minor changes:

Toggle quote (2 lines)
> + (synopsis "Fast, extensible Markdown parser in pure
> Python")
^^^^
I removed this, since all software is now fast, light-weight, and
well-written. It's the law or something.

Toggle quote (2 lines)
> + (description

I wrapped this to 80 characters.

Kind regards,

T G-R
-----BEGIN PGP SIGNATURE-----

iIMEARYKACsWIQT12iAyS4c9C3o4dnINsP+IT1VteQUCYEZ0og0cbWVAdG9iaWFz
LmdyAAoJEA2w/4hPVW1545MBAJMl9kXrJyxDVkHWS1Kh4Dq6m8LOysgs2xpilODL
a2bHAQDNQh38ZsTVSUMzl1iO4AeM4Bj8Gda0YY9q0GjuEPaGCA==
=TKOR
-----END PGP SIGNATURE-----

Closed
?