[PATCH] gnu: miredo: Fix creation of .pid file.

  • Done
  • quality assurance status badge
Details
2 participants
  • ???
  • Léo Le Bouter
Owner
unassigned
Submitted by
Léo Le Bouter
Severity
normal
L
L
Léo Le Bouter wrote on 4 Feb 2021 23:33
(address . guix-patches@gnu.org)(name . Léo Le Bouter)(address . lle-bout@zaclys.net)
20210204223353.2730-1-lle-bout@zaclys.net
* gnu/packages/networking.scm (miredo)[arguments]: Add "--localstatedir=/var"
to #:configure-flags and add 'do-not-create-/run phase to #:phases to remove
code that tries to create a directory inside "@localstatedir@" during install.
---
gnu/packages/networking.scm | 10 +++++++++-
1 file changed, 9 insertions(+), 1 deletion(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index abaab60f31..5e0022ac76 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -700,8 +700,16 @@ or, more generally, MAC addresses of the same category of hardware.")
"0j9ilig570snbmj48230hf7ms8kvcwi2wblycqrmhh85lksd49ps"))))
(build-system gnu-build-system)
(arguments
- '(#:phases
+ '(#:configure-flags
+ (list "--localstatedir=/var")
+ #:phases
(modify-phases %standard-phases
+ (add-after 'unpack 'do-not-create-/run
+ (lambda _
+ (substitute* (find-files "src" "Makefile.*")
+ (("^.+install_sh.+/run.+$")
+ "\ttrue"))
+ #t))
(add-after 'unpack 'patch-iproute2
(lambda* (#:key inputs #:allow-other-keys)
(let* ((iproute (assoc-ref inputs "iproute"))
--
2.30.0
?
(name . Léo Le Bouter)(address . lle-bout@zaclys.net)(address . 46305-done@debbugs.gnu.org)
OSZP286MB0664D4510E68C7C091F80A67A38C9@OSZP286MB0664.JPNP286.PROD.OUTLOOK.COM
Léo Le Bouter <lle-bout@zaclys.net> writes:

Toggle quote (4 lines)
> * gnu/packages/networking.scm (miredo)[arguments]: Add "--localstatedir=/var"
> to #:configure-flags and add 'do-not-create-/run phase to #:phases to remove
> code that tries to create a directory inside "@localstatedir@" during install.

Pushed, thank you!
Closed
?