[PATCH] gnu: Add libsmbios.

  • Done
  • quality assurance status badge
Details
2 participants
  • Léo Le Bouter
  • Nicolas Goaziou
Owner
unassigned
Submitted by
Léo Le Bouter
Severity
normal
L
L
Léo Le Bouter wrote on 27 Jan 2021 19:52
(address . guix-patches@gnu.org)(name . Léo Le Bouter)(address . lle-bout@zaclys.net)
20210127185214.31034-1-lle-bout@zaclys.net
* gnu/packages/hardware.scm (libsmbios): New variable.
---
gnu/packages/hardware.scm | 43 +++++++++++++++++++++++++++++++++++++++
1 file changed, 43 insertions(+)

Toggle diff (72 lines)
diff --git a/gnu/packages/hardware.scm b/gnu/packages/hardware.scm
index 3da6759472..6a704f432d 100644
--- a/gnu/packages/hardware.scm
+++ b/gnu/packages/hardware.scm
@@ -29,15 +29,18 @@
#:use-module (gnu packages crypto)
#:use-module (gnu packages documentation)
#:use-module (gnu packages gcc)
+ #:use-module (gnu packages gettext)
#:use-module (gnu packages glib)
#:use-module (gnu packages gtk)
#:use-module (gnu packages libusb)
#:use-module (gnu packages linux)
#:use-module (gnu packages ncurses)
#:use-module (gnu packages openldap)
+ #:use-module (gnu packages perl)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages polkit)
#:use-module (gnu packages protobuf)
+ #:use-module (gnu packages python)
#:use-module (gnu packages xdisorg)
#:use-module (gnu packages xml)
#:use-module (gnu packages xorg)
@@ -130,6 +133,46 @@ calibrated, and restored when the calibration is applied.")
human-readable format and checks if it conforms to the standards.")
(license license:expat))))
+(define-public libsmbios
+ (package
+ (name "libsmbios")
+ (version "2.4.3")
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url (string-append "https://github.com/dell/" name))
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0krwwydyvb9224r884y1mlmzyxhlfrcqw73vi1j8787rl0gl5a2i"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("gettext" ,gettext-minimal)
+ ("libtool" ,libtool)
+ ("pkg-config" ,pkg-config)
+ ("perl" ,perl)
+ ("python" ,python)))
+ (inputs
+ `(("libxml2" ,libxml2)))
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'bootstrap
+ (lambda _ (invoke "autoreconf" "-vfi"))))))
+ (synopsis "Library for interacting with Dell SMBIOS tables")
+ (description "libsmbios provides a library to interface with the SMBIOS
+tables. It also provides extensions for proprietary methods of interfacing
+with Dell specific SMBIOS tables.")
+ (home-page "https://github.com/dell/libsmbios")
+ (license (list
+ (license:non-copyleft "file://COPYING-OSL"
+ "Open Software License version 2.1")
+ license:gpl2+ license:bsd-3 license:boost1.0))))
+
;; Distinct from memtest86, which is obsolete.
(define-public memtest86+
(package
--
2.30.0
N
N
Nicolas Goaziou wrote on 27 Jan 2021 21:28
(name . guix-patches--- via)(address . guix-patches@gnu.org)
877dnyrup0.fsf@nicolasgoaziou.fr
Hello,

guix-patches--- via <guix-patches@gnu.org> writes:

Toggle quote (2 lines)
> * gnu/packages/hardware.scm (libsmbios): New variable.

I added a copyright line for you, fixed indentation in license field,
and forgot to move home-page above synopsis. Bah.

Patch applied! Thank you.

Regards,
--
Nicolas Goaziou
?