[PATCH] gnu: make-mingw-w64: Use mirror:// link and fix lint errors.

  • Done
  • quality assurance status badge
Details
2 participants
  • Léo Le Bouter
  • Maxim Cournoyer
Owner
unassigned
Submitted by
Léo Le Bouter
Severity
normal
L
L
Léo Le Bouter wrote on 25 Jan 2021 11:51
(address . guix-patches@gnu.org)(name . Léo Le Bouter)(address . lle-bout@zaclys.net)
20210125105121.15605-1-lle-bout@zaclys.net
* gnu/package/mingw.scm (make-mingw-w64): Use mirror:// link instead of
hardcoded sourceforge.net. Wrap lines 80 columns to fix lint warning.
---
gnu/packages/mingw.scm | 49 +++++++++++++++++++++++-------------------
1 file changed, 27 insertions(+), 22 deletions(-)

Toggle diff (79 lines)
diff --git a/gnu/packages/mingw.scm b/gnu/packages/mingw.scm
index b37f6c69bd..58f01ddc9f 100644
--- a/gnu/packages/mingw.scm
+++ b/gnu/packages/mingw.scm
@@ -46,23 +46,26 @@ specified, recurse and return a mingw-w64 with support for winpthreads."
(name (string-append "mingw-w64" "-" machine
(if with-winpthreads? "-winpthreads" "")))
(version "7.0.0")
- (source (origin
- (method url-fetch)
- (uri (string-append
- "https://sourceforge.net/projects/mingw-w64/files/mingw-w64/"
- "mingw-w64-release/mingw-w64-v" version ".tar.bz2"))
- (sha256
- (base32 "0a5njsa2zw2ssdz10jkb10mhrf3cb8qp9avs89zqmw4n6pzxy85a"))
- (patches
- (search-patches "mingw-w64-6.0.0-gcc.patch"
- "mingw-w64-dlltool-temp-prefix.patch"
- "mingw-w64-reproducible-gendef.patch"))))
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://sourceforge/mingw-w64/mingw-w64/"
+ "mingw-w64-release/mingw-w64-v" version ".tar.bz2"))
+ (sha256
+ (base32 "0a5njsa2zw2ssdz10jkb10mhrf3cb8qp9avs89zqmw4n6pzxy85a"))
+ (patches
+ (search-patches "mingw-w64-6.0.0-gcc.patch"
+ "mingw-w64-dlltool-temp-prefix.patch"
+ "mingw-w64-reproducible-gendef.patch"))))
(native-inputs `(("xgcc-core" ,(if xgcc xgcc (cross-gcc triplet)))
- ("xbinutils" ,(if xbinutils xbinutils (cross-binutils triplet)))
+ ("xbinutils" ,(if xbinutils xbinutils
+ (cross-binutils triplet)))
,@(if with-winpthreads?
- `(("xlibc" ,(make-mingw-w64 machine
- #:xgcc xgcc
- #:xbinutils xbinutils)))
+ `(("xlibc" ,(make-mingw-w64
+ machine
+ #:xgcc xgcc
+ #:xbinutils xbinutils)))
'())))
(build-system gnu-build-system)
(search-paths
@@ -85,9 +88,11 @@ specified, recurse and return a mingw-w64 with support for winpthreads."
(add-before 'configure 'setenv
(lambda* (#:key inputs #:allow-other-keys)
(let ((xgcc-core (assoc-ref inputs "xgcc-core"))
- (mingw-headers (string-append (getcwd) "/mingw-w64-headers")))
+ (mingw-headers (string-append
+ (getcwd) "/mingw-w64-headers")))
(setenv "CPP"
- (string-append xgcc-core ,(string-append "/bin/" triplet "-cpp")))
+ (string-append
+ xgcc-core ,(string-append "/bin/" triplet "-cpp")))
(setenv "CROSS_C_INCLUDE_PATH"
(string-append
mingw-headers
@@ -96,11 +101,11 @@ specified, recurse and return a mingw-w64 with support for winpthreads."
":" mingw-headers "/defaults/include"
":" mingw-headers "/direct-x/include"))
(when ,with-winpthreads?
- (let ((xlibc (assoc-ref inputs "xlibc")))
- (setenv "CROSS_LIBRARY_PATH"
- (string-append
- xlibc "/lib" ":"
- xlibc "/" ,triplet "/lib"))))))))
+ (let ((xlibc (assoc-ref inputs "xlibc")))
+ (setenv "CROSS_LIBRARY_PATH"
+ (string-append
+ xlibc "/lib" ":"
+ xlibc "/" ,triplet "/lib"))))))))
#:make-flags (list "DEFS=-DHAVE_CONFIG_H -D__MINGW_HAS_DXSDK=1")
#:tests? #f ; compiles and includes glibc headers
#:strip-binaries? #f))
--
2.30.0
M
M
Maxim Cournoyer wrote on 3 Feb 2021 16:27
(name . Léo Le Bouter)(address . lle-bout@zaclys.net)(address . 46096-done@debbugs.gnu.org)
874kitp3x4.fsf@gmail.com
Hello,

Léo Le Bouter <lle-bout@zaclys.net> writes:

Toggle quote (84 lines)
> * gnu/package/mingw.scm (make-mingw-w64): Use mirror:// link instead of
> hardcoded sourceforge.net. Wrap lines 80 columns to fix lint warning.
> ---
> gnu/packages/mingw.scm | 49 +++++++++++++++++++++++-------------------
> 1 file changed, 27 insertions(+), 22 deletions(-)
>
> diff --git a/gnu/packages/mingw.scm b/gnu/packages/mingw.scm
> index b37f6c69bd..58f01ddc9f 100644
> --- a/gnu/packages/mingw.scm
> +++ b/gnu/packages/mingw.scm
> @@ -46,23 +46,26 @@ specified, recurse and return a mingw-w64 with support for winpthreads."
> (name (string-append "mingw-w64" "-" machine
> (if with-winpthreads? "-winpthreads" "")))
> (version "7.0.0")
> - (source (origin
> - (method url-fetch)
> - (uri (string-append
> - "https://sourceforge.net/projects/mingw-w64/files/mingw-w64/"
> - "mingw-w64-release/mingw-w64-v" version ".tar.bz2"))
> - (sha256
> - (base32 "0a5njsa2zw2ssdz10jkb10mhrf3cb8qp9avs89zqmw4n6pzxy85a"))
> - (patches
> - (search-patches "mingw-w64-6.0.0-gcc.patch"
> - "mingw-w64-dlltool-temp-prefix.patch"
> - "mingw-w64-reproducible-gendef.patch"))))
> + (source
> + (origin
> + (method url-fetch)
> + (uri (string-append
> + "mirror://sourceforge/mingw-w64/mingw-w64/"
> + "mingw-w64-release/mingw-w64-v" version ".tar.bz2"))
> + (sha256
> + (base32 "0a5njsa2zw2ssdz10jkb10mhrf3cb8qp9avs89zqmw4n6pzxy85a"))
> + (patches
> + (search-patches "mingw-w64-6.0.0-gcc.patch"
> + "mingw-w64-dlltool-temp-prefix.patch"
> + "mingw-w64-reproducible-gendef.patch"))))
> (native-inputs `(("xgcc-core" ,(if xgcc xgcc (cross-gcc triplet)))
> - ("xbinutils" ,(if xbinutils xbinutils (cross-binutils triplet)))
> + ("xbinutils" ,(if xbinutils xbinutils
> + (cross-binutils triplet)))
> ,@(if with-winpthreads?
> - `(("xlibc" ,(make-mingw-w64 machine
> - #:xgcc xgcc
> - #:xbinutils xbinutils)))
> + `(("xlibc" ,(make-mingw-w64
> + machine
> + #:xgcc xgcc
> + #:xbinutils xbinutils)))
> '())))
> (build-system gnu-build-system)
> (search-paths
> @@ -85,9 +88,11 @@ specified, recurse and return a mingw-w64 with support for winpthreads."
> (add-before 'configure 'setenv
> (lambda* (#:key inputs #:allow-other-keys)
> (let ((xgcc-core (assoc-ref inputs "xgcc-core"))
> - (mingw-headers (string-append (getcwd) "/mingw-w64-headers")))
> + (mingw-headers (string-append
> + (getcwd) "/mingw-w64-headers")))
> (setenv "CPP"
> - (string-append xgcc-core ,(string-append "/bin/" triplet "-cpp")))
> + (string-append
> + xgcc-core ,(string-append "/bin/" triplet "-cpp")))
> (setenv "CROSS_C_INCLUDE_PATH"
> (string-append
> mingw-headers
> @@ -96,11 +101,11 @@ specified, recurse and return a mingw-w64 with support for winpthreads."
> ":" mingw-headers "/defaults/include"
> ":" mingw-headers "/direct-x/include"))
> (when ,with-winpthreads?
> - (let ((xlibc (assoc-ref inputs "xlibc")))
> - (setenv "CROSS_LIBRARY_PATH"
> - (string-append
> - xlibc "/lib" ":"
> - xlibc "/" ,triplet "/lib"))))))))
> + (let ((xlibc (assoc-ref inputs "xlibc")))
> + (setenv "CROSS_LIBRARY_PATH"
> + (string-append
> + xlibc "/lib" ":"
> + xlibc "/" ,triplet "/lib"))))))))
> #:make-flags (list "DEFS=-DHAVE_CONFIG_H -D__MINGW_HAS_DXSDK=1")
> #:tests? #f ; compiles and includes glibc headers
> #:strip-binaries? #f))

Pushed as commit 88c635d96a1dfba90278dd9a3c2fcf523c74b55c, thank you.

Maxim
Closed
?