Channel authentication should start at the current commit(s)

  • Done
  • quality assurance status badge
Details
One participant
  • Ludovic Courtès
Owner
unassigned
Submitted by
Ludovic Courtès
Severity
important
Blocked by
L
L
Ludovic Courtès wrote on 15 Jan 2021 18:44
(address . bug-guix@gnu.org)
87czy6xffy.fsf@inria.fr
Hi!

Currently, the first ‘guix pull’ (when ~/.cache/guix is empty)
authenticates starting from the introductory commit. For the ‘guix’
channel, that’s 11K commits today, which takes about a minute to process
on modern hardware.

Authentication should instead consider the current commits, as returned
by ‘guix describe’, authenticated, and start from there.

For example, if you install Guix 1.3, authentication should start at the
‘v1.3’ commit.

Ludo’.
L
L
Ludovic Courtès wrote on 15 Jan 2021 18:50
control message for bug #45895
(address . control@debbugs.gnu.org)
877doexf6q.fsf@gnu.org
severity 45895 important
quit
L
L
Ludovic Courtès wrote on 16 Jan 2021 12:12
(address . control@debbugs.gnu.org)
87h7nhyw3b.fsf@gnu.org
block 45895 by 45896
quit
L
L
Ludovic Courtès wrote on 2 Feb 2021 09:46
Re: bug#45895: Channel authentication should start at the current commit(s)
(address . 45895@debbugs.gnu.org)
87wnvqg8ls.fsf@gnu.org
Hi,

Ludovic Courtès <ludo@gnu.org> skribis:

Toggle quote (8 lines)
> Currently, the first ‘guix pull’ (when ~/.cache/guix is empty)
> authenticates starting from the introductory commit. For the ‘guix’
> channel, that’s 11K commits today, which takes about a minute to process
> on modern hardware.
>
> Authentication should instead consider the current commits, as returned
> by ‘guix describe’, authenticated, and start from there.

The attached patch does that.

Ludo’.
From 9bbce577036f2018d605d111042b0a7fc1be266b Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Ludovic=20Court=C3=A8s?= <ludo@gnu.org>
Date: Tue, 2 Feb 2021 09:37:33 +0100
Subject: [PATCH] channels: Consider the current channel commit as authentic.


When the ~/.cache/guix/authentication is empty, this change allows
authentication to start at the current commit, as shown by 'guix
describe', instead of starting from the introductory commit, which would
take more and more time (there's currently 18K commits per year).

* guix/git-authenticate.scm (authenticate-repository): Add #:authentic-commits.
[authenticated-commits]: Append it.
* guix/channels.scm (authenticate-channel)[authentic-commits]: New
variable. Pass it to 'authenticate-repository'.
---
guix/channels.scm | 14 ++++++++++++++
guix/git-authenticate.scm | 9 ++++++---
2 files changed, 20 insertions(+), 3 deletions(-)

Toggle diff (78 lines)
diff --git a/guix/channels.scm b/guix/channels.scm
index 3cc3b4c438..05226e766b 100644
--- a/guix/channels.scm
+++ b/guix/channels.scm
@@ -47,6 +47,7 @@
#:use-module (srfi srfi-26)
#:use-module (srfi srfi-34)
#:use-module (srfi srfi-35)
+ #:autoload (guix describe) (current-channels) ;XXX: circular dep
#:autoload (guix self) (whole-package make-config.scm)
#:autoload (guix inferior) (gexp->derivation-in-inferior) ;FIXME: circular dep
#:autoload (guix quirks) (%quirks %patches applicable-patch? apply-patch)
@@ -344,6 +345,18 @@ commits)...~%")
(progress-reporter/bar (length commits)))
+ (define authentic-commits
+ ;; Consider the currently-used commit of CHANNEL as authentic so
+ ;; authentication can skip it and all its closure.
+ (match (find (lambda (candidate)
+ (eq? (channel-name candidate) (channel-name channel)))
+ (current-channels))
+ (#f '())
+ (channel
+ (if (channel-commit channel)
+ (list (channel-commit channel))
+ '()))))
+
;; XXX: Too bad we need to re-open CHECKOUT.
(with-repository checkout repository
(authenticate-repository repository
@@ -354,6 +367,7 @@ commits)...~%")
#:keyring-reference
(string-append keyring-reference-prefix
keyring-reference)
+ #:authentic-commits authentic-commits
#:make-reporter make-reporter
#:cache-key cache-key)))
diff --git a/guix/git-authenticate.scm b/guix/git-authenticate.scm
index 4ab5419bd6..ab3fcd8b2f 100644
--- a/guix/git-authenticate.scm
+++ b/guix/git-authenticate.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2019, 2020 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2019, 2020, 2021 Ludovic Courtès <ludo@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -376,12 +376,14 @@ instead of '~a'")
(cache-key (repository-cache-key repository))
(end (reference-target
(repository-head repository)))
+ (authentic-commits '())
(historical-authorizations '())
(make-reporter
(const progress-reporter/silent)))
"Authenticate REPOSITORY up to commit END, an OID. Authentication starts
with commit START, an OID, which must be signed by SIGNER; an exception is
-raised if that is not the case. Return an alist mapping OpenPGP public keys
+raised if that is not the case. Commits listed in AUTHENTIC-COMMITS and their
+closure are considered authentic. Return an alist mapping OpenPGP public keys
to the number of commits signed by that key that have been traversed.
The OpenPGP keyring is loaded from KEYRING-REFERENCE in REPOSITORY, where
@@ -404,7 +406,8 @@ denoting the authorized keys for commits whose parent lack the
(filter-map (lambda (id)
(false-if-git-not-found
(commit-lookup repository (string->oid id))))
- (previously-authenticated-commits cache-key)))
+ (append (previously-authenticated-commits cache-key)
+ authentic-commits)))
(define commits
;; Commits to authenticate, excluding the closure of
--
2.30.0
L
L
Ludovic Courtès wrote on 4 Feb 2021 13:47
(address . 45895-done@debbugs.gnu.org)
87zh0k6lvb.fsf@gnu.org
Ludovic Courtès <ludo@gnu.org> skribis:

Toggle quote (17 lines)
>>From 9bbce577036f2018d605d111042b0a7fc1be266b Mon Sep 17 00:00:00 2001
> From: =?UTF-8?q?Ludovic=20Court=C3=A8s?= <ludo@gnu.org>
> Date: Tue, 2 Feb 2021 09:37:33 +0100
> Subject: [PATCH] channels: Consider the current channel commit as authentic.
>
> Fixes <https://bugs.gnu.org/45895>.
>
> When the ~/.cache/guix/authentication is empty, this change allows
> authentication to start at the current commit, as shown by 'guix
> describe', instead of starting from the introductory commit, which would
> take more and more time (there's currently 18K commits per year).
>
> * guix/git-authenticate.scm (authenticate-repository): Add #:authentic-commits.
> [authenticated-commits]: Append it.
> * guix/channels.scm (authenticate-channel)[authentic-commits]: New
> variable. Pass it to 'authenticate-repository'.

Pushed as 29009fdb2d3636eafa77b406da2430b08a22d47e.

Ludo’.
Closed
?