[PATCH] gnu: Add goldendict.

  • Done
  • quality assurance status badge
Details
One participant
  • Sergey Trofimov
Owner
unassigned
Submitted by
Sergey Trofimov
Severity
normal
S
S
Sergey Trofimov wrote on 10 Jan 2021 14:20
(address . guix-patches@gnu.org)(name . Sergey Trofimov)(address . sarg@sarg.org.ru)
20210110132027.8113-1-sarg@sarg.org.ru
---
gnu/packages/dictionaries.scm | 57 +++++++++++++++++++++++++++++++++++
1 file changed, 57 insertions(+)

Toggle diff (67 lines)
diff --git a/gnu/packages/dictionaries.scm b/gnu/packages/dictionaries.scm
index b49e287313..537f2da607 100644
--- a/gnu/packages/dictionaries.scm
+++ b/gnu/packages/dictionaries.scm
@@ -449,3 +449,60 @@ intelligible and easily correctable.")
(description "sdcv is simple text-based utility for work with dictionaries
in StarDict's format.")
(license license:gpl2+)))
+
+(define-public goldendict
+ (package
+ (name "goldendict")
+ (version "2020-12-09")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/goldendict/goldendict.git")
+ (commit "261e45a5d79f9df2fbc050292410bed0f4ef3132")))
+
+ (sha256
+ (base32 "01pny06d4cmwf998hpqd7xx7mccbbasb8js1bv3rkdi1ljg01f7n"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'configure
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (invoke "qmake" "goldendict.pro"
+ "CONFIG+=no_epwing_support"
+ (string-append "QMAKE_LRELEASE="
+ (assoc-ref inputs "qttools")
+ "/bin/lrelease")
+ (string-append "PREFIX="
+ (assoc-ref outputs "out"))))))))
+
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (inputs
+ `(("libvorbis" ,libvorbis)
+ ("zlib" ,zlib)
+ ("hunspell" ,hunspell)
+ ("x11proto-record-x11" ,xproto)
+ ("libtiff" ,libtiff)
+ ("qtbase" ,qtbase)
+ ("qtmultimedia" ,qtmultimedia)
+ ("qtsvg" ,qtsvg)
+ ("qttools" ,qttools)
+ ("qtwebkit" ,qtwebkit)
+ ("qtwebview" ,qtwebview)
+ ("qtx11extras" ,qtx11extras)
+ ("libxtst" ,libxtst)
+ ("lzo" ,lzo)
+ ("bzip2" ,bzip2)
+ ("ao" ,ao)
+ ("ffmpeg" ,ffmpeg)))
+ (synopsis "A feature-rich dictionary lookup program")
+ (description
+ "GoldenDict is a feature-rich dictionary lookup program,
+supporting multiple dictionary formats (StarDict, Babylon, Lingvo, Dictd, AARD,
+MDict, SDict) and online dictionaries, featuring perfect article rendering with
+the complete markup, illustrations and other content retained, and allowing you
+to type in words without any accents or correct case.")
+ (home-page "http://goldendict.org/")
+ (license license:gpl3+)))
--
2.30.0
S
S
Sergey Trofimov wrote on 7 Jun 2021 22:19
Superseded by 48909
(address . 45766-close@debbugs.gnu.org)
87h7i9h1gh.fsf@sarg.org.ru
I completely forgot that I've already sent this patch and did it
again.
Anyway, this patch is missing use-module, so it should be revised.
?